Drone oscillation after take off

it is a 7kg drone with (kde direct 24.5 triple props x 4,185 kv motors, esc uas 75hvc, ubec uas 22+) mauch power system with sensor hub x2, 6s 8000mah battery x2, cube orange.
any suggestions’ on how i my rectify this. https://1drv.ms/u/s!ArXUOgQ8ysVSg680aKnVYyqi8CpcpA?e=nJh09K

MOT_PWM_TYPE,8 PWMRange PWMRange and PWMAngle are PWM special/rare cases for ESCs. Your motor graph does not look normal to me.

This UA is not tuned yet, you should not fly in smart_RTL. I would recommend you follow this guide. Have you flown Alt-hold or Loiter before? if after tuning, and find UA twitch in Loiter, you can try these Loiter values.

Your UA CubeOrangPlus is experiencing high vibration.

AHRS_GPS_USE,2, more parameters need to set is it?

Yeah, as Jai.GAY pointed out,
You need to atleast get your basic parameters set correctly before proceeding for any flights at all

MOT_PWM_TYPE should be set to 0
or any other protocol supported by manufacturer

I checked the specs for the esc, following protocols seems to be supported

  • PWM (50-600Hz)
  • OneShot(1000-2000µs)
  • PWMSync 500Hz
  • OneShot125

If using MOT_PWM_TYPE 0 (normal PWM), defaults MOT_PWM_MAX 1940 and MOT_PWM_MIN 1100 should be set and esc calibration is not required in that case.

And there is a ton of oscillations in Motor Outputs, this behaviour tends to heat up the motor a lot and may result in burning as well so you can touch the motors and check after each tuning flights

Vibrations in X and Y seems to be higher than Z, by any chance did you intermix the foldable blades which comes as a set ? I read on manufacturer’s website that the propellers are dynamically balanced and should not be intermixed between sets. X and Y vibrations are usually due to unbalanced/damaged propellers.

You could follow amilcarlucas’s guide, its perfect but might prove overwhelming for very new users, so i would suggest going through the ardupilot documentation.

thank you for the replies i will follow [amilcar lucas’s guide] Hi jai.gay and mind probe in respect to mot_pwm i thought i had set those, thay have been set now to 1100-1940 as i have done previously on other test flight, for the gps 2 I’m using gps 1 external hear3 do i still need to set gps 2?. as to props you are correct in your assumption,i do have brand new ones to use but because of the price of replacement cost for blades from kde oz dollars $ 1800.00 so hopefully you can understand. so why I’m getting oscillation and how can i fix this i appreciate all you comments thank you. when put new props on it will reduce vibration by 90% I know.o and for flight modes only stabilise

I think you may have understood wrongly. You set AHRS_GPS_USE,2, meaning asking CubeOrangeplus to reference Here3 as the height source outdoor, then you have to also set EK3 Z source as the document said. If you didn’t install a second GPS, no GPS setting for number 2.

Anyway, CubeOrangeplus comes with a barometer built-in. Can consider setting AHRS_GPS_USE to default first. After UA is tuned, to reasonable Alt-hold and loiter performance, you can consider changing it.

@MindProbe, thank you for your contributions.

yep :crazy_face: will set to that

what @MindProbe, described you must try to follow and mentioned here.

ok will do, took it for another test flight after resetting those new setting apart from the gps one there was very slight oscillation to begin with it seemed to rectify that problem but then it decided to do what it wants and consequently hit the main hi voltage wire and crash miner ish damage i will post that log :face_with_peeking_eye:



ahrs_gps-use,2 and ek3_src 1/2/3_ posz set to 3 :+1:,now to fix the drone look like all electrical components are working ok.

Can you post the .bin log file instead in the next post?

interestingly, you do not have RTL flight mode set, why does the log show RTL?
Can you set one to Stabilize, and the rest to AltHold?

also set LOG_FILE_DSRMROT,1 and BRD_BOOT_DELAY,5000.

the RCou motor graph does not look normal to me.

check the frame XY-CG is balanced. Improve the vibration, no wire/cable over the CubeOrangePlus, secure them. check screw tightness and propeller level. redo the first flight. if okay, do Test AltHold. note: While Alt Hold is rarely a problem unless the aircraft has a very low hover throttle. If you use a spring-back throttle stick RC, please get a friend to help you switch the flight mode. check with MP GUI to confirm that, and practice with the friend without arming.

the vibration of the UA is still there.

bin 86

when i set geo fence i set to rtl-land so when it breaches it will do but not the last time as in bin 86 it just decided to to its own thing when i tested it before on previous times it did why this happen i have no clue, that last flight f;;;ked all the props ( one leg motor mount plus battery mount plus one bent arm ) in brackets Iv fixed already :smiley: just got to set arm to same height on a jig i have made doesn’t take long got to be happy with that

do you think you may have misconfigured the ESC by accident? meaning, you are trying to calibrate the ESC instead you configure the ESC of other functions. My guess, I am not familiar with the ESC you are using.

24.5" propeller for a 7kg drone (including battery??) could be overpowered.

can consider setting FENCE_ACTION to Always LAND.
try reduce Pilot_ACCEL_Z and Pilot_speed_up and dn.
You do not need to fly so high for now.

i have kde app for this and how to set it works well and when new software is available you can up date in the same way i will check it if ok, when fence works it pretty accurate but as you mention the up and doun i do have a lot of problems with how can i set this Pilot_ACCEL_Z and Pilot_speed_up and dn. at the moment it is set to default 250, it just does the question is how much to reduce by
now you know why i set fence

I’m very impressed in you help it is very much appreciated thank you, it will be a couple of days before next flight

Reduce up and down by 50%, accel_z to 75cm/s/s

z was 250 now 75 up was 250 now 125 dawn is on 0 it suggest that if kept at 0 the up value will be used

1 Like