DJI Occusync and Pixhawk Telemetry Data Transmission solution - SOLVED

There is no doubt that DJI Video TX system is one of the best systems out there for high quality video transmission and when it comes to FC, Pixhawk is my champion.

I saw a video on YouTube where one guy tried to get DJI Occusync to work with Pixhawk using MAVLINK and using Telemetry port 1.

I tried to give it a shot but so far I am not seeing any OSD data.

Below is my wring diagram for PixHawk 2.4.8.

Do I have to do anything inside mission planner to get the data out?

Yes, I have SERIAL1_PROTOCOL set to 1. Are there any other parameters that requires adjustments?

SOLVED: Many thanks to Ian of MadRC

This is what you need to do and follow these steps as explained below and you will get it worked the first time.

A. Download DJI assistant 2 (make sure you download DJI Goggle RE assistant as there are many other versions) to your laptop and make sure you upgrade your DJI Goggle and Occusync to the latest release. If you don’t know how to do that, watch this video
Make sure DJI Occusync and the Goggle are linked. I am asuming you know how to do the linking procedure if not google it.

B. Learn to understand the wiring of DJI Occusync.

C. The wiring connection between either Pixhawk 2.4.8 or Cube etc. is shown above in the diagram.

Here is the verbal explanation of the wiring.

  1. One Lipo battery Powering the Pixhawk and Occucync.
  2. I am using Telemetry port 1 on the Pixhawk. telmetry 2 should work fine as well. make sure Telm 1 is set for Mavlink.
  3. Pixhawk Pin 2 (Tx) connects to Gray Wire on Occusync.
  4. Pixhawk Pin 3 (rx) connects to White wire on Occusync.
  5. Pixhawk Pin 6 (Gnd) connects to Brown Wire on Occusync.

Do not connect the yellow wire to anything as its the S-Bus wire.

Power up Pixhawk and Occusync. Power your Goggle and you should see something like this.

At this point Occusync only provides limited telemetry data picked up from the Pixhawk.

1 Like

I did not see this question on the video till now. Sadly YT does not always show every reply at times to me.

This was working fine as per my video as it was added on firmware

I will update everything to latest release and test this again today.

Thank you. I have gone nuts trying this to work and its not working.

I contacted DJI as I buy a lot of their products. They are clearly refusing to provide any support and will not either confirm or deny if Occysnc supports MAVLINK or not.

Also they are refusing to explain what protocols DJI OCCSYNC supports which is kind of strange. I think Occusync is great product and they are missing out on millions of dollars of additional sale by refusing to co-operate…

Ok I have checked this all again tonight and it’s still working for me on latest firmware.

So we have Cube Black on serial 1 Mavlink, Air unit connected to serial 1 with White wire to MCU TX and Grey wire MCU RX, brown to GND.

Make sure then you are powering the air unit separate from the controller as well.

I just tested with Pixhawk Cube and still no telemetry.

Can you upload your parameter file here.

In your picture above, you are powering Occusync with Lipo balance lead wires??? That’s only 3.7 Volts. Very confusing how is it even powering up on such a low voltage.

My wiring is as follows:

  1. One Lipo Powering both PixHawk and Occucync.

  2. I am using the following Occusync version as shown in pic

  3. Using Telemetry port 1.

  4. Using

          a) Pin 2 (Tx) - Gray wire on Occusync. You said you connect to white wire here. Why? Gray Wire on Occusync is the RX.
          b) Pin 3 (Rx) - White wire on Occusync. You said you connected Gray wire here. Why? White Wire on Occusync is the TX.

I tried swapping both wires. No difference. See Occusync pining diagram below showing which pin is what.

c) Pin 6 (GND) - To Brown wire on Occusync.

I even tried using a separate battery for Occusync make no difference.

I have never been so frustrated in my life :slight_smile:

Far right pin on telemetry Port is Pin 1 right?

Also, I am looking at the Goggle Inside View pic you uploaded. It looks totally different then mine.

You are using DJI racing Goggle RE right?


Yes this is all the RE system.

Please can you post a screen shot of your screen as that’s odd but its sounds like your not actually fully updated, If you look you have a minus sign after the version numbers in the top corner, that means one part of the system is not fully updated. This is standard DJI practice to show a mismatch.

Just to confirm you have updated both your goggles and air unit to latest firmware ? That picture suggests your not on the latest as it should say refresh’s not update ?

You need all parts to be on at lease v1.0.5.0 or ant firmware onward, DJI added it on that release. if you not seeing the ladders or the additional info then a part of your system is not un to date

On Prams for Ardu these are totally stock as no changes are needed to the serial port 1 to work, you can flash and use.

As for the battery that fully voltage if you look at the pins I’m on :wink:

I am also on the latest firmware with all parts of the system but also downgraded to test as well.

I would suggest re flashing every part of the system, goggles have to be done then Air unit with the camera connected separate.

What you should be seeing is this

I FINALLY GOT IT TO WORK!!! :slight_smile:

The culprit was that I didnt have the latest DJI firmware.

So still no Lat and long data as you can see in the pic. I sent an email to DJI but offcourse they are refusing to support MAVLINK altogether.

I think we all should send emails to DJI and bug them to support full MAVLINK decoding. I am surprise they don’t want to do that. Their DJI FPV Goggle which is supporting Beta flight, provides complete OSD. So, not sure why they want to miss out on large scale commercial drones using DJI OccuSync as DJI a video transmission solution. I guess they want to push DJI commercial drone sale agenda. Its all about money and maintaining the monopoly.

Lat and long does not work correctly with Mavlink in my experience.

These are pretty much EOL now from a development point of view, these don’t have anything near the support the new FPV goggles have. They dont have Mavlink support at all but you can convert it with an Arduino.

These were a pet project more than anything for them, I was one of the original beta testers for this system and I fed back a LOT if requests but it did not happen sadly. Trust me it took a lot to get Mavlink support at all :wink:

Who is the head of DJI development. I will bug the hell out of him or tell him I will develop a competitive product same as Occusync…lol :slight_smile:

Adding an Arduino or any comp is really not a clean or viable solution just to get telemetry data out.

So what is DJI protocol based on?

Its MSP based on the same as Betaflight.

what is MSP? Sorry not familiar with it.

Multiwii Serial Protocol V1.41 I believe off the top of my head. It should work with V2 as well as that’s what Inav uses.

So one easy solution world be is to have FC such as Pixhawk/MP to adopt to support MSP? if just a software change the just MP alone…right?

Easy to deal with that then trying to convince DJI corporate bureaucratic company?

My over all goal is to create a harmony between Ardupilot and DJI :slight_smile: :slight_smile: Its like an ORGY of UAV systems in my opinion…lol

DJI email response

Dear Asim,

Thanks for your reply.

I really appreciate your support to DJI. I will pass on your suggestions to our Filed Application Engineering team for further review. Hope they may evaluate this suggestion and make it into reality in future updates.

If you have any further questions, please feel free to contact us. We are always here to help.

We would like to remind you that during the period of outbreak prevention and control, please avoid visiting areas where the disease is prevalent, and also avoid crowds. Please wear a mask when going out, and keep your hands sanitized by washing and disinfecting them frequently. We will defeat this disease!

Best regards,
DJI Technical Support

Trust me I was on the beta team and fed back into the dev team directly on both both systems and they know what people want, I told them more than once my self. Mavlink is not priority as sales form Mavlink users are tiny. It took a lot to get it to the first system.

Betaflight and racing drones is where the volume is and that’s why it’s supporting MSP.

Having MSP support in Ardupilot would be ideal but with Mavlink being priory that’s again unlikely to happen. Currently INav and Betaflight use MSP but they are different versions and not compatible with each other, Ardupilot is using Mavlink and controllers like The Vector have their own. Sadly there are a few too many systems in the mix at the moment.

How much funding would be needed to have Mission Planner support MSP?

iI I fund it, do I get copyrights? :slight_smile:

There’s actually a very limited MSP implementation already, as the blheli esc’s use it for setup. But I think the easiest path to a useable implementation would be an onboard lua script to translate from either mavlink or one of the rc telemetry protocols (frsky, hott, etc).

1 Like


I like your thought process. Who do we got to make this happen? I would be interested in even hiring someone to do this for me.

I started a dialogue on this topic with Ardu team but someone close my thread not sure why.