Crash! Drone went up without control, passthrough FrSky telemetry bug?

Hello guys!
Today I had a crash with a new quadcopter that I am building, when I took off in Loiter the drone became to go up withouth control althought the throttle was at minimum! Then I switched to stabilize but it only went down when I practically put the throttle at minimum. The only thing I could do was lower the throttle at minimum until the quadcopter hit the ground. I have other drones with the same specs and the only difference is the passthrough FrSky telemetry with a MAX3232 which I have configurated for this drone to avoid the use of a Teensy, as in the others that I have.

My quadcopter setup:
Motor: T-Motor u7 420kv
ESC: Hobbywing x-rotor 40A
Props: 15x5.5
Battery: 6S 16000mAh
FC: The Cube black Pixhawk 2.1
Version of arducopter: 3.6.11

I really appreciate your help.

Here you have the log

00000007.BIN (572 KB)

Update: I don’t understand what is happening here, the PWM of the four motors oscilate when I armed the drone and still landed… later when the drone took off, the PWM oscillations became bigger, the desired altitude began to rise althought the throtthle was at middle or lower.

First up, you need to upgrade to 3.6.12 at least , and change this parameter:


Make sure you use the latest MissionPlanner or QGroundControl, they will warn if there’s a problem with that Black Cube.

It looks like you’ve got a lot of default values, That’s a large craft and those values don’t suit. Initially use these for your prop and battery size:

ATC_INPUT_TC,0.22 (RC Feel)

You can copy/paste these into notepad and SaveAs {something}.param and use MissionPlanner to load them without making mistakes or wasting an hour trying to find them all.

A couple are just my suggestions or preferences, but most are calculated from the Tuning Guide

I highly recommend you do the Compass/Motor calibration, and follow the instructions precisely or it can be very dangerous.

OK, once you’ve got all that done, just do some basic hovering and slight movements around in Stabilize mode and try AltHold mode if Stabilize is OK. Hover throttle will be relearning during this.
Fly for at least a couple of minutes.
Check logs again for any problems, and find your most recent hover throttle values in the log.

After that, set these:
PSC_ACCZ_I, {2x hover throttle value}
PSC_ACCZ_P, {1x hover throttle value}
Set Autotune to do one axis at a time

Check for good GPS lock, it’s one of the pre-arm settings anyway, takeoff in Stab or Alt and then test Loiter - be ready to switch back to Stabilize or AltHold if anything goes wrong.
If all is going well, switch to Autotune - you need a large open area and no wind.
When Autotune finishes just manually return to launch and land WITHOUT changing modes and disarm. This is the easiest way to complete an autotune.

After you’ve done all 3 axis you should be in a much better place with a nice flyable craft.
To get more out of Autotune a second time around, try this:

Thank you very much for your answer. I will change the version when I rebuild the drone, and I will follow your instructions step by step.

I know that the drone wasn’t tuned with those optimal parameters in that first flight, I only wanted to test that the drone could fly.

When I know that the drone “works” I begin to change parameters little by little to tune it correctly, I have parameters very similar to yours, so I will test them to see if they are better :wink:

The only problem is that I don’t really know what have happened with the pwm of the motors and why the desired altitude raised without control. Maybe is there some kind of bug in that version?

So thank you very much for all, I will rebuild the drone and I will test the last version 4.0.3, I will keep you updated.