Copter not switching to GUIDED_NOGPS


I was trying to to set up the MAVProxy and Mission Planner with the Pixhawk and am really interested in testing out the GUIDED_NOGPS mode.
I have a companion computer(Raspberry Pi) connected to the Pixhawk and I ssh into the RPi and start the mavproxy commands.
When try to send the mode change request from the terminal it says that no such mode exists and that the mode is unsupported.

Can anybody please help me with the same as I am really new to this. Thanks

Please update your mavprovy and your ArduCopter to 4.1.3

I just tried this and it works.
MAVProxy Version: 1.8.46
AP: ArduCopter V4.2.0-dev

Yes, I expect that:
MAVProxy Version: 1.8.46
ArduCopter V4.1.3

Are enough

1 Like

baudrate of 9600 is probably too slow for proper GUIDED operation, you might want to increase that.

Thank you for your reply, but I already have updated both of those to 4.1.3 and 1.8.46

Yeah also I noticed that the version of Arducopter is still 4.0.6 even though I updated the firmware I will try that again

Even after changing the baudrate and updating the ArduCopter to V4.1.3 from V4.0.6 it still gives me the same error

The issue is not on the ArduCopter FW version, but it does help a lot to use the latest stable.

The issue is on mavproxy.

  1. How sure are you that you do not have multiple mavproxy versions installed? And are using the latest one and not an older one?
  2. Which board are you using?
  3. does it have 2MiB?
  4. How sure are you that GUIDED mode has not been compiled out?

I had installed MAVProxy for the first time on the machine I am using at v1.8.46 also ran the update command for the same.
I am using a Pixhawk PX4
I am not sure about the space
It changes to guided mode but I am not sure about that as well

I downgraded from v4.1.3 to 4.1.1 and it switched modes to GUIDED_NOGPS but I am unable to takeoff
The issue was also there in v4.1.3 in STABILIZE mode whenever I give the command for take off it says takeoff started and then and error message is displayed stating the TAKEOFF Failed

I use 4.1.3 in GUIDED flight mode (more demanding than GUIDED_NOGPS) and do automated takeoffs on a daily basis. It does work. No need to downgrade the FW.

I also tested it in SITL, there it also works fine. Please provide more details so that we find out what are you doing differently from the rest of us

So I am using a Pixhawk PX4 board with a Raspberry Pi as the companion computer with MAVProxy installed on it. I ssh into the Raspberry and send commands to the PX4.
ArduCopter V4.1.1 MAVProxy V1.8.46
The rotors are not attached yet and we are trying to test it inside a lab.

First off, there is no “Pixhawk PX4”.
Pixhawk is an Hardware.
PX4 is a firmware, and that FW is different from ArduCopter. You say that you are using ArduCopter, so no PX4.

Do you mean “Pixhawk4”?

It’s a Pixhawk not Pixhawk 4 and yeah FW is Copter not PX4 sorry for the confusion

Does your Pixhawk have 1MiB or does it have 2MiB ?
Some features are not included in the 1MiB Firmware versions.

If it is a Pixhawk, why are you using fmuv2 and not pixhawk1 FW Type?


Yeah I have gone through bot of the links also I opened up the pixhawk and saw the processor its a Rev3 so I don’t think that’s the issue

This is what I get everytime I try to take off