Copter lands when Alt Hold selected

Hi all. I have a Tarot 680 Hexacopter with a Pixhawk 4 controller (3.6.9 firmware) that was flying well. It was well tuned and I had flown several 1km mapping missions with it. Then, out of the blue it started doing a controlled landing every time I selected Alt Hold mode??. I checked all parameters, redid all calibrations with the same result. I reloaded the firmware(loaded rover then reloaded 3.6.9)…reloaded my saved parameters,redid all calibrations with the same result. I upgraded the firmware to 3.6.10, repeated all with same result. I would really appreciate some help on this…I don’t have much hair left!!! lol Jim

Here is a Log:!Ap2jaX-B23TGjhuxTyf5XxZ9AmJV

Throttle position? When I observed this it was because my throttle stick was below 50% when I switched to alt or poshold.

Your throttle is at 1100 when switched to alt-hold no surprise it lands.
Hover throttle in stabilize is not necessary the same as hoover throttle in alt-hold.

Thanks for the observations. I looked at previous logs of when it behaved properly and saw that the throttle did NOT drop when switching to AltHld mode. The question still remains…Why does the throttle position now drop when in AltHld mode?? Physically on the transmitter the throttle is still about mid position??? Tx Jim

Are you sure, throttle output is not middle, your RC3 is configured 980-2000 range, and you fly in stab mode around 1100.
You will hover at 1500 not 1100.
Your throttle did not change when switch to althold, it stays at around 1100. I think it is you who lower it when copter is landed…

Remove all trims and expo from your throttle. make sure center position is 1500.

1 Like

Thanks Andras, you got my brain cells working. I checked the RC3 parameters and found the Trim set at 1500. I have reduced it to the low setting and recalibrated everything. Also checked no trims, subtrims or expo on throttle…Let you know what happens…Jim
PS how do you produce the graph that was attached???

He is using APM Planner 2 - its a lesser-used GCS, but makes very clean graphs.

1 Like

Well, now I really am stuck. I checked the channel3 range of my Taranis …980 to 2006…physical center of the stick was about 50%. I recalibrated the transmitter to the pixhawk4 to the same range. When flying The RC3 signal still remains at abt 1100 and when I switch from stabilize to alt hold it just lands. When I fly the sticks physical position is about 50% so the RC3 signal should be about 1500…BUT it isn’t. Anybody out there have any suggestions?? I’m about to rip out the Pixhawk 4 and replace it…Tx

You said you calibrated several times.
What were you using to calibrate?
Mission Planner?
Is the throttle graph responding with the right values in the Radio Calibration graph if you are using MP?

You said you checked the Tx output on Ch3.
How did you do that?
Are you using the servo out monitor function in the Tx?
With the throttle stick in the middle is the servo monitor showing 50% if you are using servo monitor?
If you plug a servo into Ch3 on the Rx is the servo in the middle?
Does it respond equally each way?

As @Eosbandi pointed out, the Pixhawk is seeing 1100 on that channel, so I would start looking and verifying the Tx and Rx outputs.
Especially any mixes EPA’s in place.

Have you checked the servo out parameters in the Pixhawk?
Using full parameter list are they all the right value?

Some answers to Mikes questions…
Am using Taranis+. On Mission Planner monitoring screen ch3 output goes from throttle stick min ,-100 to throttle stick max at +100. On the Taranis output screen, low of 988 to hi 2012. Throttle mid is 1500. I plugged a servo in ch3 on the Rx(L9R). It centred properly with the Tx stick centered. It rotated equally in both directions. I believe the Taranis is outputting properly to the Pixhawk4. On the Pixhawk radio calibration screen the signal goes from low 982 to hi 2005. Mid is 1494 with the Taranis stick at 1500. It looks like the Pixhawk4 is seeing the correct signals.(Holybro Pixhawk4 with AC v3.6.10)

RC3 settings are , DZ 30, MAX 2004, MIN 982, RC3 REV 0, TRIM 982.

Im stumped,it should work…??? Is the RC3 TRIM setting correct? I have tried 1500 but it doesnt change anything.

Did you checked flight modes ? Tried the calibration screen with different states of the mode switch on your Taranis ?

Perhaps you need to calibrate your radio, can you confirm that all channels (1-4) are showing correctly (1500 in middle) in the radio’s output screen?

Still grounded. Checked the Taranis radio calibration screen with different flight modes and responses where normal. 1500 at center , ~900 low and ~2000 high.
I reloaded the firmware (loaded rover then loaded copter 3.9.10.
Redid ALL calibrations, accels, compass, radio, ESC’s, checked flight modes.
Still same, flies great in stabilize but when I switch to ALT HLD, the RCIN C3 setting changes to ~1100 and the copter lands. First time in using the APM controllers (from the inception) that I haven’t been able to solve a problem. Any other suggestions out there???

Sounds like you’ve got flight modes or mixer set up in your Taranis, affecting that channel.
Clear any and all flight modes and mixers in the Taranis.
It’s RC outputs should go direct to the flight controller (via the Rx of course).
Set up one 3 position switch for Stabilise, Alt Hold and Loiter - something like that.
Set another 2 position switch for RTL

In the Taranis decide on your channels for their use, for example Ch5 = flight modes, Ch7 = RTL
Ensure you can get them working and the PWMs change as expected in MissionPlanner in the RC Calibration page - then set the correct paramaters for the selected flight modes and RTL.

Well, the saga continues. As Shawn suggested, I created a new model (no trims subtrims mixes nothing) on my Taranis and set up a mode switch with Stabilize,AltHld and Loiter. I calibrated the radio in Mission Planner and calibrated the ESC’s. Same bad results. The motor RC outs are ~ 1480, the RC3 in is~1150 and it keeps landing when I switch to AltHld. Any other ideas?? Thanks to all who have been thinking about this. I looked at logs of this Hexa flying in the spring and RC3 IN is about 1500 and does not change when switching to AltHld. Wonder what happened?.
Here is the latest short flight in my backyard:

The last resort is to trying eliminate the culprit by replacing the possible faulty or missconfigured parts. I would start with the RC receiver. Are you using SBUS or CPPM ?

A noob suggestion. & Ignore this
1)check parameter for ALTHOLD in full parameter list.
2)Remove Props, select ALTHOLD MODE, ARM, & raise throttle. How does it respond.?

What are your MOT_THRST_HOVER and MOT_THRST_LEARN values?

It looks like your log does not have any relevant CTUN/ThH values which the FC uses to hover. It appears to be pegged at “1” for the duration of the log in the OP. (Whats even weirder is that it displays at a value of 0.5 on the y-axis scale, but the MIN/MAX/AVG at the top of the mission planner graph all show “1”)

These parameters are not used in stabilize, but are used in alt-hold modes.

See here for more info:

Edit: You can set MOT_THRST_HOVER manually if desired. To do this, you would fly in stabilize and review the log. Particularly CTUN/ThO. You would take the average hover value and copy that into MOT_THRST_HOVER parameter. However, the documentation shows the typical values to be 0.2-0.8. It looks like the log in OP has a hover value of ~0.15 as best I can tell. This would lead me to believe that you have an over powered copter. This theory is supported by the RCOU logs - it looks like you’re hovering a bit low @1300.

eklip you were right on. I checked the MOT_THST_HOVER and it was ~0.59 and CTUN.TH0 was ~0.18 when the hex was hovering. MOT_THRST_LEARN WAS 2. I changed MOT_THST_HOVER to 0.4 and did a backyard test flight. I hovered carefully in stabilize for several minutes then tried AltHld…it worked. I checked MOT_THST_HOVER and it was 0.27. It had auto reduced from .4 to .27. …like it is supposed to.
What I don’t understand it why it didn’t correct when it was 0.59
Thanks to all who contributed. The different points get the brain cells working. Thats what these forums are about…Happy in Port Elgin

Great! Im glad it is flying well. I suspect you are a little overpowered with a MOT_THRST_HOVER of 0.27, but that might be OK as long as you feel like you have a good amount of overhead control in all directions. (Obviously we want to make sure the copter can come back down, too!)

Dont forget to mark the solution so others can learn from this as well.