Copter GPS speed varies depending on take off method!?

Hi, we are facing an issue here!

During some test flights, we noticed that the copter (42kg octa), flew very slowly and with less accuracy, but sometimes it flew just fine.
we’re getting 3ddgps often… 3d fix sometimes…

Arducopter 4.0.7 , nav_speed = 3m/s

If take off in LOITER and then switch to AUTO >> Bad behavior, low navigation speed (~1.5m/s).

If take off in GUIDED mode and then switch to AUTO >> Bad behavior, low navigation speed (~1.5m/s).

If take off directly in AUTO >> GOOD behavior, good navigation speed (~3m/s)


Does anyone know what might be happening?

Thanks in advance!


We have had a very similar problem, guided speed was st to 6 m/s but the copter was stuck at 2 m/s in auto mode no matter what we tried. The only thing that worked was to use a not round number on wpnav. If we set wpnav to 6.1 m/s than everything works correctly each time. We still do not understand what is the problem.
Try using 3.1 m/s and see if it fixes your prob.

1 Like

Thanks for sharing your exeprience! We’ll try to do that.
I’ll post how it went then.

Same prob:

1 Like

Well, as @Corrado_Steri said…

Changing WPNAV_SPEED from 3m/seg to 3.1 m/seg SOLVED THE PROBLEM!!!
*Note: wpnav_speed is ment to be set in cm/seg

…there’s something about round numbers that is making wayponits navigation go slower…
And there’s also something about the way you take off as I said before…

Takeoff secuenses (with wpnav_speed=3m/seg) :

Take off in loiter, hover and then switch to auto mode >> wrong navigation speed (slower)

Take off in guided, hover and then switch to auto mode >> wrong navigation speed (slower)

Arm in loiter, switch to auto, 50% thottle to begin the mission >> correct navigation speed!

It is not the takeoff that makes the difference but is entering in guided mode that has something wrong.

I wrote about it 6 months ago but went pretty much unnoticed, probably not many people use guided :slight_smile:

@tridge maybe is worth have a look at it.

1 Like

Guess it is of no inteest, oh well :slight_smile:

Did you open a github issue? did you attached logs to it?

@amilcarlucas no … I’ve never done that before. A log is linked in the first post here

I wrote about the problem once it was released in beta test, if i recall well it was first seen on 4.0.3.
Ultimately i brought up a problem, if you don’t need this kind of feed back, it is fine with me and will not do in future :slight_smile:


Is beta done to receive feedback or to open github probs? Just to know.
I was wrong, problem is older and was already there in 3.6

Here a discussion with logs, i think it was ignored.

I solved the problem by not using round number in rtl or navigation speed. In my copter whenever i use 6m/s than speed doesn’t get past 2m/s. Any other number such as 6.1 m/s or 5.9 m/s works as expected.
I think the fact itself that it doesn’t work with round numbers should give an indication of where to look.

Would like to know what you think about it.

The forum is for support. Users ask questions and users answer questions. Its a huge community, with lots of knowledgeable friendly users. One or the other developer might also help, but do you want developers to use their limited time supporting users? Or do you want them to fix bugs and develop features?

Bugs are to be reported to github, so that they can get prioritized and not forgotten inside some forum thread. We do try to use the best tool for the job, and a forum is not a good tool for bug tracking. Github issue tracking is built for that and is much better at it.

@Corrado_Steri any other questions?

Ok, so i guess there is no point in publish beta here and ask for feedback here.

@amilcarlucas shouldn’t all release and report be done on github?

P.s. there is a problem with navigation speed, not considering it because it is reported here and not on github, it is ok with me, have a good day.

Feedback is welcome here, in the forum, but once it is determined to be a bug, it should be reported in the proper place.

This is not hard to understand, or is it?

Ok, at least. Developer admitted it is a bug, now i guess we can open a github issue.

Was waiting for a skilled person to certify it as a bug so i can move on to github.

P.s. kind of hard to understand, very low iq on my side :slight_smile: