Copter Falls From Sky after Mission Start Action Excuted

Hello all,

I have been recently attempting to enable an autonomous mission. I have tried multiple times using the auto mode using my controller with no success.

I then proceeded to use the Mission Start Action in APM Planner. This seemingly worked, however once the aircraft had briefly climbed, it suddenly fell from the sky! I’m not entirely sure how this happened. I inspected the copter afterwards and there were no apparent mechanical malfunctions. I included the logs from the flight.

apmlog_20170829.txt (132.0 KB)


Hi Michael.

I flown loads of missions using a transmitter and it’s normally easy.We’ll need a .bin log if possible.Mission Planner didn’t like the text log posted and I’m not sure which bit of logging it is either.I guess it’s from APM Planner2.

Okay, here is the .bin file.

17-08-27_16-28-26.bin (226.2 KB)

Well,I’ve had a scan through there and can’t see anything.It didn’t go into auto at any time though which I think it needs to do to perform a mission.This will probably need someone to go a bit deeper into it.

When I perform a mission with the handset all I do is arm the motors and then switch to auto mode and raise the throttle.And off she goes.Always.Sometimes not where I’m expecting but that’s pure pilot error normally

Does this copter fly ok manually ?

Are you sure that’s the right file? There’s only a few seconds data in there and it looks very wrong. None of the commanded or intended actions actually occur, almost like it’s held in place.

@Jagger The copter flys okay. Its responsive to manual input and is stable. The log that I posted, I did not use auto mode. In APM planner I selected Mission start and clicked execute action.

The copter is not connected in the image below.

Good.That’s info that can be used.Problem being I’ve no experience with APM Planner 2 in the last three years and don’t run missions with Misssion Planner either barring the uploading part.I do it all with the handset so far.I still think it should switch to auto mode to run a mission.

Can you address fnoops’ concern about the file ? (is it the right one ?)

@Jagger @fnoop Thats the incorrect file! Totally my bad! Thanks for pointing that out @fnoop.

The correct file is above.

That’s better.At least it has an auto mode change.It looks like it did the first command (take off) and then went back into stabilize with the throttle down.Only one way it’s going after that.Everything else is the crash.

As to how and why I’ll have to leave it to someone with experience of APM Planner I think,or at least running missions from the GC.That’s something I haven’t bothered to do yet.

@Jagger Yes correct. @Michael_Letterio I don’t know what mechanism apm_planner2 uses for the mission (would have expected it to be guided or auto), but for sure it instead puts it into stabilize mode with effectively all the RC channels at default (midpoint and no throttle), so gravity took over.

ie. The firmware itself behaved exactly as expected, its the GCS/user fault for telling it to do something very wrong :slight_smile:

Hope you didn’t have too much damage.

Thanks @Jagger, I have not been able to use the controller to enable a mission using Auto mode as of now. For now I can only use GC, I have to look at logs from when I attempt auto mode from the controller.

@fnoop Thankfully there wasn’t too much damage, the landing legs took most of the damage.

All I do is upload the mission,arm the motors,switch into auto,then raise the throttle.Occasionally I’ll manually take off and go to position hold then switch into auto.Works every time,although my big Tarot set off for Devon last time I switched that.I forgot to upload the local test mission I wanted.

I take it you’re on apple stuff if you’re using APM Planner then ?