Copter-4.4.1 released!

Copter-4.4.1 has been released as the official version for multicopters and traditional helicopters. The changes vs 4.4.0 are in the ReleaseNotes and copied below.

  1. Autopilot related enhancements
    • H750 external flash optimisations for to lower CPU load
    • MambaF405Mini fixes to match manufacturer’s recommended wiring
    • RADIX2 HD support
    • YJUAV_A6SE support
  2. Bug fixes
    • Airbotf4 features minimised to build for 4.4
    • ChibiOS clock fix for 480Mhz H7 boards (affected FDCAN)
    • RPI hardware version check fix

Special thanks to our beta testers and those devs who contributed to this release!


Hi @rmackay9,

I just updated from a 4.4.0 dev version to 4.4.1. @Leonardthall added the “TKOFF_TH_MAX” feature/parameter which in the release notes said it was added in Copter 4.4.0-beta1 19-Apr-2023. After upgrading to 4.4.1 this parameter seems to be missing? I’ve taken a deep look (to see if it was renamed) but can’t seem to find it. This parameter is critical to our operations. Any idea what’s happened?


Hi @DroneUnit,

You’re right, we’ve got a mistake in our release notes. TKOFF_THR_MAX did not make it into Copter-4.4.

Re it being in 4.4.0-dev, there are sometimes a few weeks after we start beta testing before we rename the 4.4.0-dev to 4.5.0-dev so it is possible it slipped into this window.

Sorry about the confusion. The TKOFF_THR_MAX is included in 4.5.0.

Okay, thank you.


I am just curious from the release note, 4.4.0-beta1 it states changes from 4.3.6. We know there are some fixes that result in 4.3.7 and 4.3.8.

So, my question is are these 4.3.7 and 4.3.8 changes also found inside 4.4.x version? for example, EKF3 accel bias calculations bug fix in 4.3.7.

1 Like

Yes all fixes up-to 4.3.8 are included in 4.4.1

1 Like

you forgot to mention this important fix for Skystars H7 users:

AP_HAL_ChibiOS: change incorrect I2C internal mask from SkystarsH7HD …

without compass there is no arducoptering :slight_smile:

After updating to latest stable version I’ve noticed a “compass parameter missing” pops up in QGC after about one minute.
Is this an outdated file issue (APM-Firmware file within QGC) affecting all Copter 4.4.1 or ist it linked to me using a Pixhawk 6x with second compass/GPS combo ?
(Happens in QGC stable 4.2.8 and daily version)

Hi all,
facing a problem with version 4.4.1… Actually we are using GSF… So while tested with arducopter version 4.3.8 GSF activated properly… Then it was easily switched to Loiter mode… bbut while using version 4.4.1 with same parameters , there was a problem showing Gyro Inconsistent, so GSF could not be activated, failed to switch Loiter also… Please help…

Hi @RohitMahajan1992,

Thanks for the report. I think this known issue may be related but I would like to see a log file if you can provide one.

Thanks for the response. Here is the link of the log, please find…

hello sir @rmackay9 anything in the log? Eager to know…

@rmackay9 sir, GSF activated at a speed around 5 m/sec… Is there any way to reduce this speed for activating the GSF? kindly help.

Here you refer to a parameter GPS_VEL_YAW_ALIGN_MIN_SPD , but I have not found any parameter named this…

Thanks in Advance…

Hi @RohitMahajan1992,

Sorry for the slow response on this. I’ve created a custom Copter-4.4.3 binary for the CubeOrange here that reduces the minimum velocity for GSF to 2m/s for Copters. Could you give this a try to see if it is sufficient? This change has not gone through beta testing (nor has it even been merged to master/latest) so please be careful although I think it should be completely safe.

We could theoretically make this speed a parameter but I slightly worry that people would just set it to zero because they simply want GSF to work at as low a speed as possible and this would just lead to more problems.

@rmackay9 Thank you Sir. I have tested for two times, seems like working absolutely fine till now… Any issues in future will update here.
But there were lots of problem faced from last two years (like sudden jerk, radio failsafe issues)if I am not updating the firmware version at right time. this version is 4.4.3. To avoid such scenario I have to update the latest firmware version. So for next the update also I want this GSF configuration (2 m/sec). How can we achieve this in the latest updated version available in future?

@rmackay9 Please, my sistem: NAVIO+ quadcopter, firmware 4.0.3 is working perfect, i have flashed another SD card on the latest 4.4.1 everything works but it doesnt see my PPM receiver. Same wiring, same harware just swapping SD card to 4.0.3 my receiver kick in again on radio page. Any advise? Or 4.0.3 is the last firmware that works on my Navio+? I appreciate your attention.

Hi @dsmoura777,

Thanks for the report, I’ve added it to the 4.4 issues list. I suspect you’ve found a real bug.

Would it be possible for you to temporarily try 4.5 on the Navio+? This can be installed using Mission Planner’s Firmware Install screen, just press Ctrl-Q and the labels should change to 4.5.0-DEV. This is helpful to know whether we’ve fixed the problem already (although I suspect we haven’t).

FYI @williangalvani

Great @rmackay9 , i will update it to 4.5 and see how it works. I guess i need to use your guide to upgrade my NAVIO+ as MP wont do it am i right? I will let you know!

I just did it, same results, no RC input

1 Like