Copter-4.1.0-rc1 released for beta testing

WARNING: numerous reports of telemetry connection issues have been reported with this release. -rc2 will be released within the next 48 hrs with a fix so we recommend waiting for -rc2

Copter-4.1.0-rc1 has been released for beta testing and can be downloaded from the ground stations (MP, QGC) using their beta firmwares links.

The changes vs -beta8 are in the release notes and copied below

  1. Enhancements
    a) Log download speeds improved on F765 and F777 based boards (USB buffers increased)
    b) Serial port DMA contention heuristics improved (reduces chance of delays writing to serial devices)
    c) WPNAV_SPEED param changes take immediate effect in Auto
  2. Bug Fixes
    a) Airmode fix if throttle held at zero for long time
    b) Auto mode SCurve jerk time calculation fix (prevents jerk from being set too high)
    c) CRSF frame timeout increased to reduce RC failsafes
    d) Declination automatic lookup rounding fix (caused inaccurate declination in some parts of world)
    e) DShot (bi-directional) support on Pixhawk4, CUAVv5, CUAVv5-Nano
    f) IMU semaphore fix to avoid occasional corruption
    g) QioTek Zealot F427 GPIO pin fix
    h) Replay/DAL RMGH log message format fix
    i) Rangefinder initial buffer size and baudrate fix (affected Aintein US-D1 radar)
    j) Surface tracking fix to reduce lag and overshoot
    k) WPNAV_SPEED change with ch6 tuning knob feature gets divide-by-zero protection
    l) WPNAV_SPEED_DN handles negative values

We still have some items on the 4.1.0 issues list but no blockers so I think we are very close to the stable release of 4.1.0. Any and all testing and feedback is very much appreciated!

In particular I would appreciate hearing from users of airmode and surface tracking. I just want to be sure that these features are working OK.

Thanks again for all your help with the beta testing!



There seem to be some resolved issues that are marked as “resolved for beta9”. Would this release be considered as beta9?

After updating from beta 8 to rc1, Herelink (connected to Telem1) is not able to connect to the flightcontroller anymore. Neither the Solex app can connect nor a passthrough via UDP / UDPCl to Mission Planner works anymore. Half an hour before, I was connected through Herelink so I know that it was working right before the update from beta8 to rc1.

Mission planner (when using the UDP passthrough from herelink) seems to be able to detect the heart beat message, but when trying to read the parameters, it stays endless in the parameter reading pop-up.

Connection through USB still works.

I had exactly the same problem, although it occured with beta 8 at some point. I have posted it already on Cubepilot (one of the last replies), not sure if it is related to the recent herelink firmware


Yes, that’s right. this “-rc1” would have been “-beta9” but we decided to call it “-rc1” because we think it could potentially be released as the stable version.

1 Like

SIK Radio telemetry on SERIAL1 does not work any more.
Worked again after downgrading to beta8.
It is a Matek H743-Slim board.

Other serial connections GPS, TFmini, FPort are all working.


@Samu I am not using the latest Herelink firmware (still on the first “stable” firmware of last year). So it must be related to the -rc1

Same issue with SIK radio on Serial1, it doesn’t transmit data in -rc1, but -beta8 is ok.

can you please try setting BRD_SER1_RTSCTS to 0 (it is probably set to 2) and see if that fixes it. If it does then we know the issue is RTSCTS.

That fixed my telemetry!

ok, thanks for testing. Was BRD_SER1_RTSCTS set to 2 when it failed? If so that tells us it is the RTSCTS auto-detect.
The strange thing is that nothing should have changed in that code between beta8 and rc1. Are you absolutely sure it worked with beta8 with BRD_SER1_RTSCTS=2 ?

Yes. I did load a saved parameter file trying to rcover my telemetry but that did not work.

BRD_SER1_RTSCTS was 2 on both -beta8 and -rc1
Worked with BRD_SER1_RTSCTS = 2 on -beta8
Works now with BRD_SER1_RTSCTS = 0 on -rc1.

btw. with “rover-4.1.0-rc2” it is working with BRD_SER1_RTSCTS = 2 (Matek H743-Mini, MAVESP8266 with 230kBit). So I suppose it must be a special copter-thing?

Hi all, @tridge @rmackay9
I just updated to 4.1.0 rc1 and had connectivity problems with my herelink and also with a mavesp8266 bridge.
I boiled it down to the following problem:
With Arducopter 4.0.7, all parameters reset to default, the telem2 outputs heartbeats on boot.
With Arducopter 4.1.0, all parameters reset to default, the telem2 does not output heartbeats on boot.
I confirmed this with a logic analyzer with just wires into the telem2 port, not connected to any device except the logic analyzer, see below:

4.1.0 RC1

I confirmed that the autopilot is receiving mavlink on those ports, as when I connect and disconnect to the port, I can hear the autopilot beep to indicate GCS failsafe going on and off. (Ready to fly and not ready to fly beeps as well as failsafe beeps) But no mavlink comes out of the port even when sending heartbeats to it.

After setting BRD_SER2_RTSCTS=0 on 4.1.0 the problem is resolved and the logic analyzer output looks the same as 4.0.7.

Thanks! I’ve reproduced the issue and done a PR to fix it here:


Can confirm, that BRD_SER1_RTSCTS=0 (temporary) fixes the issue also for me.

Is drift mode working? I am runnimg a Matek 743 Slim on 4.1.0 and when drift is selected my yaw and roll are reverser.I miss my drift even though I am prabably the only one on earth that uses it.

1 Like

@Hacky, @james33, @RainFly, @PLUMBER, @zaxari4,

Thanks for the telemetry reports. I’m going to add a warning above and we will release -rc2 probably tomorrow with the fix.


I know the DRIFT mode is a nice feature for stunning videoing without a gimbal. The latest GoPro’s have a HyperSmooth what makes that possible.
Hopefully it will always be available!