Copter-4.0.4-rc3 available for beta testing

As some delays Copter-4.0.4-rc3 has been released for beta testing and should appear in the ground stations within a few hours of this post. The changes vs -rc2 are in the Release Notes and copied below. In short it is a relatively small set of changes and hopefully this will be the last beta before the official release.

  1. Bug Fixes and minor enhancements:
    a) Compass ids from missing compasses reset after compass cal
    b) LIS3MDL compass enabled on all boards
    c) Lightware I2C lidar fix when out-of-range
    d) Parameter erase fix for revo-mini and other boards that store to flash

The 1st issue was really the blocker because we want to be sure that users find the new compass prioritisation features works well. The issue was that if you removed a compass it was somewhat difficult to clear the pre-arm “compass missing” message. With this fix once you do a compass calibration it will clear out any missing compasses. The other way to resolve it is to go into MP’s compass prioritisation table and move down a few rows so that it’s out of the top 3.

All feedback is greatly appreciated!


Downloaded to test this commit: “”, as well as many other changes to the altitude hold behaviour in GUIDED mode.

PS, I controlled this using raw attitude setpoints.

This is a flight log from before

and after

Unfortunately, it seems like my AGL altitude is still not being used as the primary source like it was in loiter. Is this perhaps because I did not take off using the take-off command?

Also, the ground itself is not flat, but I really would like to fly at a consistent 1m above ground level as in Loiter/Alt Hold. In Guided_NoGPS, the altitude hold behaves much more like Alt Hold mode when given the same attitude setpoints.

Will there be MSP support included for DJI OSD in this release?

I have installed AC 4.0.4 rc3 on pixhawk cube and here2 gps via I2C.

Still I got HERE 2 compass HMC 5883 missing compass issue even BRD_BOOTDELAY set to 5000ms. @rmackay9

But in arducopter 4.0.3 stable version detected

but it’s not happening consistency. Most of the time it’s not detecting and some time detecting.

I have tried with multiple Here2 via I2C connection but seems to be problem with cube.
Then I thought to connect it via HERE 2 via CAN. Now showing like this.
Compass LSM303D also showing up on as external and UAV CAN also showing external.

The ROI forgotten effect is still observed in rc3 (tlog capture, video, log):

I am observing this occasionally without a clear reason. With stable 4.0.3 it happened after hitting a tall grass (tlog capture, video, log):

@warp2, The DJI OSD is still very much a work in progress so it won’t be available until Copter-4.1.x goes out i’m afraid.


Thanks for testing. So it seems that this is probably a hardware issue to do one particular cube right? Other cubes seem to be working with the same I2C compass?

Yes,what could be the reason for this problem?


It’s hard to say but it could be a bad solder joint on the I2C port itself. I’ve had a Cube where the entire GPS connector (including the I2C pins) pulled right off. This is the extreme case but something more subtle could cause the symptoms you’re seeing.

1 Like

kindly look at this post regarding HDOP and GS spped can’t reach.

Hey @rmackay9
These may not be problems with AC4.0.4rc3 specifically but these were small bugs that I could find while setting up CubeOrange on AC4.0.4rc3.
Bug1: Unable to set HW version for Batt monitor. Once HW version is selected, the sensor changes the type to other and results in wrong A/V and V divider values which shows wrong voltages.
Bug2: I usually use Neopixel on my test aircraft. The LEDs set for AP_Notify has sync loss. This is only in CubeOrange. Black works good. @iampete had made fix for sync loss in Neopixel on CubeBlack.
I’m doing more tests on CubeOrange. I’ll keep you updated.

1 Like

Flying it 3rd day on Cube Orange and no issue.:+1:

1 Like

These are not issues. These are tiny things which would mess up someone who’s setting up for the first time.

I agree with you.this is not what i ment.i had all parameters from 4.0.3 already set.

1 Like

Hi @kalai1219,

Thanks for the report. The vehicle not reaching the specified top speed is a known issue. Here’s an issue that brings up the same issue for Guided mode.


Txs for the report. So the issue with the HW version happens when using MP’s Battery Monitor screen? This logic is all in the mission planner itself so we need to ping @meee1 to figure out if there is an issue here. Txs again.

The video re the NeoPixel shows the problem well. Hopefully @iampete can comment on this…

Interestingly its not actually sync loss as we saw it before, previously we would miss (at least) a whole cycle and it would then sync up again. Here its just a bit late (I had to watch in slow mo). So I would guess that something else is using the DMA, where previously we would miss, we now just get delayed.

@Mallikarjun_SE Are you using BLHeli esc’s? I would guess if you used aux 1-4 it would be better/different. What do you have on UARTs? I think they can also share DMA.

I haven’t seen this on my LED-Copter, I can fire it up again on this beta and double check.