Copter-4.0.3 released!

Copter-4.0.3 has been released as the official/stable version for multicopters and traditional helicopters and can be installed using one the GCSs (Mission Planner, QGC, etc) or can be directly downloaded from

Changes vs 4.0.2 are in the Release Notes and also copied below:

  1. Bug Fixes:
    a) “RCInput: decoding” message watchdog reset when using MAVLink signing (Critical Fix)
    b) HeliQuad yaw control fix
    c) Do-Set-Servo commands can affect sprayer, gripper outputs
    d) Partial fix for BLHeli passthrough fix for H7 boards (CubeOrange, Holybro Durandal)
  2. USB IDs updated for “composite” devices (fixes GCS<->autopilot connection issues for boards which present 2 USB ports)
  3. RCOut banner helps confirm correct setup for pwm, oneshot, dshot
  4. ZigZag mode supports arming, takeoff and landing

The most important fix is the first one which can lead to the autopilot rebooting (via the watchdog ) when the RC transmitter is first turned on but only if MAVLink2 signing is enabled. We are not aware of any crashes caused by this issue.

Thanks very much to the developeres and beta testers who contributed to this released! Thanks!


I have flown 3 vehicle with new FW4.0.3 the first time last weekend.
1 quadcopter, 1 hexacopter, 1 heli.
All modes and basic funktions I need were working fine with all 3. I could not find any problem.
Thanks a lot for all your work.



Great, thanks for the feedback!

@rmackay9 - I’ve tried to burn the new version on my mRo Zero and encountered few issues:

  1. After the burn process completed I’ve rebooted the unit and after power on it got stuck in boot on stage (blinking LED).
  2. Several resets didn’t help.
  3. Burning the FW again seems to solve the issue but after connecting it the unit it’s not being recognized as it usually does:
    Compared to a normal one:
    Could it be a corrupt built?

Hi Roman,

I can confirm 4.0.3 does work on the mRo Control Zero.

This is almost always a serial port driver issue. My fix is to uninstall the driver but making sure to check the box to delete the drivers. Most of the time there is driver on top of driver so you may need to repeat until there is no longer a checkbox to delete the driver. If you continue to have issues please email us at and I will happily help you 1 on 1.


1 Like

Thanks @pkocmoud - I’ll try your fix and update.

running on pixhawk 2.4.8 flight board I run into some issues (Potential Thrust Loss) keeps poping up when I move the throttle stick quickly. need help figuring out if im missing something . thanks

To answer questions like this we need to see a .bin log file from the pixhawk.

Can someone build a 4.0.3 fmuv3 for me with custom “ardupilot\libraries\AP_Scripting\generator\description\bindings.desc” please? (1.8 KB)

ESC settings? Disable all optional ESC features, turn off voltage cutoff or set it as low as possible. Disable active braking.
Ensure all voltage and current monitoringin AC is set up correctly and working.

AP_Logger.cpp crashed in mid flight. This morning during two minutes into flight, I suddenly got an error of the QGC screen, something like AP_Logger.cpp something thread… due to being in mid flight I had to pay attention to the quad’s behavior so I didn’t have the smarts to capture the screen…
However, when looking at the log file I do see it stopped in mid flight.

Not sure if this issue important but it never happened to me before.

Using Cube Black, with 8 CAN ESCs, Here 2 on CAN and LightWare range finder on serial.
Adding my params file just in case.

It will have said “thread stuck”, I have seen this where another thread at IO_PRIORITY isn’t relinquishing control. Most likely in a driver, so would be good if you could list the drivers you are using.

1 Like

@andyp1per, Not sure which drivers are used by AP, however I have listed in my post what I know: CAN ESCs, CAN Here 2, SBUS for RC and serial 5 for SF11/C. I have also added my params file in my post.

any way to disable it in qground control?

Hi, ap_logger.cpp thread stuck keeps showing up. Today I noticed that when my quad was pitching forward hard ap_logger.cpp stuck thread showed. If it’s related than it might come from the LightWare driver? I use SF11/C

My guess is the same thread starvation that I see on FFT. It’s going to be one of:

Which are you using?

Sorry @andyp1per, but I don’t know what it means. I am not using osd and I don’t know what are the other drivers. How can I check?

OAPathPlanner is Object Avoidance - that’s the only likely culprit. Are you using that? Other possibility is a bad SD card - have you tried a different one?

Not using OA, so it might be the sd card. Can I simply replace or I need to copy something?