Copter-4.0.1 released!

How’s your RSSI looking when you get the “Sensor Lost” message !? And do you lose all telemetry or just part of !?
On my Taranis, I get Sensor Lost when I’m at the edge of range, along with Signal Critical, but parts of the telemetry still work.

What do you use for signal duplexing and inversion ? Some MAX3232 chips heat up if powered at 5V. I use a diode to cap power to 3.8V.

RSSI was approximately 85 when the signal dropped. Losing all telemetry but still have RC control. The other thing to note was that we are running a R9M in addition to a RFD900X. I understand they are both on 900mhz and this could potentially be what is killing the telemetry signal. I know this is not ideal, but it’s what the customer wanted… and I hate saying no. Thinking we will go back to a 2.4ghz setup and give it a shot.

“What do you use for signal duplexing and inversion ? Some MAX3232 chips heat up if powered at 5V. I use a diode to cap power to 3.8V.” Unfortunately I don’t have an answer for that question.

1 Like

Deleted and reinstalled. All good. Thank you!

1 Like

Oh, OK.
Usually, a customer requests the data output, sometimes the payload. Never the radio equipment onboard.

I do BVLOS flights with regular 100mW telemetry and 2.4GHz FrSky. I’ve tuned and upgraded the antennas, and my range is 3-3.5 Km, depending on flight height. But I don’t expect to take manual control of the drone that far away except for the emergency case in which the GPS fails.
Why don’t you go for a HereLink instead ?

They asked for a FrSky Horus X10, so that’s what we gave them :slight_smile: They also stated the HereLink video and touch screen was too small for them…

If any customer asks me for a Horus X10, I’d say that the X12S would mitigate the problem of telemetry screen being obscured by the belly of the oparator, and berate them on the bad choice.


@Leonardthall spent a few hours yesterday pouring over the AutoTune code and I’m afraid we’ve discovered a bug that likely contributed to your crash. It’s a bit technical but basically AutoTune was not properly restoring the original gains when the vehicle was switched out of AutoTune - the I-term was left at a very low value which for some vehicles would result in bad attitude control. We’re really sorry about this but if it’s any consolation we’ve got a fix now that is being tested and will be included in the next point release.

Thanks again for the report.

1 Like

Hey @rmackay9
Have been flying AC4.0.1 since release and have performed autotune twice. I didn’t find any issues. Can You elaborate more on the bug?
Here is a log of yesterday’s flight.

The bug only manifests itself if you touch the sticks during a twitch or if you have hardware problems that rely on the I term building up quickly to address the issue.

Hey @Leonardthall
I read the fix article. Is it a good idea to start Autotune in Loiter mode? Because loiter mode mainly controls horizontal speeds that is being set.

I always kick off AutoTune from Loiter so I’d stick with that. How Autotune is started doesn’t make the bug any better or worse by the way.

I’ve had that bad AutoTune a couple of weeks ago, where the copter won’t switch back to previous PIDs after testing the AutoTuned values. Is it related ?
If you can compile me a fixed Pixhawk 4 firmware, I’ll give it a shot.

yes, this may be the cause of that problem.

It would be right, what You has found. The copter act very oddly, after second time it fly away something about 100m, and i hit RTL, it start to fly to me, but the ALT was going up, so i gave him the low on throttle, to reduce the Alt, seconds after that it has just fall down.

Hello! I use Pixhawk holybro 4. The latest version of firmware! Run into problems. After Autotrim, the new values are not saved, I did it several times but always the same result! The new firmware version has changed the auto trim setting

Give this a try, this is what I had to do…

Perform Autotune. Once done, read the values into Mission Planner, basically you can “refresh” the screen and the new values will appear. (assuming you have telemetry radios active). Then Write the values.

This worked for me. Like you, mine did not save until I did this

Yes, but before auto trim was saved automatically when disarm, now the values are not saved. I read that there are problems with firmware 4.0.1 and for now I will return the old 3.9.11

Auto Trim or Auto Tune? Very different functions.


I just tested Copter-4.0.1’s SaveTrim and AutoTrim feature and it seems to work correctly. You followed the instructions on the wiki? If you can provide an onboard log then we can try and figure out what’s going on.

By the way, I’ve updated the wiki page just now to clarify that in most cases, AutoTrim and SaveTrim are not required. The accelerometer calibration does a good job of setting the trims.

1 Like

Yes. I think when Auto Trim is suggested it’s not understood what accelerometer calibration is meant to do. Why one would want to trim to a temporary, and most likely fleeting, condition never made sense to me.,

1 Like