Copter-4.0.1 released!

I have fmuv3
My board is pixhawk 2.4.8

I’ve tried fmuv2 firmware, and mavftp is working (but with mavproxy app, in mission planner 1.3.70 it’s not working too). Maybe i should use another firmware, but as i search, the fmuv3 is correct for my board. The Cubeblack firmware has no use - i tried, i have sensor missing masseges.

@rmackay9 Installed today 4.0.1 in order to test on a Y6F configuration(fresh build), but i was not able to find it in the setup, even though i am able to see the option on the wiki. Am i missing something?
i will also test the code tomorrow on my X6 test platform and give my update also.


Great, the DJIX frame should work then.

Re the motor order being different from DJI, it’s mostly historic. ArduPilot’s original Quad motor order came from Multiwii. It’s an odd order but MultiWii was a very popular system at the time (more popular than DJI) and I think the MultiWii developer’s thought there was some hardware performance improvement they could get from that ordering.


Yes, you’re right that while “Y6” is available on MP’s Frame Type screen, the secondary option for “Y6F” is missing. This is really a mission planner issue so can I ask that you raise an issue in the MP issues list? Until that’s resolved you will need to set the FRAME_TYPE parameter to “11” through the full parameter list.


I retested on my mRo Pixhawk (aka Pixhawk1) using the fmuv2, fmuv3 and Pixhawk1 firmwares and MAVFTP worked (for me) with all of them. I’m pretty sure this is a mission planner issue so I might ask if you could raise an issue in the mission planner issues list so @meee1 can have a look at it. I suspect though that the issue has already been fixed in the latest beta and it’s just a matter of either upgrading to the latest beta or waiting until the stable includes the fix.

By the way, I’m using MP’s beta firmware. The exact version is 1.3.7331.1623.

looking at the log I see you used fmuv3 firmware. Can you confirm which exact board this is you’re using, and which i2c connector the rm3100 is on? I’m guessing from the set of IMUs that this may be one of the mRo boards?

I tested a Drotek RM3100 standalone compass on the I2C2 connector of a CubeBlack running fmuv3 Copter-4.0.1 firmware and it works fine

Dji motor mix will work for all frame type like Quad, hexa, octo?


No, I’m afraid it’s only defined for quads. It’s not very hard to make it work for hexacopters and octocopters though. It’s always counter clockwise?

By the way, if you try and invalid mix of FRAME_CLASS and FRAME_TYPE you’ll see a pre-arm error that the motors haven’t been initialised.

I’ve added an enhancement request here. Feel free to add details.

This is the motor numbering and position for DJI flight controllers.

Please note this is NOT the Arducopter Motor Layout***

1 Like

Good day, im using the mRo x2.1… ive wired the drotek rm3100 on the I2C port of the mro can node…, stand alone on i2c port work well… ive solve

1 Like

@Dave84, great, thanks for the feedback on the rm3100!

Thank you for your reply. No Need to raise the issue since this morning on the beta update of MP, its showed it.
Once again thank you for all the hard work.

I don’t know if it’s MP, but now it has now matter - my drone has crasched today. It was in autotune with firmware fmuv2 (the Mavftp was warking on that firmware on MavProxy), it has flow away to much (befor autotune was in pos hold), i have it fly to me twice, and after second flying away i turnoff autotune, hit RTL and in the half a way it just fall down. Can somebody read the log and tell what was the reason? I couldn’t find anything with sens.

Hi @Kowal666,

I’m afraid because the tuning is quite bad on the vehicle it triggered the Crash Check. The crash check can trigger if the vehicle maintains a 30degree lean angle error for more than 2 seconds and doesn’t seem to be accelerating by more than 3m/s/s.

So in this case the vehicle was attempting to pitch at about 30 degrees (see blue line) but it’s actual pitch is shown in orange and it’s much lower.

So sadly in this case the tuning is bad enough that the crash check triggered. The crash check can be disabled by setting FS_CRASH_CHECK = 0.

Installed on Cube and not seeing the dropdown menus for Ch 7-10 opt - Extended Tuning


This is really a mission planner issue. I think most users have overcome this by updating the MP which can be done from it’s Help menu. If this doesn’t work for some reason then it’s probably best to raise an issue in the MP issues list or directly update the RCx_OPTION parameters.

Ok, Thank You. Bad luck, 150EUR lost, but it is as it is. To strong wind, new propellers for autotune. But for the future new experience …

Hey guys, I just had a chance to test 4.0.1 and I am still getting the “Sensor Lost” message on my Frsky Horus and losing telemetry in the air. Still have RC link tho, just no telemetry (using the Yaapu widget). I tried two flights- one occurred about 10 minutes into the flight and the other occurred around 3 minutes into the flight.

I was also running into this problem on the 4.0.0 FW. Has anyone had a chance to confirm that the 4.0.1 release fixes this?


That’s very odd, I have the X10S and was running 4.0 and then 4.0.1 rc2 and rc3 and never had an issue at all.