Servers by jDrones

Copter-3.6.9 Released!

@Amozov_x, the changes between 3.6.8 and 3.6.9 are quite small and shouldn’t lead to the compasses not being found. Could you try reverting to Copter-3.6.8 to confirm whether going back to the old firmware resolves the problem or not? The MP’s Install Firmware screen has a drop-down on the bottom right called “Pick Previous Firmware” that has 3.6.7. Alternatively versions 3.6.8 is available from firmware.ardupilot.org although you’ll need to know which firmware is appropriate for your board.

I have a Pixhawk mRo. This is what firmware I need?

Today I tried to install 3.6.7 through Mission Planner. On this firmware works. 3.6.8 standing on another quadcopter also works. And 3.6.9 put on one more quadcopter does not work on it. I tried all the wires and modules of the gps. Everywhere the same thing. I have 3 pieces of MRO module.

I will try again.

Not detected at all on autopilot original 3dr pixhawk. The mRo is still somehow defined on 3.6.7 and 3.6.8. On the original do not want to be determined:thinking:

Well done, great job.

When will the Radiolink minipix be recognized by Mission planner for firmware updates. Why does it have to be updated manually?

I experienced the same issue with 3.6.8 an MRO LIS & IST GPS puck. I found that installing Chibios with 3.6.8 was creating the issue. As soon as I reverted back to NuttX only, the mags were able to be recognized again, and all my Mag related issue disappeared. Hope this helps

  • Ed
1 Like

Hey Randy,

Any chance the DEV’s will have a solution for the bad logging issue that seems to be occurring in Pixracers with Chibios? I haven’t been able to get data flash logs or T logs since 3.6.8

I read somewhere that @tridge had said that it was because the new SD cards on the market are designed for much more than just logging. Any idea if there is a fix in sight, maybe next release?

  • Ed

Radiolink took the open source code, made up there own code and did not share it. Not honorable at all.
I do not think we will ever see real Mission Planner work with door stop radiolink FC.

Curt, there is a minipix firmware 3.6.9 available on the ardupilot server. You have to download the .apj file manually and install it. My question is, why the hardware can not be recognized by mission planner

1 Like

I did not have a issue connecting to mission planner? I just could not get through the configurations. Thanks for the info on the firmware. What type of radio TX/RX are you using?

I use Taranis with x4rsb and x8r. Both with passthrough telemetry. I am very satisfied with the minipix for cheap copters. For more expensive ones I use cuav Pixhacks v3 or Holybro Piyhawk 4 / Pixhawk 4 mini.

From what I read from Chinese distributors on taobao, the Radiolink minipix required “dedicated” GCS and FW that can be downloaded from radiolink, and won’t work with “regular” pixhawk firmware. I’d say that radiolink minipix not working with mission planner flawlessly is more or less intentional.

AFAIK they haven’t released their source code modifications - despite
being asked - so RadioLink is in breach of our license.

The MiniPix works just fine on master, and with any GCS. The build target
is “mini-pix”.

We have met one Mini-Pix with a dire hardware failure which caused a plane
to lock up and fly-away; we are still not sure of the root cause, but the
barometer was completely insane. Our leading theory is that the hardware
failure also affected the IMU’s bus and ArduPilot stopped, waiting for
input.

We have also met a Mini-Pix whose RC output was broken - only 3 of the 6
outputs worked IIUC.

That being said, I fly one of these on one of my planes here and it’s
fine. Single-IMU and the EKF goes insane with vibration issues, but
that’s my problem, not the autopilot’s.

1 Like

I also encountered the same problem, I want to know how to solve it? Thank you

I have the same problem as you. How do you solve it? Thank you

Dear …still facing issue,not solved.

@Flyman
You can switch to stability, the throttle is at zero and wait for it to automatically disarm, I think it should be able to protect the aircraft

Thanks… hopefully it works.

@Flyman
My aircraft did not detect landing because of the high vibration value. From your log. IMU.Acc. After the aircraft has landed, the vibration value is increasing (higher than the value in flight). It should be a structural problem of the aircraft. You can try to reduce the vibration value. Or simulate a vibrating aircraft test (Altitude Hold)

I returned also on nuttx and 3.6.8. I still refuse to see external compasses. not from mRo, not from drotek.:frowning:

Servers by jDrones