Servers by jDrones

Copter-3.6.6.-rc2 available for beta testing

beta
beta-testing
beta-release

(rmackay9) #1

Copter-3.6.6-rc2 has just been released for beta testing and can be downloaded using the GCS’s Beta Firmwares link. The changes vs -rc1 are in the ReleaseNotes and also copied below. This release includes one critical bug fix (please see below).

Changes from 3.6.6-rc1

  1. Bug fixes
    a) EKF compass switching fix for vehicles with 3 compasses
    b) CAN fixed on Pixhawk4 and PH4-mini
    c) Mini-pix uart telem1 and telem2 reversed
    d) Divide-by-zero protection if _FILT_HZ params set to zero
    e) Guided_NoGPS skips GPS pre-arm check

The critical change is the EKF compass switching fix (highlighted above). The issue is that on systems with 3 compasses (which have become very common) the EKF could continue trying to use a “bad compass” even after it had determined that this compass’s heading doesn’t match the GPS and IMU. This can lead to the bad compass negatively impacting the vehicle’s position and/or attitude estimate leading to a loss of control and a crash.

Although this bug sounds very scary (and it is) the worst case is quite rare. A much more common symptom of the problem is many messages from the EKF warning that it has changed the primary compass. At least two beta testers have reported seeing this less serious symptom.

Any and all beta testing is greatly appreciated! If things go well we hope to release this version as the official/default version next week.


(rmackay9) #2

(Andyp1per) #3

Oh nice! Looking forward to trying out this fix when it’s not raining or snowing and winds are below 50mph :wink:


(Gino Nencioni) #4

I apologize if I open the topic again but after several tests with the optical sensor cx-of I found that it only works with version 3.6.4 of copter forcing the drivers. I performed the tests on 3 flight controllers: Kakute F4, Matek f405std and the minipix radiolink…
Any chance to fix it?


(Marcin) #5

I am sorry if this is not very interesting. Can you turn on the firmware for pixhawk the option of connecting an external barometer as long ago declared in the arducopter documentation from 3.6 Thank you in advance. We know that the internal barometer is good but can not be moved…


(rmackay9) #6

@Gino_Nencioni, I’ve heard this report so I’ve added it to our 3.6 issues list here. It won’t make it into 3.6.6 but we can try for 3.6.7.


(rmackay9) #7

Hi MarcK,

ok, i’ve added the non-working baro to our 3.6 issues list. Is the baro you’re using the same as one of the ones on the wiki page?


(Marcin) #8

I connected the mp280 barometer and thanks to your action I will be able to use it. I have a hexacopter modified for 2 years. fly perfectly on dshot and despite the noise of the internal barometer on the level of 1meter noise the height with an accuracy of 15cm. Looking at the logs with the barometer noise I thought it could be better and decided to connect the external well-shielded barometer good quality parameters I have thanks ultra low vibration and a precise gps with enabled Galileo.Lidar I have temporarily turned off because in Poland it is winter and the narrow bunch of lidaru gives big errors in the area with vegetation. For summer this lidar greatly supports the maintenance of height. I have tft mini benawake. I often fly at a height of 1-2 meters so the matter of maintaining the height I am very interested. I am grateful for the quick positive reaction. I am happy.Thank you very much


(Marcin) #9

of course, Bmp280 not mp…


(rmackay9) #10

Ok, I never personally got the MP280 to work but @vierfuffzig has I think.

@vierfuffzig did you have to do anything special to get the mp280 to work? Was it with Copter-3.6 or some other version that worked?


(Marcin) #11

Bmp 280 is on kakute f7. When I uploaded the arducopter 3.7.0 noise from the barometer during the flight was low about 0.2 meters despite the only cosmetic pad and driver assembly. Year ago on the pixhawku had noise about 0.3 meters on the built, but I changed propellers, engines and a little The current location, despite the driver’s installation, is not perfect and I am looking for a better barometer position. Barometer tests (ms4611 and bmp280)show that both are good


(basti) #12

@rmackay9 i‘m using bmp280 types for external temperature sensing on all my airframes, those being fixed wings running arduplane though, and alt noise is no parameter i did pay special attention to. all 5 setups run on stock plane fw with no additional hw, just the bmp280 breakout board connected to the FC‘s I2C pins. FC‘s used are omnibusf4proV3, matekF405-wing and revomini.

from coarsely reading over the last couple of posts i couldn’t really tell if we’re trying to rule out a vehicle-specific issue or if it‘s board-related ?

i can well try to run an external bmp280 on copter fw, but i don‘t have a pixhawk at hands to test on…

cheers, basti.


(basti) #13

@rmackay9 edit: i’ve actually found an old fmuv3 (AUAV-X2) in my drawer. just quickly flashed latest copter and connected that BMP280. i can confirm the external BMP280 works just as fine on fmuv3 running copter as it does running plane on any other FC :wink:

it actually requires one single parameter adjustment, that is setting the GND_PROBE_EXT bitmap to the baro type you want to probe for. that’s a value of 2 if you want to probe only for the BMP280.

cheers, basti.


(rmackay9) #14

Marcin,

Ok, thanks. So I guess you’ve managed to get the bmp280 working now. thanks for the feedback!


(rmackay9) #15

@vierfuffzig, great, thanks for the confirmation that it is working so I’ll close the issue. I’m actually still unsure if it works on Copter-3.6 because I think most of the tests have been done on latest…


(rmackay9) #16

I think I may release 3.6.6 today as the stable version today. I was wondering if anyone else had given it a try?


(Marcin) #17

I have uploaded a new version to the hexacopter 3.6.6(6b88b2ba) and there is no possibility of detecting an external barometer. There is no parameter Gnd_probe_ext…Can someone confirm that he was able to connect an external barometer on the latest version?


(Marcin) #18

I use mission planner 1.3.62 for the configuration, this board is pixhawk 2.4.8, I have loaded firmware3.6.6 today and I still do not have GND_PROBE_EXT .


(basti) #19

@MarcK @rmackay9 sorry for not being precise regarding fw versions in the first place, but i’m not exactly familiar with AC release version handling.
i can confirm that copter 3.6.6 does NOT contain the respective additions of aug. / sept. 2018:


seems those additions didn’t make it into any releases yet…

cheers, basti.


(Marcin) #20

thanks, I hope that soon the patch will be available. All good…