Copter-3.6.11 released!

Copter-3.6.11 has been released as the official version and should appear in the ground stations within a couple of hours. The list of changes is available in the ReleaseNotes and also copied below.

Changes from 3.6.10

  1. EKF and IMU improvements:
    a) IMU3 enabled by default if present
    b) IMU3 fast sampling enabled by default on Cube autopilots
    c) EKF protection against large baro spikes causing attitude error
    d) EKF origin fixes (consistent across cores, set externally only when not using GPS)
    e) EKF logging of 3rd core
  2. Minor enhancements:
    a) Land mode supports heading requests (ie. ROI)
    b) Support Hexa-H frame
    c) MatekF405-STD binaries created
    d) Benewake TFminiPlus lidar support
  3. Bug Fixes
    a) Barometer health checks include sanity check of temperature
    b) Lightware serial driver handles invalid distances
    c) IO firmware fix involving delayed writes to serial ports (ChibiOS only)
    d) CAN Compass fis to for unintialised device IDs
    e) mRo x2.1-777 USB ID fix
    f) ChibiOS fix for I2C storm

The important reliability fixes are 1c and 3f highlighted above. Although rare we have seen at least one incident of each across the vehicles (Plane, Copter, Rover) so we recommend 3.6.x users upgrade to this latest version.

Thanks very much to those who helped us with the beta testing!

1 Like

Hi rmackay9,
I searched for MatekF405-STD binaries but they are missing…

1 Like

@Gino_Nencioni, oh darn. OK, I’ll try and get someone who knows the build system to have a peek at it

1 Like

Is AC3.6.11 still supported by Pixhawk 2.4.8?

Pixhawk 2.4.8 is supported by AC 3.6.11. And 4.0.0-dev for that matter,


I am using a Cube Black and am having major problems upgrading to 3.6.11
The interface is new, I am not sure about the drop down menu that I have never seen before.
Also more troubling is that I cannot select a HEX Y6 configuration. It always defaults to a Quad.
It seams all configurations other than the Plane or Rover, default to a Quad after the upgrade. So far I have spent 5 hrs trying to fix the Cube.

The location under the com ports and the connect area, only shows COM-32 QUADROTOR
No matter which configuration I select and format with the firmware, other than Plane or Rover the board formats for a QUADROTOR.
Normally it would say COM-32 HEXCOPTER, or COM-32 OCTOCOPTER.

I have done hundreds of firmware upgrades before this over the past 3 years , so I believe I know what I should expect to see.

I need it to be the Y6 Hexacopter.
I have tried 3 different Pixhawk2 cubes and get the same result.

Anyone know why?

I have tried 3 Pixhawk2 Cube boards and 3 PC 2 with Windows 7 and one Windows 10.
Results are that one board formatted with the new firmware as a HEXROTOR, after 5 hrs of attempts the other two will not take the HEXROTOR Y6 format with the 3.6.11 firmware or any firmware they only allow Plane, Helicopter, Rover, and Quad. They will not format to Hex or Octo.
I have never seen this before.
Also there is a new drop down menu when you are formatting the boards the I am guessing the USB and other settings. Is this new formatting menu new, or is a bug as it is not mentioned in any documentation I have seen.

I have tried to wipe them clean by loading in the Rover Firmware then attempting to install the Hex Y6 format, only to end up with a QUADROTOR settings.

So set the FRAME_CLASS parameter to 5 (Y6) and restart the FC.

Thank you Dave
That worked!!!
FRAME_CLASS was set to 0
Changed to 5 and restarted.

Very odd, I have never had to make that change before.
I am now cautiously going to test it, worried that it just changed the description under the com ports and not the flight configuration.

Have you done that before and did it fly correctly

again thank you so much, I was stumped

More updates
After following Dave’s suggestion I tried to load the 3.6.11 Hex Y6 firmware and it worked and stayed as a HEXROTOR Y6
So it appears that if the frame setting gets mixed up, the newest firmware loader does not set it correctly for some of the frame types.

This has been the case since (from changelog):

Copter 3.5-rc1 28-Jan-2017
Changes from 3.4.4
1) Multicopter firmware consolidated into single binary, users must set FRAME_CLASS parameter (1:Quad, 2:Hexa, 3:Octa, 4:OctaQuad, 5:Y6, 7:Tri)

Thanks Dave I appreciate knowing that it has been the case since Jan 2017
Odd why I have never had an issue before.
Since then I must have formatted at least 80 new Pixhawk2 Cubes to a Y6 config and never an issue before. I have also updated those 80 Cubes many times over so I guess I was lucky or something

Learned something today… always something new.

Perhaps it’s a Mission Planner issue. I’m always updating to the latest beta as I run Ardupilot beta’s and dev versions on some craft. What version are you on now?

I have version 1.3.68 Build 1.37105.26478 on the three computers I tried.

I was just going over the rest of the config, since you solved the problem I had for many hours… THANK YOU, Compass #3 no longer show up when I do the compass calibration. It has been their before. I know its an internal and the external Here Compass 1 is the best one to use.
I have the check box selected, and I cannot get it to calibrate with the others. I am wondering if I need to force it as well. Like the Frame configuration and configure it by not using the check box.

OK, that’s current MP.

Are 3 listed on the Mandatory Hardware>HW ID page with a device ID?

I figured it out, I am too tired. Working on this for most of the afternoon and evening.

When I was bench testing the Pixhawk, I did not have external HERE GPS attached.
So Compass 1 and Compass 2 were the internal
Three was missing because I did not have the HERE plugged in… DUH.
I need some sleep.

Thanks Dave for all your help.
Greatly appreciated.


I found out that Log downloading trough USB gets 4x slower when CAN is enabled.
Normally it is around 180-200kB/s, but with CAN enabled it is 30-50KB/s.

This happens even when there is nothing attached to carrier board (only Cube + carrier).