Copter-3.6.0-rc9 available for beta testing

Copter-3.6.0-rc9 will be available for beta testing within a few hours. This new beta version can be downloaded using the MP’s Install Firmware screen after clicking on the “Beta Firmwares” link. Other GCSs including QGC can also load the new version (check that the version string includes “-rc9” at the end).

The changes vs -rc8 are in the ReleaseNotes and are also copied below.

  1. Landing gear can be operated using AIRFRAME_CONFIGURATION mavlink messages
  2. Support playing tunes received via MAVLink (i.e. from GCS)
  3. Bug Fixes:
    a) Twitch reduced when entering Loiter at high speed
    b) Safety switch state fix when Pixhawk/Cube I/O board reset in flight
    c) External display fix to allow plugging into either I2C port

This it’s a relatively minor release which likely means that we’re getting close to the end of beta testing. There are a few outstanding issues some of which we haven’t responded to yet but hopefully over the next few weeks we can address the most critical.

Thanks to the beta testers for your help!


thank you and the team for your hard work and dedication

just to report:
tried to compile it for px4-v2 using the px4 toolchain (make) on Win, and it failed with error “region `flash’ overflowed by 10600 bytes”
trying to manually disable more features didn’t changed anything, always 10600 bytes overflowed
I do see a ArduCopter-v2.px4 in the ArduPilot firmware site, not sure what the difference is

solved, was my fault, see below

I’ve completely failed to get 3.6rc9 to work (was on 3.5.7) before. I’m sure I’m missing some docs somewhere but can’t find them. Here are my notes:

  • Copter won’t arm but there is no indication why (no audible tone like in 3.5.7 and no mavlink message)
  • Ready-to arm tone takes a long time and only happens when I push the safety switch
  • No tone on flight mode changes
  • Had one situation where the copter sat in the initialization loop with the lights cycling for ever
  • Can’t calibrate external compass (but I think this is down to a bad compass)
  • Weird tune gets played after a short while - di di di - di di

I tried 3.6 because of my compass issues, but looks like I will drop back for now.

I am using a pixracer R14 with apmplanner 2.0.26rc2 on a mini quad

Looks like my issue is ChiBIOS. I re-uploaded with NuttX and all was well.
Probably should have a health warning for ChiBIOS in the release notes!

My pixracer is working properly on chibios… But I updated to it months ago… No problem from chibios rc8 to rc9.
My pixracer copter does not have a safety switch, so maybe that’s something to consider…

I’m guessing the issue was I am configured for oneshot which isn’t supported so probably why it didn’t arm. The lack of mode change noises again is because they aren’t supported and the di di di - di di is the unready to arm tone. So all explicable, just confusing when they all come at once.

Haven’t heard Oneshot is not supported. Oneshot125 is I’m using it (Chibios PixRacer).

Same here… My pixracer copter ESC’s are too old to support dshot, and it’s working for me w/ oneshot 125.

Yea, its annoying. The Same Spedix ESC’s I have are now being sold as Dshot capable. Obviously there is some difference as I can’t get them to work on Dshot. Even tried updating the ESC firmware and that didn’t work. Thought I bricked them but they flashed back.

Hi all
I’am lookig for help with my small quad (150 mm).
My configuration:
Kakute f7 aio v2 ,150 mm quad, emax mt1306 3300kV, 3030 props, tattu 3s 40c 1300mAh. Drotek gps with mag.
I perform auto tune. In loiter mode it flays perfect ( flying time about 6 min afer autotune).
I tested SmartRTL alt hold , landing and it works OK.
I notice problem with log file . I cant download log files trought USB.
In MP I cant even list files from FC in QGC I see files but if I select any files I recive message: time out. I try several sd cards. If I use card reader evrything is ok
Some files do not have a date ant time.
The second problem is with stabilize mode.
Can anyone help me with settings in stabilize mode? In sabilize mode I have to move stick very gently. Evry touch of throttle causes rise or fall
My log file
Thx in advance

This is supposed to happen as stabilize mode, all 4 stick controls, we need to keep adjusting them. Try flying in Loiter or PosHold if Stabilise mode seems difficult to control at the start.

As for your first question, seeing the log files, everything seems fine. Please check if after connecting the f7 to your computer, it is being recognised. If no, then something is wrong with your board.

OK thx
Is there a way to reduce throttle sensitivity in stabilization mode ? Which parameter have to be changed ?

Honestly, I would suggest to not change any of the parameters as flying in Loiter is just easier for you, plus you tend to crash less in Loiter.

That being said, you can maybe change the values of
" PILOT_SPEED_DN" and " PILOT_SPEED_UP" to change the speed of the copter with respect to your throttle, and " PILOT_ACCEL_Z" to control the rate of acceleration in vertical direction.

Please take this with a pinch of salt as it may or may not work.

I have
PILOT_SPEED_UP set to 250
PILOT_ACCEL_Z set to 250
Value Pilot_speed_up and pilot_accel_z should be the same.
And what means PILOT_SPEED_DN set to 0 ? is it mistake or error ?

None of those parameters have an effect in Stabilize mode.

Are there any parameters that affect in Stabilize mode ?

I use a throttle curve like expo in the transmitter.

I tried this Version with and without ChibiOS on a Pixhawk 2.1
Without the Chibios im missing Servo_BLH Options which i would like to use
With Chibios the Systems hangs after a few seconds up to a minute - one orange led keeps flashing on the Pixhawk but no response in any other way.
It takes anywhere between 10 seconds up to 1 or 2 minutes until this error happens.
If i try to change a parameter in Mission Planner it immediately happens

Is that true? I assumed that the throttle will be changed since the rate of acceleration in Z direction changed? Or am I not understanding the parameter correctly?