Copter-3.6.0-rc5 available for beta testing

yes, thanks to some great work by Huibean Luo the KakuteF7 is supported now, and has had successful test flights. The microSD support seems to have an issue - it works sometimes, but often fails. Other than that it seems to be working well.

1 Like

Why are you using althold for AutoTune instead of the new improved poshold AutoTune


is there any information on the factors for the microSD issue? i received kakute f7 aio FC - flashed it with no issues, upon startup i see
No IO Thread Heartbeat ()
PreArm: Logging failed

i tried so far 2 latest generation sandisk cards - 8gb and 16gb. is there anything else that is known about SD card problem? i saw old thread where “No IO Thread Heartbeat ()” had a suggested ‘fix’ to set log_file_bufsize to ‘4’ - is there anything similar here?

here are all messages i see printed on the kakute:

PreArm: Logging failed
PreArm: Need 3D Fix
PreArm: Compass not healthy
PreArm: Throttle below Failsafe
EKF2 IMU0 tilt alignment complete
No IO Thread Heartbeat ()
Initialising APM
Frame: QUAD
KakuteF7 003C003A 34345117 39383339
ChibiOS: c77e7465
ArduCopter V3.6-dev (d86dbee1)
Barometer calibration complete

on a card i see sometimes partially formed files with incomplete names. odd.

ps: buzzer, if soldered, is producing non stop tone, i guess it is also yet not finalized? is there a dedicated thread for this fc issues?

Looks like “Motor Test” is not working in the new builds also rolling back to master firmware from Beta is not working. EDIT Solved. RC trim mim greater that trim. set trim value to 1500.

Also, i flashed kakute f7 with no issues using befaflight gui and ardupilot_with_bl hex file. Is it possible now to flash betaflight back into it, if yes, how?
As if i press boot button now and connect usb cord - there is no new device at all showing added in windows. MP seems working fine but i wanted to test telemetry wires i soldered in betaflight and got stuck. How to recover DFM bootloader? Or is it irreversible?

I have exactly the same problem as you. Do you have a way to contact you directly??? Whatsapp maybe?
I’ve tried everything and discovered lot of things. I would like to discuss it with you

As i do not hide :slight_smile: - my email is

Pls email me.
So far i only got one true showstopper - cannot get s.port telemetry to go via r-xsr, so far. Used 3 diff diodes between tx/rx, 10,5k,1k resistors, it refuses to work. Very annoying

Hi, i have rc6 loaded on kakute f7 - saw your message here and just tried - motor test worked fine, default settings.

Solved: I needed to input RC trim mim greater that trim. set trim value to 1500 and it worked. Not sure about ESC calibration working 100%.

if you try dshot protocols - be extra careful and take off props, my model did something bazaar on it - span motors while disarmed after some initial blips.

1 Like

I just received my PixHack V5 today and connected it to MP. It connected but was missing the serial parameters to configure. I upgraded to the latest copter beta version with FMU V5 support and now, it does not work at all.
The USB ports is no longer recognized. When I connect the USB, it says installing USB driver for PX4 BL FMU v5x and then about 15-30 seconds later says USB device not recognized. When I insert the USB, the FMU flashes green for a couple of seconds and the I/O lights flash - slow red, solid blue, blinking white. I hooked up the DSU7/Debug port but nothing is coming out of the serial port. I am hoping there is a way to fully reset or an alternative to uploading new firmware. Any help would be greatly appreciated!


we’ve pushed out a new Copter-3.6.0-rc7 although I actually suspect this is a ground station issue. It’s almost impossible to “brick” a Pixhawk so we should be able to get it working somehow. sorry to not provide much useful info just yet.

happened something similar to Ron E with a mini-pix…

same behavior when connecting the fc to the computer…