Servers by jDrones

Copter-3.6.0-rc3/-rc4 is available for beta testing

beta-release

(rmackay9) #43

Copter-3.6.0-rc4 is available now replacing -rc3. I’ve updated the title of this thread and the release notes at the top (look for “added in -rc4”). The major reason for the quick release of -rc4 was because we found the auto build of some of the new boards wasn’t working.


(brandon macdougall) #44

Quick issue: mRo v2.1 radio "stock wiring " will not connect to Mission Planner unless booted with USB first.
ChibiOS RC-1 through RC-4:

Steps plug in battery. look at radio no flashing of green but solid red. Radio in question
unplug battery plug in USB to FC and then battery Radio flashes and you are able to connect.

Note: advised to remove two wires on the connection however should we not check this for issues that can affect flight characteristics?


(brandon macdougall) #45

Decided to move the mRo FC to a old frame I lost the motor location on the frame so I needed to check motor rotation order assignment then received this error message in Mission Planner: False Flag when using " Motor Test" ChibIOS RC-4 and Nuttx error message: RC-trim greater than mim trim09. RC not calibrated and " command denied by autopilot "

What I did. Update firmware to chi rc-4 or PX4-v3 connect to MP using usb plug in battery or just raido, arm craft go to Optional Hardware/motor test. click on test motor a.

After the error I recalibrated radio and set trims to min 800 with same results. Note: craft will arm with radio.


(Joe Breznai) #46

Updated ChibiOS rc3 to rc4 today and flew one flight on both 2.4.8 Pixhawk and mRo Pixracer quads. No flight issues and was in heavy winds ( 11 gusting to 25 mph). Other than “beep” issue mentioned above, no problems.
Have not tried NuttX version yet, nor a setup from scratch.
Joe


(rmackay9) #47

Hi Brandon, thanks for all your testing!

re the mRo radio. Are the issues only happening with ChibiOS or with NuttX as well? I guess there are two possibilities:

  • the radio is browning out because the flight controller cannot provide enough power to it. If you’re using a Pixhawk or Cube autopilot then normally Telem1 can provide the most power so I’d move the radio to Telem1 if possible.
  • the flow control pins on the radio are not working or ArduPilot is not correctly detecting whether the flow control pins should be used or not. You could perhaps get around the problem by setting BRD_SER1_RTSCTS = 0 (to never use flow control) or 1 (to always use flow control). Note that the SER1 part of the parameter name assumes the radio is connected to Telem1.

The “RCx trim greater than min” is a mission planner issue so hopefully @meee1 can fix it in a future beta.


(rmackay9) #48

JoeB,

Thanks for testing! The “beep” during compass calibration should be sorted hopefully in -rc5.

By the way, it’s probably clear but it shouldn’t be necessary to calibrate the compass regularly. A compass calibration normally isn’t required when the vehicle is flown at a new location because we lookup the “declination” in a table based on the vehicle’s lat/lon position and the “inclination” is detected automatically. The compass calibration should only be required when metal bits are moved around on the vehicle.


(brandon macdougall) #49

Hi only with ChibiOS rc1 thro rc-4


(brandon macdougall) #50

Yes if I remove the flow control wires it will connect I was wondering if this is possibly what causing the extra noise hurting GPS performance in the ChibiOS builds. Px4-v3 is fine no issues and i using this power pdb

BRD_SER1_RTSCTS = 0 I did try that but no change last month.


(brandon macdougall) #51

Hi this is a new issue when testing motors in Mission Planner it also give a radio calibration error flag and then " command denied by autopilot " in the same menu not in the HUD. I needed to roll back to a older FM to override. Will test this more. Note: Nuttx and ChibiOS.


(Joe Breznai) #52

Thanks Randy. FYI , I put new ESC’s with telemetry on that machine, that’s when I re-did Compass Cal and noticed no beeps. Should have mentioned that. Telemetry ESC’s works great on Pixracer. Interesting info to have.
Joe.


(Randy Bachtell) #53

I have three vehicles running 3.6rcx /chibiOS, a 350 quad and a 550 quad with with PH cube and Edison/apsync, Here GPS. A large hex with PH cube and TX2/apsync/zubax uavcan GPS. All three work perfectly with 3.6/nuttx. Switching to chibiOS things go a bit off. The quads are set up almost identical, the small one now arms with log_backend set to 3 and ekf2 and ekf3 running. The 550 with rc3/4 sets bad logging unless I set log_backend to 1, with rc2 it works fine. The large hex is set up almost the same with the exception of uavcan gps, it works with rc2 and log_backend set to 1 but I get bad logging with rc 3/4 no matter what. If anyone would like to see a log let me know what bitmask to set that would be the most helpful. These are all long running craft that have proven solid fliers and have been through many beta versions. I have compared parameter files several times and can’t find anything that might cause the issue.

Cheers, Randy B


(David Ardis) #54

In the migration from 3.5 to 3.6 I have noticed the Battery Failsafe had changed in my case from 13.5v to 10.5v. I do realise the Parameters have been renamed from FS_BATT_ to BATT_FS_ but thought the value would remain the same.

In my case not a big issue but just wanted to point it out.


(Randy Bachtell) #55

solved. Unnecessary alarm.


(Gal Nitzan) #56

Hi,
noob alert here.
Just wanted to report issues I have with ArduPilot for the Pixhawk 4 (FMU_V5).

So, First updated the FC to PX4 latest version, configured everything and had one flight (IronMan Sport) with it, all went well. However, I need some features missing from PX4 like BLH passthrough so decided to try ArduPilot since its already in RC stage.

So, using latest MP I have flashed from latest firmware (07/07/18) build, without any problems, all went well. After reboot got the following errors: PreArm FS_THR_VALUE (the value was 975 instead of 925) and PreArm Safety Switch. Initially, I have ignored all errors and went thru frame type (X), calibration and compass. After reboot I fixed the FS_THR_VALUE by setting it to 925 and refreshed. Than I received the error COMPASS inconsistency, to resolve for the moment I disabled internal compass and the error was gone. So, after that it was quiet :). So, I disconnected and now tried to connect thru my SIK radio, nada. The remote unit’s led is steady which means it is connected to base (my desktop), however MP can’t connect - please remember that two hours ago I used the SIK radio with QGC without any problems. So, basically, main issues to report - compass inconsistency (yes I did the calibration twice) and SIK radio is not working. HTH. I’d be happy to help in your great effort with issues related to Pixhawk 4.

Best, Gal.


(Roland Mayer) #57

Hello, want to report some strange thing on my setup Pixhawk 2.1, Frsky RC, Kiss 32a ESC, Quad 700.

  • With ChibiOS relay not working on AUX in combination with Oneshot125 or Dshot on Aux.
    with Dshot motors sound strange, no smooth running like with oneshot125
    I have to revise Dshot Kiss esc behaviour - probably it was related to the RC speed setting was 400

  • With Nuttx Relay funktion is ok on Aux in combination with Oneshot125

  • Stabilize, Loiter RTH tested and seems fine but after some flights have seen high vibes in the logs.


    but ACC Imu 1 and 3 seems to be good

    looking at IMU 2

  • when RC speed set 50 there is no Oneshot at Aux Port - ESC detected PWM
    if I set Servo Rate to 50 Oneshot still available
    its not so logic for my understanding because I thought RC_speed ist for IO-out and the new Servo Rate for Aux

just did a flight with ChibiOS and Dshot


Roland Mayer's Copter-3.6 issues
(Rickjames) #58

Reporting back hoping RC-4 would solve a couple issues with a new HEX BUILD (835)

  • Pixhawk 2
  • HERE GPS
  • HEX Frame
  • 370kv motors
  • 10000 Mah
  • LittleBee BLHELI_32 ESC
  1. Running Copter 3.6 I have never seen the safety switch work, nor has an ESC calibration worked
    Still unable to complete these with RC4, I’m starting to think its Hardware related??
    (Even when I changed to OneShot125 protocol for this test flight)

  2. Auto Tune seemingly fails. I have lowered the P values manually to get some stability but wanting to Autotune as I’m sure the computer is better at it than I…
    I have a 6 Pos switch, set to Stabilize ->Alt Hold -> AutoTune
    Lift off in Stabalize switched to Alt Hold for a moment then Autotune however, Nothing happened.
    I do have AutoTune bitmask set for ‘Roll’ only
    Log show the Mode changed back to Alt Hold immediately…

I have attached a DF log if someone could give insights on this… I may flash ChibiOS on this to see if the safetly switch and DShot protocols work…

Also, are there major differences in current draw for PH 2.1 vs Original? I ask as I should be seeing MUCH longer flight time with this build with the 10000mAh battery but voltage droppes very quickly.
Any way to save some power… i.e. Disabling heated etc…?

Thoughts?

http://www.sislink.net/2018-07-08_HEX.bin


(rmackay9) #59

Gal,

Thanks for the report.

I guess this is a new vehicle setup so the FS_THR_VALUE being too high and compass inconsistency are probably somewhat normal setup issue. The compass inconsistency is probably because of metal in the frame interfering with the internal compass. Turning off the internal compass (COMPASS_USE2 = 0) is a good solution especially once you’re pretty sure that the external compass is pointing in the correct direction.

Another tester (Brandon Macdougal) has also reported issues with the SiK radio so it is on our list to look into.


(rmackay9) #60

Roland,

thanks for the report. This is too much to process in this thread so I’ve created a new thread (in the Copter-3.6 category) to dig into this.


(rmackay9) #61

Rick,

Thanks for the report and the logs.

BRD_SAFETYENABLE has been set to “0” so the safety switch has been disabled. Maybe set that to “1” and hopefully it will work.

I think AutoTune isn’t doing anything because it is seeing some pilot input on the yaw channel. I think it’s yaw input because the channel 4 input is about 1498 but the RC4_MIN is 1100 and RC4_MAX is 2000. So that would mean the mid is about 1550. Maybe an RC calibration is required.

It’s not too important but to keep things clear I think it is in AutoTune from “5:32:51.671” to “5:33:02.725” which is about 11 seconds.

Thanks again for testing and reporting back, it really helps!


(rmackay9) #62

Gal, @quadsours,

Tridge and I have found the SiK radio issue and we’ve got a fix that we will release as part of -rc5. I imagine we will release this in a couple of days after Copter-3.5.6 is out.

EDIT: until then you can temporarily set SERIALx_BAUD to “57600” instead of “57” and it should work.