Servers by jDrones

Copter-3.6.0-rc3/-rc4 is available for beta testing

beta-release

(brandon macdougall) #63

Good news I relay appreciate you guys look into this!!!


(Fnoop) #64

Hi, I’ve been testing 3.6.0-rc4 on a MatekF405-Wing. It generally flies and works beautifully using dshot150. I’ve had two problems yet to resolve:

  • Frsky and frsky passthrough doesn’t work. I’ve tried multiple UARTs. What’s weird is that a normally working flvss smartport voltage sensor works fine until Ardupilot is added to the smartport bus, at which point the bus stops working.
  • A 3DR GPS/Compass (of the original pixhawk vintage) is detected and functions, except that I could not work out a correct orientation for the compass. Because of this there was a lot of EKF variance errors and yaw resets, which then makes simple/super-simple impossible to use.
  • A Here/Hex GPS/Compass/LED unit seems to crash the i2c bus. It initially works and you can see the mag and gps data, but at random time periods the LED either shuts off or shuts on permanently and the mag data stops. The GPS data continues.

Thanks for everyone’s work on the Chibios port, it will revolutionise the userbase of Ardupilot!


Dev Call July 9, 2018 2300 UTC
(Gal Nitzan) #65

@rmackay9 thank you and @tridge for resolving that so fast :+1:

Best,
Gal


(Pete) #66

Currently running master with a custom hwdef.dat to get 3 uarts on revo-mini, frsky passthrough telm, wifi telm and gps. Its working well, Tridge fixed the compass orientation so no longer getting compass problems when rotating it about with the motors un powered. However often get ekf failsafes when flying, due i think to compass interference. Hard to remedy on a 180 size quad, everything has to be close together. When it goes into loiter correctly it is extremely good.

I have fitted a current sensor with the hope of doing a compass mot calabration. However when i try from either mistion planner or Qgroundcontroll. It just says failed.

Have tryed through the MP command line too but it just returns rubbish.

Any ideas?

Thanks


(zhangpeng) #67

@tridge@rmackay9

I did not see ChibiOS FW support for hardware “f4light_Revolution” in the update log. Is it common to a hardware motherboard, or is it currently not supported? Are there any specific schedules and plans?


(rmackay9) #68

Pete,

I haven’t tested compassmot recently but it should still work. Of course you’re followed the instructions here on the wiki?


(sevet) #69

I saw the new 3.6RC has many changes to the Marvelmind beacon so I installed it.
I Installed RC5,
For some reason there is no BCN configuration at all on the parameters list/tree .
Is it working on RC4? how can i get it? it is not on the “pick previous firmware”.


(rmackay9) #70

sevet,

If you’re not seeing BCN_ parameters and you’re using a Pixhawk family board then the issue is probably that somehow the -v2 version of the firmware is being loaded onto the board.

To add some detail, we have “-v2” versions of the Pixhawk firmware for boards with the 1MB flash limit (this is a hardware issue that affects a lot of older Pixhawks). Then we have the “-v3” firmware for boards that have 2MB of flash and can thus fit more features.

I guess you’re using the MP so it should have loaded the -v3 onto the board if it can. I think there are at least two options:

  1. download the Copter-3.6.0-rc5 firmware directly from firmware.ardupilot.org (download “ArduCopter-v3.px4”) and then use the MP’s “Load Custom Firmware” link to upload to the board
  2. switch to the ChibiOS builds which are significantly smaller so we can easily fit all features even on the boards suffering from the 1MB limit. Instructions for uploading the ChibiOS firmware is here.

(David Ardis) #71

@rmackay9
When you switch into the new loiter mode from stabalize the deceleration can be quite rapid and there is a parameter to adjust this. I have also noticed that if you are hovering in a strong wind in Alt Hold then switch to loiter it can abe abrupt.

David Ardis


(Pete) #72

Of course, not ruling out any rookie mistakes though, I’m using EKF3 and EKF auto compass learning i guess this shouldn’t make any difference?

I guess it could be a mission planner ChibiOS interface issue.

Thanks


(Leonard Hall) #73

Do you have a log I can look at that shows the aggressive breaking?


(David Ardis) #74

Leonard

I should have a log but would it be more helpful if i did you a video as well so you could see what it was doing well.


(Leonard Hall) #75

A video would be great with the log to go with it!!

Thanks!!


(Chris Olson) #76

David, is this helicopter or multicopter? Me and Leonard figured out different settings for helicopter for New Loiter and those settings are currently in the form of a param file. Just want to make sure, as if you are flying heli you will definitely want to load that param file or it won’t work right.


(David Ardis) #77

Chris it a Multirotor at the moment Heli has no flight controller as its in the Quadplane


(brandon macdougall) #79

mRo radio does not connect using ChibiOS

Frame: HEXA
fmuv3 001A0034 33365109 36353335
ChibiOS: e7b6334c
ArduCopter V3.6.0-rc5 (2301b196)

Edit: will move issue to RC -5 directory.


(sevet) #80

Thank :slight_smile: This was it, I put the -v3 and it worked but in the end put ChibiOS!
The new Marvelmind beacon behavior is impressive!!
Still not perfect, played with the EK3_BCN_M_NSE got some mixed results, when it works it stays perfectly spot on, when it doesn’t, i get weird ground speed data and see my quad on mission planner racing somewhere when its not even armed…


(Liang Tang) #81

Why 3.6.0 release version always be revoked, not enough stable or something?


(rmackay9) #82

Liang-tang,

No, Copter-3.6 seems pretty good. The issue is that we can only beta test one firmware at a time and we need to do a patch release of Copter-3.5.x. Here’s the annoucement.