Copter-3.6.0-rc2 available for beta testing

Copter-3.6.0-rc2 has just been released and is available for beta testing using the Mission Planner’s “Beta firmwares” link (and perhaps similarly in other ground stations). This version has been “rebased on master” meaning that it includes all the developments done by the dev team in the last month. The changes are in the ReleaseNotes and also copied below:

  1. ChibiOS support for Holybro Kakute F4
  2. Range finders:
    a) Benewake TFmini and TF02 support
    b) WASP200 laser range finder support
  3. D-Shot and ESC telemetry support
  4. Vision-position-estimate support for use with ROS
  5. Bug fixes and minor enhancements:
    a) TradHeli swash plate servo trim fixes
    b) SmartRTL gives pilot yaw control
    c) marvelmind reliability improvements
    d) CoaxCopter and SingleCopter output fixes
    e) Maxbotics I2C sonar health fix
  6. Safety fixes/improvements:
    a) GPS/EKF failsafe disabled in Acro/Stabilize modes
    b) interlock switch arming check fixed
    c) Auxiliary switch de-bouncing
    d) pre-arm check for GPS/AHRS difference changed to 2D (to avoid false positives)
    e) startup crash fixed when VL53L0X lidar configured but not connected

Thanks in advance for beta testing this new version. I hope to provide more feedback in the coming weeks to some of the questions posted in this category!


When getting RC2 manually from, which directory should I pull from? Latest, Beta, 2018-06 ?


@lordneeko, from the beta directory. Txs for testing!

1 Like

That’s what I thought but…this is the beta directory for skyviper…

Type Filename Date Size
Parent Directory
arducopter.abin Apr 21 02:19 880K
arducopter.apj Apr 21 02:19 725K
firmware-version.txt Apr 21 02:19 31
git-version.txt Apr 21 02:19 198

In fact ALL of te beta directories in Copter have the same date.

in MP running chibiOS will not give you the build software name unlike Nuttx.

example: Frame: HEXA
PX4v3 00350024 3236510D 36363331
PX4: b535f974 NuttX: 1472b16c
ArduCopter V3.6.0-rc1 (d575d5e9)

can we have a chibiOS name as well? like ArduCopter V3.6.0-r2 (d575d5e9) chibiOS.

1 Like

Right if you install the beta of MP and go to the install FM page select " Beta firmwares" rc-2 will show up on the copter modes. MP also will show the chibiOS version during the fw install.

Flew 3.6.0 rc-2 ChibiOS on F450 with mRo Pixracer. All went well in Stab, Althold, Loiter, PosHold, Circle, Mission, RTL and Smart RTL.
Motor ESC Telemetry with BLHeli_32 with D-shot set works as does BLHeli pass-threw programming function.

Re: Smart RTL, Yaw works now throughout flight and copter faces next retuning waypoint ( I don’t think it did in rc-1).

I wonder if the “RTL_Cone_Slope” function can be used to prevent the decent from being so liner on the final leg?

Example: Take off, climb to 50 feet vertically, then fly around and when retuning by Smart RTL, on the “final” leg, the flight path slopes down to take off point getting me bit too close to the (real) fence in my side yard. Can’t seem to make it go to that initial 50 foot climb point, then descend. That 's why I wonder about the “Cone” parameter.

So far-so good. I will fly later today with Pixhawk machine if possible.
Great job again.

1 Like

I think normal esc calibration is not working even if disabling the arm switch.

1 Like

Doesn’t answer my question about the layout of the firmware drop location…

Re the dates on the files, there’s a web page creation issue there. They have been updated and if you open the git-version.txt file inside is the actual version included. The date on the file on the server has also been updated but on the web page it appears as an old date. It’s on the list to fix but does not real harm except that it adds confusion. txs again for testing!

1 Like


Thanks for the testing and feedback, it really helps. Yes, I think we need to try and do something at the final stage of SmartRTL…

Installed chibiOS on my mRo v.2.1 hex flew well in stabilize but Loiter was jerky in zed.

hi Randy, could you pls confirm how exactly dshot support works on pixracer? it has only 6 pins for esc connectors and when according to wiki i altered servo outputs, it did not work. but it seems if i alter only motor type param - it works - but, pls, could you confirm what exactly needs to be altered?

Paul, I saw you question and on a PixRacer you only set the MOT_PWM_TYPE parameter to “4” to enable D-Shot 150. If you look carefully at the Wiki they only mention the need to change outputs and alter settings for PixHawk type boards. You don’t need to alter the individual port settings (33,34,35,36) on a “PixRacer”; as it doesn’t have the same hardware (an additional co - processor) as on a Pixhawk. I am guessing in the future that may change for Pixhawk; we will just have to check the Wiki as additional releases come out… FYI, on my PixHawk machine, I moved the ESC’s to the AUX ports and changed settings, as per the Wiki, and it worked just fine.

Is it only me observing that issue - ?

Hello Sergey, tested on Pixhawk 2.1 with Motors on AUX-Out Oneshot125. Servo on Main-Out work,

  • ChibiOS, Pixhawk 2.1, KISS esc32, Oneshot smooth Motor - Dshot Motors doesn’t run smooth and more Vibrations compared to Oneshot125
  • with Dshot or Oneshot I’m not able to use Relay-Pin

RTL reposition work :grinning:
New Loiter :grinning:
Autotune need less time to finish
NLon max 1 :grinning: with 3.5.5 I had about 800 High NLon and MaxT copter 3.5.5
MaxT below 3000 :grinning:

1 Like

Thank you, I have that issue on Pixracer that has no separate aux and main outputs. Just 6 out pins. So looks like you cannot use Oneshot125 on 1-4 outs with usual PWM on 5-6.

I just concerned by the fact the issue wasn’t got any label in github, so may be this is something related to my config?

with RC1 on Pixhawk-Mini I have the same.
Maybe its related to this
I guess the dev team know that issue

I can’t find the directory for 3.6-rc1 hex and would like to look at something after updating to rc2 yesterday.

Can someone help me locate this file directory and link it here. I looked and looked.

Thank you.