Copter-3.6.0-rc10 available for beta testing

Copter-3.6.0-rc10 is now available for beta testing and can be downloaded using the ground stations’s “Beta Firmwares” links (check that the label under the icon includes “-rc10”).

Changes vs -rc9 can be seen in the ReleaseNotes and area also copied below:

  1. Compass orientation automatically corrected (can be disabled with COMPASS_AUTO_ROT = 0)
  2. Arming/disarming from transmitter can be disabled with ARMING_RUDDER parameter
  3. ChibiOS fixes:
    a) UART baud rate rounding fix (allow 921600 baud to work)
    b) ADC fix to allow more simultaneous channels
  4. Bug Fixes:
    a) Lean angle limit (to maintain altitude) always allows at least 10deg of lean
    b) Attitude Control and PID initialisation fix to reduce twitches when switching modes

Thanks to our beta testers for uncovering those issues and special thanks to Tridge and Leonard Hall for fixing them. I think we are getting close to the final release now.



What are the values for the ARMING_RUDDER? Couldn’t find any info about it.

Is there any compass-related issues for Pixracer on chibios?
Have flied my current setup for month on nuttx version and never noticed such problem: compass # 0 stop working after a few minutes after start up.

0 = disabled for arming and disarming
1 = enabled for arming
2 = enabled for arming and disarming

1 Like


Is the compass failure repeatable? … and does it only happen with ChibiOS? If you put NuttX on it does the compass keep working longer?

Flied a mission with nuttx version and also got compass stop feeding data.
But this time it happened after 11 minutes of flight.
Does this seem like a hardware issue? There are strange spikes all the time.
And another question is why compass still reports healthy even there is no data coming?

I’ve been trying to test it on my pixhawk on s500 frame. Blend gps, sunnysky 2216 and racerstar 28a. I had problems with oscillation on 1 esc. But Not constantly. Didn’t test much for that reason, but RTL was working good :wink:
Hovering around didn’t gave any problems!

1 Like

Sorry but I was messing with this version and blheli suite and after a few good connections I have lose usb connection, windows not recognize the board, but guess what, It is working on Mission Planner via sik radio and seems ok.
Tried all I know with usb and windows don’t let me do nothing, changing cable, restart computer, check other board by usb, reset all parameters, check sr0 params., put blheli params. to 0… anyone have anything more?
Pixracer and MP 1.3.58 and 3.6rc10 copter
Edit:Anyway to flash the board without usb? yes, wifi module, but ftdi or so?

RC 10 runs perfectly well on my Solo.
No glitches so far.
A big thanks to all you developers!

1 Like

I still have the problem that DShot is not working on the pixhawk 2 (cube)
I have a hexa setup and connected the ESCs to Servo 9-14
With Oneshot everything is working fine but if i set Mot_pwm_type to 4, the Pixhawk hangs after booting. It takes anywhere from 10 seconds up to around a minute of uptime. (The orange Led under the cube starts blinking, everything else stops. Telemetry, Data over USB, Motors stop spinning if they were running when the software starts to hang

1 Like

I have loaded on both my Helicopters Copter 3.6.0 rc10 the ChibioOS version. On both Helis with identical FC Pixhawk 2.1 cube and LIDAR-Lite 3 Laser Rangefinder. In both Helicopters the Rangefinder is not working with ChibioOS. But loading back NuttX Copter 3.6.0 rc8,rc9,or rc10 the Laser Rangefinders are working. This is repeatable.
I must let you know I do not connect my Lasers with I2C cables.
It works perfectly on both Helis but with NuttX only.

I’m getting some strange compass behavior on chibios as well, but I can’t even arm it. Fine on nuttx.

should be mentioned in the Wiki that OSD (F4 boards) is only supported since ArduCopter V3.7 seems strange to me because all OSD parameters are available in the beta but not effective… but works great with ArduCopter V3.7-dev :slightly_smiling_face:


Hi, i have a code built from current dev master but i suspect in this area it is same as code from rc10.

the scenario that just happened - a model was attempted to liftoff in the alt hold mode. for reasons not relevant - operator error most likely, or hardware - it flipped over propellers on the floor. immediately after that ch8 was hit - with a function 31 to kill motors.

model ignored that, motors kept spinning wildly, it gave up to 80A at some point trying to spin them, fried motors a bit as it smelled - all this time ch8 wsa on, ignored, so i had to throw a rug on props, step on it and unplug lipo.

it does not sound as something that was supposed to happen, i would guess?

Paul !
Master is NOT release, RC releases come after a kind of feature freeze. 3.6 is in the branch Copter-3.6. Master is an interim, hardly tested working version…

dshot implementation and basic flight modes logic in rc10 and master is same. i am not saying it is a dshot issue, but i know quite well that with oneshot125 i never had motors to keep spinning in any position in any situation after kill switch 31 being hit.

but you are correct, master is not a release, so, if you choose to ignore - ignore.

I would not ignore it. Your log stops right when ch8 went high, so there isn’t any useful info in it.
Did you tested ch8 emergency motor stop before takeoff ? Is it worked before ?

after ch8 was hit it was at least minute or so of spinning, i acted quickly but it had some time to burn. odd.

yes, it definitely worked always before, no exceptions. but i did not have such a rollover in quite q while and do not really want much to re-try it…

Paul, just to overcome possible language issues (English is not my forte) did ch8 emergency stop worked on this specific copter with the exact firmware ?