Servers by jDrones

Control RunCam Split 4 video recording from a radio transmitter

Hi,
I am trying to set up RunCam Split 4 video recording from a radio transmitter using this instruction.
I have Matek f765-wing board with Arduplane 4.1 dev build.
Camera connected to Rx3 Tx3 (as well as C1).

According to Matek documentation
Rx3 Tx3 = USART3 = SERIAL4

So I set (for Taranis switch on channel 7)

SERIAL4_PROTOCOL = 26
RC7_OPTION = 78

When I run system, nothing happens, RunCam always recording, no reaction to switch, no reaction to stick gestures.

According the instruction:

When the camera is connected correctly and the serial port configured correctly you will see a message similar to the following at boot: APM: RunCam initialized, features 0x0077, 2-key OSD otherwise you will see APM: RunCam device not found.

I dont’s see any of these two messages, neither on OSD, neither in Taranis yaapu telemetry, neither in Mission planner.
I can only see
INF RunCamControl MIDDLE

Where I should look for this message?

Also I can’t find in full parameter list CAM_RC_BT_DELAY.
I am flying with Arduplane 4.1.0 dev 26.06.2020 (as I can see in Git, RunCam support added in April).

Should I update Arduplane to the latest dev build?

Any ideas?

The parameter is CAM_RC_BTN_DELAY
The message should be in MissionPlanner
Did you set CAM_RC_TYPE to 2?
Final thing - I seem to remember finding the RunCam serial docs confusing - have you tried switching RX and TX around?

1 Like

Thank you for your explanation.

Updated to the last dev build.
Parameters CAM_RC_BT_DELAY and CAM_RC_BTN_DELAY appears in the full parameter list.

I set CAM_RC_TYPE to 2.
After this I got a message in Mission Planner.
10/4/2020 10:43:15 PM : RunCam initialized, features 0x0077, 2-key OSD

I still can’t control the recording with either the switch or the sticks.
When I move switch - in telemetry I got “RunCamControl HIGH” / “RunCamControl MIDDLE” / “RunCamControl LOW”, but no reaction from the camera.

If I move left stick “Enter” - no reaction.
If I move right stick “Right” - OSD disappered, after I move it “Left” OSD appeared again, only if RunCam connected normally (Rx to Tx and Tx to Rx).

Can be issue with the port speed?
Any ideas?

Sounds like you are getting closer - features 0x77 sounds correct. So whatever way round you have wired to get that is correct.

Can you post your other CAM_RC_ settings? Not sure what the message is seems weird - I’ve not tried this on plane, maybe there is some problem there.

Thank you for you answer.

My RunCam settings:

CAM_RC_BT_DELAY 7000
CAM_RC_BTN_DELAY 300
CAM_RC_CONTROL 10
CAM_RC_FEATURES 0
CAM_RC_MDE_DELAY 800
CAM_RC_TYPE 2

It’s very important that autorecording on the camera matches the value in CAM_RC_CONTROL - your setting indicates that the camera is set to NOT autorecord. If it is set to autorecord then either change this on the camera or set bit 4 (add 16 to your value) on CAM_RC_CONTROL

1 Like

I just checked on my Split 2s - all worked fine. I was able to start and stop video with RC8_OPTION=78

Thank you for the explanation. After I set camera autorecord off in the camera settings, I can enter in camera menu using sticks, and even switch recording on/off by sticks, but not with the switch.
And looks like the camera menu and OSD are out of sync.
Controlling the camera is not entirely clear to me, the same actions lead to different results, for example, sometimes the camera turns on in recording mode, without the indication of a red blinking dot on the video-out, which cannot be interrupted even by hardware buttons on the camera itself, only by turning off the camera power.

Any ideas?

I just looked at the manual - the Split 4 does not support camera mode so you should set CAM_RC_TYPE to 1

1 Like

Thank you for your prompt reply. After I set CAM_RC_TYPE to 1, camera menu and OSD are in the sync, but not possible to turn recording on/off, and only reaction on switch - message on OSD: “RunCamControl HIGH” / “RunCamControl MIDDLE” / “RunCamControl LOW”.
The ability to turn the camera on and off with a switch is the most important for me.
Any ideas?

Ok getting closer. With everything booted can you start and stop the recording using the RunCam buttons?

Yes
     

Might need to give you a debug build to try - have you got the latest firmware for the split?

Yes, I have updated RunCam to the latest firmware 1.1.5.

Might need to give you a debug build to try

Let’s try

What flight controller do you have?

I have matek f765-wing with a camera connected to Rx3 Tx3 (they are aligned with Camera1 connector)
Do you mean run a debug build for troubleshooting?
It seems to me that runcam 4 split don’t understand recording command, may be it’s different for this model?
I tried to fly the latest debug build over the weekend without success so if possible I prefer to incorporate this code into more or less stable build.

Very interesting, I gave up on getting this to work a month ago or so with a RunCam Hybrid. I wasn’t aware AutoRecord should be off, so I’ll try again.

Just tried it again and I’m having very similar results with the RunCam Hybrid. I can’t get the switch to control start/stop behaviour, with neither auto record on or off. All I see is the messages RUNCAM LOW, MIDDLE, HIGH.

I tried both CAM_RC_TYPE 1 and 2 - assuming the Hybrid is a 3-mode cam that can be in 3 states: recording / stopped / QR reader for configuration. Is that assumption correct?

Strangely, with either type set, it always seems to report “5-key OSD” in the “features” message. Maybe it causes confusion that the Hybrid could be accessed in both ways: It has a dedicated 5-key keypad input for setting the FPV cam, but the HD/4k cam is controlled by 2 buttons. Both are strictly separated and have different menus.

Question: CAM_RC_FEATURES is not featured on https://ardupilot.org/copter/docs/common-camera-runcam.html - what does it do? It is set to 127 - is that the correct default?

Thanks!

Features is populated from the camera handshake, you should not have to set it yourself. Interesting that it reports as 5-key OSD. That might account for the issues. I’ll post a couple of debug builds so that we can at least see what is going on - what flight controller do you have? Or if you are happy building your self set RUNCAM_DEBUG to 1 in AP_RunCam.cpp

Building is beyond my knowledge, sorry - I’m just an end user. :wink: The FC I tried it with is an F405-WING. I’m planning to fly the plane tomorrow, so I’ll disable all the RunCam control stuff for now. I will probably be able to test it on Sunday.

Servers by jDrones