Constantly beeping ESC and jerky motor

Currently I am working on my first project related to RC models. My vehicle is a V-tail plane, as shown in the following image.

. I am using Pixhawk 4 controller, Graupner MX12 RC transmitter and a GR12 RC receiver on the plane itself. The MX12 transmitter has been set up to control V-tail fixed winged aircraft. I have successfully calibrated the accelerometer, GPS, and compass. Servo functions were also set accordingly, as suggested here. My throttle output pin is therefore the main pwm pin number 3. The next step for me was to calibrate the ESC. I am using a Red Brick 70 A esc. Both the ‘all-at-once’ calibration and ’ Manual ESC-by-ESC Calibration’ failed for me. However, after the manual calibration, the motor began spinning when my throttle stick was at its maximimum position. Then, using trial and error I managed to get everything to work well after using the alternate esc calibration method as written here.
The RC channel throttle input to the pixhawk had a PWM approximately in the suggested range of 1100 to 1900. However the servo output at the main pwm out number 3 which I used for the ESC had the range as shown in the following image. . I then proceeded to connect my servos for the v-tails and ailerons. After I tried powering everything back up again all hell broke loose. The ESC(or the motor) began to beep incessantly about once a second, as the motor seemingly could not start and began jerking. What could have caused this problem? All my connections are solid and the connectors used are really sturdy. What other information about the system should I write here so you guys could help me out?
With regards,
Emir.

Your min throttle is to high and the ESC is beeping to notify you that it does not get a low enough throttle signal to arm itself. The motor is jerking, because the ESC is using the motor coils to make sounds, so the motor sometimes moves a bit.
Setup your transmitter without any mixing to use it with Arduplane.

2 Likes

But when I lowered the servo 3 minimal value to 1100 it wouldn’t spin anyway. I heard people are having a hard time calibrating their expected input PWM values for the red brick escs.

The motor should not spin when the throttle is at minimum. Just calibrate your ESC directly connected to the receiver and then set the servo out values to match the input values. And do not use a v-tail mix in the transmitter, it may work in manual mode, but not in any other flight mode. The autopilot will do the mixing after setting the tail servo outputs to servo function 79 and 80, not 19 and 21.

1 Like

Thanks, everything worked well.

Hello
I am facing a similar issue. Can you please explain what exactly do you mean by matching servo out values to input value? What exactly do I need to change in transmitter or mission planner?
This issue is bothering me a lot and I can’t find any solution. I am new to this industry. Any help would be great.
Thanks in advance.

Regards
Shubham Thakur

What am I missing?

I found solution to the problem. My tx pwm range for throttle was 1000 to 2000 and throttle range in Mission Planner was 1100 to 1900. I updated the range to 1000 to 2000 in mission planner and the beeping stopped.
Thanks for the help
Cheers.

Sorry, I could not answer sooner. Glad you figured it out yourself!

1 Like

Hello,

This Throttle range issue still eists in latest 4.0.5 Arduplane version.
It is not normal that after doing a Radio calibration, the throttle range is not customized accordingly (range remains at the default 1100 to 1900 values).
I do not rememner that this issue existed in the first arduplane versions I used years ago.

Glad however the problem is easily fixed but both arduplane setup documentation and radio calibration procedure should mention this little annoying detail that blocks any new user from configuring arduplane without pullnig his hair out :slight_smile:

1 Like

Worked for me after I manually changed the MOT_PWM min and max values below and above the calibrated radio throttle values in MP. Similar to @Shubham_Thakur 's suggestion.

PS: Using Copter 4.0.7.

1 Like

I’m also Facing Same Problem. but how to update mission planner range

Thank you. it’s is working my problem solve

1 Like

I’m sorry for late reply. I’m glad you figured it out.

Hi,

The same issue was happening to me. This discussion thread helped resolve it.
My Rig

  • Mission Planner - 1.3.76 build 1.3.8029 - ArduCopter V 4.0.7 (0bb18a15)
  • T-Motor 2216/KV 880
  • ESC - HobbyWing - XRotor - 20A
  • PixHawk 2.4.8
  • Jumper T12
  • Receiver - Jumper R8

This is what I did:

  1. In Mission Planner, ->Confif->Full Parameter List
  2. Changed both MOT_PWM_MIN and MOT_PWM_MAX to 0. Clicked on Write Param. It took a couple of attempts to write the parameter.
  • Problem Solved!!!

The reason I did the above was because I have another copter, call it test copter, with similar build and the above MOT entries were set to 0. I am hoping if somebody could explain the reason for this to work, especially why the difference in values in the 2 cases. I did not set the values of MOT_MIN and MAX manually in the test copter.

I hope this information helps others. And thanks to Shubham and beenjamminallallday to give me the clues.

Sincerely,

Asim

Sorry, It should have ben Config, not Confif :slight_smile:

I was trigger happy, the issue persists.

Upon connecting the FC, all motors start beeping and twitcing slightly. I am able to arm and spin the motors after arming. I am not sure what this beeping bahaviour could do during a flight.

I have calibrated and programmed all ESCs manually using the accoring to the manual.

I have also been calibrate the ESCs using the mission planner, in the using this method

As a test, I have also used BLHELI ESCs 30A on this copter and did not observe the beeping behaviour.

Below are my Radi Calibration values
image;

I changed the servo values below, based on my understanding of the resolution of this issue, please see the screnshot below

Issue persists, please help.

Thanks

Asim