Motor arming issue (continuously beeping) on pixhawk and mission planner

Hello, I am building a arduplane on new skywalker aircraft.

Motor:- T-motor AT 2820 830kv
ESC:- T-motor T60A 400Hz
FC:- Pixhawk 2.4.8
GS:- Mission Planner
tx/rx:- Taranis QX7/L9R

Everything seems to be working fine except for ESC and Motor is continuously beeping with pixhawk blinking yellow repeatedly. There’s a slow beep on powering the pixhawk and when I push the switch the beeping speeds up. There is no pre-arm failure.

I Calibrated the ESC by connecting it to 3rd channel of receiver. The esc and motor are working fine. The issue arises when I connect it to the pixhawk. Is there any parameter I should change. I can’t find any solution to this on other threads. It’s very frustrating as I am looking for a solution since 3 days. Is there anything I should do with ESC. Am I missing anything?
Please help :blush:
Thanks in advance.

here is the link to the video of the issue.

What is the Esc you are using and make sure If Esc need 5v input to get signal from the pixhawk.

It’s the wrong way to calibrate the esc the beeping meaning the esc get the pwm duty cycle higher than minimal calibrated value, just recalibrate with the esc calibration on gcs.

I found solution to the problem. My tx pwm range for throttle was 1000 to 2000 and throttle range in Mission Planner was 1100 to 1900. I updated the range to 1000 to 2000 in mission planner and the beeping stopped.
Thanks for the help

Could you please help me to how to set the throttle range is mission planner,

Do you mean Or are asking about

Thanks man it helped