Constant Height in AltHold

Hey guys!
I’m currently flying without GPS and relying mostly on a down facing lidar.
During althold i fly over obstacles and i wish the drone to keep its height and not respond to changes.
I have some flights with RNGFND_FILT = 0.1 and 5.0, and another flight with PILOT_ACCEL_Z = 150 and 10.
I turned off obstacle avoidance (I think) and still nothing is working and the drone reacts to the obstacle.
In the logs attached I fly above a cardboard box and back (so 2 spikes in the CTUN.SALT).

RNGFND_FILT = 0.1
PILOT_ACCEL_Z = 10
PILOT_ACCEL_Z = 150
RNGFND_FILT = 5.0

Do you guys know a fix for this issue?

Thanks,
Martin