Connecting RC by MAVLINK, Crossfire, Matek F405 Wing

Thanks for confirming the need for an external WiFi router/hotspot! I asked the question on the TBS FB page and was told, not too politely, that it does not need that and I am just stupid. I wasted many hours trying to make the connection directly to the Crossfire AP work!

The Mavlink option that keeps on turning off is a pain, and so is the bluetooth connection that keeps on dropping and they (TBS) keep on “fixing” it but not really fixing it.

Seems like the TBS Crossfire Mavlink option is less than mature, sadly…

The Mavlink (V.1) connection of TBS Crossfire was quite ok until v3.75 via Bluetooth.
Since the update to 4.0x and Mavlink2, the Crossfire implementation has a lot of unresolved issues.

i wanted to help you but cant because i dont know about arduplane because i have a copter with apm 2.8.

@Steviegeek, were you able to connect CRF with MP? If yes, could you please publish the wiring diagram and parameters (Solved)? Also please point out any bugs.

I am interested in testing your setup, and I had posted a similar question at this link:

@RizHass
I’ll try and get this together in next few days.
I’m using the old v1 CSF module so I use bluetooth not WiFi
Steve :slightly_smiling_face:

Hello!
I confirm it is possible to get telemetry from vehicle but not possible to send commands
Well… It works at the bench but I cannot manage in real flights conditions.
Honestly, I’m disappointed in crossfire now.
Also telemetry range is pretty limited for me for about 10 km.

The same vehicle, the same antenna placement, same route it was possible to get telemetry from 30 km with R9

Look at the RCWare RX2SIM interface {SBUS/PPM/PWM/DSM2/DSMX/DMSS} --> USB-Joystick (and others). I use a Hitec Aurora 9 Tx with 2.4 GHz module, and an Optima-D Rx sending SBUS to the RX2SIM on the GS PC, while another Optima-D is connected to the F765 FC, controlled by an RPi0w with UAVcast-pro and Huawei 3372h G4 modem (the other 3372h is connected to the GS PC). Works at home, still to fly…

I’m very impressed by the RX2SIM since I map 8 channels to it all as fully proportional “axes”, and four of these also map to 9 switches. Some el cheapo Chinese SIM pirate dongles I have tried are nowhere near as good, taking only PPM input and not mapping all the channels or doing many switches correctly. I think you may find it useful, since it really works and takes many protocols.

Hello all, I want to join the discussion. Yesterday I got to connect with Qgroundcotrol and Missionplaner via WIFI and UDP port : 8888

It worked, however it was really slow loading the parameters and sometimes was no giving me the full parameter download so I got limited functionality.

Any help please?

Yup. That’s what it is. Many of us have hit the same wall. MavLink on CRSF is just not ready yet. Yes, it will connect but in my case it was 20+ minutes to download parameters. I’m hoping there is an update on the horizon that will make it worth all the money I spent.

Would it be better using Bluetooth?

I don’t know. I’m using the MicroTX V2, so bluetooth isn’t an option for me.

If you ar talking about a separate BT radio it would work but I think those radios are a pain. I use WiFi radios (ESP8266) on most models, I find them easier to deal with. The ESP-01 versions are dirt cheap. But they are no speed demons either at downloading logs.

I am using the crossfire Bluethoot and the internal laptop bluethooth. I tried and it worked for me better than the crossfire WIFI. It takes a bit to charge the params but then works fine.

What effect would have choosing MavLink 1 or 2 protocol in the UARTH that connects the telemetry?

I have discovered that QGrouncontrol works way faster when using Mavlink telemetry over Bluetooth than Missionplanner

Hi guys,

Recently also got a TBS full size TX and a Diversity Nano RX.
TX is set to dynamic power sitting on my desk, stock antenna’s, currently on 10mW TX power.

I’ve got the matek F765 board, and am also having issues connecting to Mission planner.

Setup is as follows:
Mission planner on PC -> UDP connection -> phone wifi hotspot -> XF Wifi (on the TX) -> nano RX -> Mavlink2 -> Flight controller (set to mavlink2 on telem1 to suit this configuration)

I’m using firmware 4.10 on the full size TX. The release notes state: (among other things, just listing relevant points here)

  • improved: MAVLink message routing
  • fixed: turn on WiFI after re-enabling the RF
  • fixed: MAVLink bluetooth disconnection issue
  • fixed: CRSF telemetry to WiFi module
  • improved: MAVLink library updated
  • improved: internal code restructuring

So it looks like some important bugs were fixed thankfully.

However, when connecting to Mission planner (version 1.3.74) and connecting takes a very long time. Usually around 8 minutes. There are a lot of “already got param” messages.

The link quality also looks like its trash:
image
However, this may be reporting incorrectly, I’m not sure yet, see this comment here for more details, basically, Mission planner thinks there’s a buttload of dropped packets if one of them were to arrive out of order: https://github.com/ArduPilot/ardupilot/issues/9752#issuecomment-437703166

I’ve just updated the full size TBS TX to the beta firmware v4.11
Release says only one thing:

  • improved: MAVLink stability

Testing the connection with mission planner, I’m now getting 14-36% link quality, and a connection time of 1 minute, 2 seconds + however long it took me to unlock my phone and start the stopwatch (~20s). A marked improvement!!

I still need to switch mavlink to ON in the XF Wifi menu on the TBS TX every time, but it auto connects to my mobile hotspot as soon as it appears and the rest just seems to work. Still somewhat dissapointed in what I thought would have been a great “it just works” out of the box experience. The connection to Mission planner just dropped while typing up this forum post. Now wondering if I should have just got a dragon link instead (probably should have!!).

I’m spending a ton of time basically beta testing a feature which is a core part of the product! Ridiculous. True connectivity they say… I’m not seeing it here. How long has this module been for sale?

They also don’t have their own forum - just a facebook group. Posts are quickly drowned out in the noise as there is no categorization of topics. Not impressed.

Anyway enough moaning from me. Hopefully another update or two and this will work strongly.

Todo: Explore using the crossfire radios as a serial bridge, and use the Serial RTS pin on the FC to improve performance. Looks like this is only possible over the bluetooth module. Btw windows does not play very nice with bluetooth COM ports, just something to keep in mind, isn’t always TBS’s fault if BT doesn’t want to connect - works great with android, and should work well with linux systems.

1 Like

I tried to use Crossfire WiFi, yes, the parameters loading is terrible slow. For me the Mavlink 2 is a bit faster. The mobile MP is working, but QGround not (when using ESP8266, it is working well). Is there some way, how to set port 8888 in the QGC application?

On QGroundControl, go to the create new connection screen, scroll down and you will see the port options and you can just enter the port number: 8888

Thanks, I will check it.
I will also check, if TBS released ver. 4.1.1 also for my micro Tx. In the Crossfire WiFi currently I have ver. 1.41 and Mavlink is still ON.
I have same thoughts about TBS as you. Before I was also thinking about Dragon slight_smile: From TBS I received info they are working on it, so hopefully…
I am using F765 and Ardupilot, too. Yesterday after flashing different FW version I lost all my parameters and after recovering them from the backup file not all have been recovered - also a strange behavior…

Let me tell you a story. I have a 3d printer from Tiertime that has a bug that is central to their proprietary 3d printing software resulting in prints with half or less the strength of comparable printers. 2 years I waited for a fix. Still nothing. They finally have a alpha release that sort of fixes it and introduces other issues. Lots of promises and deadlines that were never met.

No.
I won’t wait for fixes, the product is advertised as fulfilling this feature and it does not sufficiently deliver. How long has it been released? Several years? They have had plenty of time. I already feel misled and won’t have the same happen again what happened to me with Tiertime software. If I don’t have this working over the next few days I’ll be returning the product.

Yes, mainly software guys need far more control when releasing something.

1 Like