Servers by jDrones

Can't disable EKF3, can't arm without compass

Hi everyone. A friend and I are using arduplane 4.1.0 dev in order to use the DJI FPV system OSD. I have a matek f405 and he is using omnibusf4pro. The issue is neither of us have a compass on our planes, and we cannot deselect EKF3, and EKF3 will not arm without compass even with COMPASS_ENABLE = 0. I have tried turning AHRS_EKF_TYPE = 0 and EK3_ENABLE = 0 then rebooting, anytime I enable EKF and reboot it just resorts back to EK3. . Tried EKF type to 2 and EK3_ENABLE=0, still not working. I have ARMING_CHECK set to 1018 (no compass required)

Any ideas? Currently can’t arm and fly at all.

Specifically it looks like the INS parameter in the arming checks does this. I can disable all and it will arm, currently at 426 for the bitmask and it will arm without INS

EKF3 is the only option with 4.1.0-dev and 1Mb boards. Good time to move to H7 boards.

COMPASS_USE?

Also set to 0. Really not interested in ripping my FC out of several planes for this… I’ll probably run in the danger zone with reduced arming checks.

This is currently a known problem - we are (hopefully) working on a fix

If I try to fly without the arming checks or compass is the EKF3 even going to be able to do autonomous modes like RTL?

So there is fix that was merged yesterday that will make this a little better - when did you last sync?

I uploaded today’s build and now I can’t arm with arming_check at 1018 but I just get the message “AHRS Not healthy”. velocity_horiz is red with a value of “Off” and pos_horiz_abs is red with a value of “Off”.

EDIT: I disabled airspeed check (arming_check now 506) and it will arm. So INS checks are now passing.

Servers by jDrones