BlHeli_S passthrough


Help please on setting up the ESC with the firmware “BlHeli_S”. BlHeliSuite does not detect connected ESC, the screenshot shows the Arducopter settings and the error that BlHeliSuite gives. ESC definitely working through BetaFlight all programmable.

1 Like

Me too facing the same problem.
ESC-Special Edition Racerstar REV35 35A BLheli_S 3-6S 4 In 1 ESC
Pixhawk clone [white shell] 2.4.8
Tried one shot 125 & D shot 150.

Since around 2 month with the last copter beta the BlHeli_S passthrough its not working anymore here, too.
I can’t remember exactly from whats release its stopped working but it was working in the past!
(I’m using a pixracer)

Hi all

I have updated the firmware ChibiOS and the same thing happens to me

I followed the instructions of the wiki:

And it does not work,

my hardware

Clone Pixhawk [white housing] 2.4.8


Please dev have a look at this, already 4 people reports its not working, I’m quite sure its really easy for all to try bluheli and verify this issue.

I had the same issue as well.

There is an open issue on this, I think it will be addressed when some developer will find the time to do so

BLHeli pass-thru on Hobbywing XRotor micro not working.


Beta ardurover 3.5 ChibiOs
Windows 10
latest mission planner


I have the same issue.
BLHeliSuite is connecting but can not read the ESC setup.

Pixhawk 2.4.6
ArduCopter V3.6.7 Quad
Afro Slim BLHeli


Assuming it’s BLHeli_S (or just BLHeli) it’s not going to work. BLHeli_32 works. I use an old Naze32 FC to program those.

I mean BLHeli. In Beta/Cleanflight passthrough is working. I hope they will fix in soon.

I am using kaute F4 and blheli_s on freestyle copter. Wires are soldered and passthrough does not work. I have to flash it with betaflight every time I want to change ESC settings and then go back to arducopter.

It’s not broken… It’s just not supported… Only 32 is supported.

Get yourself a cheap Naze32 board and us it for ESC programming. They are <$15

The whole point of passthrough is to program ESC w/o having to disconnect wires from FC on compact builds where everything is soldered

Well sure I know that. But Ardupilot isn’t going to work with BLHeli or BLHeli_S and having a dedicated FC for programming is a better solution I think than flashing different firmware. But then I have been using an old Naze32 board for this purpose long before Ardupilot supported any passthrough so it’s routine.

The arducopter manual says:

Now connect a USB cable to your flight board and use BLHeliSuite on Windows to connect. You will need to use BLHeliSuite32 for BLHeli_32 ESCs, and BLHeliSuite16 for BLHeli/BLHeli_S ESCs.

But it doesn’t work with BLHeli_S anyway does it? The manual/Wiki is not always up to date.

I think it is a lot less hassle to re flash firmware than partially disassemble the copter, unsolder and resolder ESC wiring just to change ESC settings.
But using Naze32 could be a good option for initial ESC programming before assembly. What firmware can I use with Naze32 for passthrough ESC programming?

Oh, that’s not good… I don’t know who edited that manual page, but I do know from reading around the forums that no one ever worked on making it work w/ anything other than blheli_32…
I would say that is a pretty serious issue that the manual is wrong. Don’t want people making design decisions based on that, only to find, as you have, that it doesn’t work.