Blheli_32 will not connect to pixhawk1

I have been working on upgrading my esc’s from older simon k Muti-Pal esc’s to Iflight SucceX 60A Plus BLHeli32 ESC. Everything has been wired, I have studied the wicki, and what other info I can find. Currently, I can power up the pixhawk1 via usb or battery and connect to Mission Planner as usual, no problem. However, The Blheli_32 Suite will not communicate with the pixhawk1, The usb connection and com port work just fine with mission planner. I hope I am missing something simple. Any thoughts or direction would be welcome, Can I be the first with this problem?

Make sure your board is powered up using the battery. On my board, Blheli won’t read the escs when the board is only powered by the usb cable.

Thanks for your reply. Yup, got that. Over usb power only, I can connect and communicate with Misson Planner but not Blheli_32 Suite.

this is a screenshot of the debug screen in blheli 32 suite:

The other thing that got me was that I didn’t have SERVO_BLH_AUTO set to 1 to enable the passthrough.

1 Like

I’m pretty sure I got that right. This afternoon I’ll post all the parameters that I have set up for the pass thru.

This is what I currently have installed:
Arducopter 3.6.10
Blheli32suite version

mot_pwm_type: 4 (dshot150)
servo1_function thru servo8_function disabled or NOT set for motors
servo9 thru14 set to motor numbers 33,34,35…
Brd_pwm_count: 6
Serial5_protocol: 16
servo_BLH_trate: 10
servo_BLH_mask: 16128, also tried 0 with no effect
servo_BLH_auto: 1, also tried 0 with no effect

question on firmware as it applies to Blheli32 pass thru.

When looking at the available firmware files for download I see a version called “arducopter_with_BL.hex”

It looks like this should apply to the blheli pass thru, but I have found no reference in the wiki,
and my attempts to load it result in an error message. Can anyone confirm or dispute that this hex file applys to my trouble connecting blheli32suite to the pixhawk?

that is arducopter with the boot-loader, nothing to do with BLheli

are your disconnecting missionplanner? does blheli suite connect to the pixhawk? ie does it connect but not see the esc’s. you have probably found the wiki page already but its here just in case:

Thanks for that, I’m starting to grasp for straws of hope!
So I disconnect mission planner, then use the usb with the same com port, I believe the com port connects, see the screenshot above, then a message comes up stating that the flight controller will reboot, but that doesn’t happen, and I get a message to check the usb cable. power by battery or usb, no different.
The blheli32suite log info seems to suggest its getting hung up on the line: “msp_asi_version failed”

Check older version of BlHeli32 suite. 1.4 or 1.0.

That problem seems to have been fixed with the latest

Do you have the file? I have only found the current Blheli32 suite, but not the older versions.

Well, in the absence of any advice or opinions on this subject I am forced to conclude that:
BLHELI_32 SUITE will not work with a Pixhawk 1.
Sorry, but there is just no other conclusion. No place to turn.

With this in mind, Must I have BLHEILI_32 Suite?
How bout I just forget about the pass thru, and the telemetry, I just need working esc’s.

Can I flash the firmware without a flight controller?
Will the default settings work?

I have been grounded for at least six weeks now. Lots of money spent. Nothing to show for it.
I have been thru all the hardware upgrades and never hit the wall like this.

Thank you all, those who attempted to help.
Harry Courter

“stronnag,” a user on rcgroups states’ “It looks like you need a flight controller that uses MSP as its message API (iNav, betaflight, cleanflight).”

So, that suggests this is a problem with the Arducopter firmware. I am never one to jump to that conclusion, so first, I will ask the question, Has anyone been successful in creating a communications link between Arducopter 3.6.10 and Blheli32suite version, with a Pixhawk1 flight controller? Anybody??..

@Hquarter not with exact Pixhawk1 hardware, but with fmuv3 and various other boards. it requires to mind some steps, maybe this helps:

Thank you for your insight. Unfortunately, no change in my results. No connection between the Blheli_32 Suite and the pixhawk. The BLH32suite log shows the com port connects successfully then fails on the line “MSP_API_Version” See the screen shot above.

As per your advice I did change the servo_pwm_min to 1000 for each motor; Servo_BLH_Auto =1 and the bitmap value has been entered. I’m working with Blheli_32 Sutie v

Not giving up.

As my problem only involves the communication from the BLH32 suite to the Pixhawk, I have a question.

If I have no esc’s are attached to my pixhawk flight controller should I be able to connect the BLH32suite to the pixhawk? Or is verification of the esc’s a requirement to complete the connection process?

Most of the advice seems to apply to the BLH32suite recognizing the ESC’s after the connection is made between the flight controller and software.

yes, if BLH32 is setup correctly in your FC but no ESCs are connected or powered, you will be able to connect to your interface, but not read out any ESC data obviously.
check your BLH32suite window’s top row text changing to “ARDU ARM-BLB @ COMxx” on successful connect.

Thank you, that is very helpful.