Benewake TFmini LIDAR works on Ardupilot

Did you assign USART to correct Serial according to wiki ?

I was wrong, I was testing the F765 connected by USB because I still have not mounted the drone and of course it does not give enough power. Connecting to BAT, everything OK


Do you have reading now?

yes, selecting in the Quick tab “Ragrfinder1” , I can see in cm the height correctly

When I have my TFmini attached to the FTDI to usb module, I see readouts and seems working. But when I check the Pix Mode box, the graph stops and doesnt continue until I uncheck Pix Mode. ???

Hi, I am having similar issues as this post, with Ardupilot 4.3.6 and Navio2/RaspberryPi getting an BAD LIDAR HEALTH message, while using a TF LUNA sensor.
I tried sending it the command you mentioned on this post “42 57 02 00 00 00 04 06” using PUTTY.
However it didn’t seem to have any effect?


I never worked with LUNA but according to this blog you can set mode by switching the mode pin.

I tried it both ways, grounding pin 5 for I2C communications, and connecting it to the I2C port on the NAVIO2, The “BAD LIDAR HEALTH” error message goes away. But there is no change on the Sonar Voltage & Range stay at zero.

Also tried, using two USB-TTL converters, one for the VCC, GND and TX, RX, and the other one to set PIN 5 to 3.3 VDC and connecting it to the USB Port on the Raspberry PI, for Serial communications, again the BAD LIDAR HEALTH message goes away, buth the Sonar Voltage and Range stay at zero…