Benewake TFmini LIDAR works on Ardupilot

It could be an electrical problem. Can you try to have an external 5V bec for direct power.

I just tried an external BEC and neither

Hello ~
Benewake have upgraded TFmini and TF02 to new model TFmini-S and TF02-Pro with better technical parameters and lower cost, welcome to check the LiDAR models comparasion below:

I think Benewake need to implement theTFmini Firmware on Matek F765.

Benewake is one step behind

Isn’t it the Arducopter firmware that determines if the TF Mini works on the Matek F765 board as the TF is just a UART or I2C device.

I think it depends on tf mini version…, im using the s version on a can node, uart and I2c can suffer a little bit the interferences but if you will use a twisted cable for can application you will see a different result


Unless you have very long cable or extremely noisy environment it should not make an impact on signal quality of serial or I2C. Until we can get cheap devices available on CAN, that alternative is still way too complicated and cumbersome for a single device connection

1 Like

I think that can bus can give more features and stability … of course everyone can choose his own way

Why in a pixhawk everything is OK and on
F765 it doesn’t recognize it? regardless of I2C / CAN bus

TELM2 on F765 (F7) is one USART (no UART). >>> SERIAL2_OPTIONS (halfduplex/Tx & Rx inverted) ???

i don’t think that your fc support the can bus…, aside this tf mini uart/i2c can be used on a can node… but as long as your fc don’t have the CAN PORT you cannot use it.
if i remember well f7 support the reverse signal via software

My TFmini is UART type.
Connecting it to Pixhawkit 1 works perfectly but connecting it to a Matek F765 does not recognize it

Seems an UART wiring of the sensor on your fc or a setting

Did you assign USART to correct Serial according to wiki ?

I was wrong, I was testing the F765 connected by USB because I still have not mounted the drone and of course it does not give enough power. Connecting to BAT, everything OK


Do you have reading now?

yes, selecting in the Quick tab “Ragrfinder1” , I can see in cm the height correctly

When I have my TFmini attached to the FTDI to usb module, I see readouts and seems working. But when I check the Pix Mode box, the graph stops and doesnt continue until I uncheck Pix Mode. ???

Hi, I am having similar issues as this post, with Ardupilot 4.3.6 and Navio2/RaspberryPi getting an BAD LIDAR HEALTH message, while using a TF LUNA sensor.
I tried sending it the command you mentioned on this post “42 57 02 00 00 00 04 06” using PUTTY.
However it didn’t seem to have any effect?


I never worked with LUNA but according to this blog you can set mode by switching the mode pin.

I tried it both ways, grounding pin 5 for I2C communications, and connecting it to the I2C port on the NAVIO2, The “BAD LIDAR HEALTH” error message goes away. But there is no change on the Sonar Voltage & Range stay at zero.

Also tried, using two USB-TTL converters, one for the VCC, GND and TX, RX, and the other one to set PIN 5 to 3.3 VDC and connecting it to the USB Port on the Raspberry PI, for Serial communications, again the BAD LIDAR HEALTH message goes away, buth the Sonar Voltage and Range stay at zero…