Autotune: does not twitch until I move a stick

I have just finished assembling and configuring a quadcopter with the following:

500 mm across between motor centres
Pixhawk 2.4.8 FCU
900 kV motors & 1045 props
3S 5,200 mAh battery
Arducopter v3.6.11
AUW 1,480 grams

I have successfully flown it several times now, but it needs a completed Autotune to be more responsive and crisp. However, every time I enable Autotune (in Altitude Hold Mode), there is no “twitching” until I move a control stick. The first pass of Autotune is in the roll direction, but if I manually move the copter in any direction (roll, pitch or yaw) the Autotune will then give one twitch in the roll direction and nothing more until I move a stick again …

I have spent hours plowing through the log files but cannot find any clues as to what is wrong. I suspected excessive vibration, but the vibration levels appear to be OK?

I thought that the Ch1,2 or 4 dead zone might be too small (20) so I increased them to 40.

I then suspected the the 12" props were too flexible, so replaced then with much stiffer 10" props.

Then, I suspected the anti-vibration mount as described here (Autotune does not function unless input is given) so I removed the anti-vibration mount and fixed the FC with 4 small pieces of double sided foam tape. But, that didn’t help either … :anguished:

I have previously built a similar sized Hexacopter and it performed Autotune perfectly. So I am at a loss to figure out what is wrong with this build.

Here is the most recent log file (https://drive.google.com/open?id=1NRnF0DAhdgLW1xIs4tTt_nBmgVO1o6rA) - I would welcome any suggestions or advice as to what I need to change or fix. This issue has me really puzzled …

1 Like

You are sure that all trims on your remote are centered?

Yes, the trims are all set to neutral. I have checked them several times.

If yours RC trims are OK, than I suggest your problem is high vibration on the IMU, it always happen to me too!
Did you check the new guide made by master Leonard? this guide could solve your vibration issue, because it could be ralated to the IMU filtering parameters that you have to set properly depending on your copter charateristics
http://ardupilot.org/copter/docs/tuning-process-instructions.html

Your Y&Z vibrations levels are high and clipping is indicated on both.

Thanks for the suggestions @Giorgio_Rinolfi and @dkemxr, I think we might be making some progress …

Did you check the new guide made by master Leonard?

Yes, I did follow that guide very carefully - in fact, I have just gone through it again to verify that I did not miss something.

Your Y&Z vibrations levels are high and clipping is indicated on both.

Yes, you are correct - I should have attached an earlier log file which has acceptibly low vibrations and no clipping. My first attempt to do a complete Autotune was with 12" props and a vibration damper like this:
image
And this is the VibeX, Y & Z chart, which also shows zero clipping:


According to the information here, “normal levels are below 15m/s/s but occasionally peak to 30m/s/s. Maximum acceptable values appear to be below 30m/s/s”
So I am surprised that Autotune would not work with these values.

My next test was to change the props to stiffer 10" ones, which produced this:


This time, the vibration is higher, but still mostly below 30m/s/s and should be acceptable. And there was zero clipping.

My third test was to remove the fancy vibration damper and just use four 1cm square pieces of double sided foam tape to mont the FC directly to the quadcopter (one in each corner) and retain the 10" props. This is the vibration chart from that test:


and the clipping is no longer at zero:

So, it looks like my original setup (with the 12" props and the vibration damper) is the best option and should be fine - correct?

According to master Leonard’s insructions,

"There are number of problems that can prevent Autotune from providing a good tune. Some of the reason autotune can fail are:

1 High levels of gyro noise.
2 Incorrect value of MOT_THST_EXPO
3 Flexible frame or payload mount.
4 Overly flexible vibration isolation mount.
5 Non-linear ESC response.
6 Very low setting for MOT_SPIN_MIN
7 Overloaded propellers or motors."

With my original configuration, I don’t think that #1 is an issue.
For #2, my MOT_THST_EXPO is 0.65, which I believe is correct?
I believe that the frame I am using is very stiff and apart from the battery, there is no other payload.
Not sure about #4 - how do I know if the vibration isolation mount is “overly flexible”?
I think that #5 is fine, but again, I am not sure what “non-linear ESC response” means nor how to verify it?
For #6, I have MOT_SPIN_MIN set to 0.07 - is that considered a “very low setting”?
And I don’t believe that I have overloaded propellors or motors. Although the 12" props I am using feel quite flexible to me, so maybe much stiffer (rigid) props would be better?

Hi Taipan,

I m working since 3 years with small copter (5" prop) , all my experience with these, its that I cannot see any vibe in the VIBE graphs, but I see clearly how high is the peak of the noise on the gyro if I make a log for the FFT, looking for the noise on the gyro! Than I use the notch filter, you need to enable it in the parameter, match the central freq with the peak in the FFT graph, and so on for the wide and the amount of the notch filter. Before the notch filter on my main noise peak (the propeller pushing on the frame), the autotune is not working, after the notch filter its working, but also the flight performance is night and day.

Hi Giorgio,

That sounds like a good suggestion. Weather permitting I will do a flight tomorrow to gather the FFT data and see if a notch filter will do the job.

It sounds like this is a bit of a “trial and error” process in that the notch filter depth can’t be determined from the FFT graph as the amplitude is not scaled to a useful value?

Where there is the main freq of noise, there is mainly only noise, and you have to eraser it ! :slight_smile: Moreover the notch filter its working very narrow in that, I m using high value for amplitude, also more than 100 db is working good for me, and already 50 db and less is making the autotune working, but fine tuning it make you finetuning also the low pass filter making it lower in some case if you put more amplitude on the notch. You will have a very good tune, you’ll never have without the notch filter.

When I look at the last two graphs above; 10inch and fc supported by carriage and double sided tape versus 10inch and double sided tape I see two things.
The y axis accelerometers become very bad according to vibes and the vibration is high. I will assume that you did not have anything bumping into the pixhawk case. The vibration is something you should address. Have you balanced your motors and have you also balanced your propellers. I don’t know what rating your motors are but 900kv motors I use would not appreciate 12 inch props.
You do not want anything loose or it may vibrate.
The carriage you use to start with is interesting. Could it be too flexible though? I have seem cases where others have had to stiffen the gimble supports because of issues.

20gms of lead on the pixhawk case works quite well with the frugal use of the double sided foam tape under the fc. No carriage.
Assume your motors are square? Bearings ok? There are phone apps you can use to check and balance each motor.
Get the vibration to acceptable levels first, at source.
I try my drones in pos hold. 2m high for a minute or and land. Then peruse the vibes etc.
Use notch filtering as a last resort.

+1 for adding lead weight and everything else @whatgoesup said.

“There are number of problems that can prevent Autotune from providing a good tune. Some of the reason autotune can fail are: …”

These seven reasons can explain why autotune fails to achive a good tune but I believe in your case it fails to twitch. I also don’t see how high vibrations will prevent twitch but will allow to twitch when you move a stick.

I had same exact problem with 7" chibios build, I had to keep doing slight throttle jerks to keep copter twitching and I would actually complete autotune this way. I had several autotune sessions, sometimes autotune would run normally, but sometimes I would have this problem. I didn’t figure out exactly what was causing it, because I finished tuning, but I am suspecting that battery voltage drop under load could be possible cause. I was tuning using old junk battery with high internal resistance and when I autotuned right after charging it would be Ok, but if I let battery it sit for a few hours and/or hover too long before starting tuning, then I would have a problem. However it is not mentioned anywhere that battery voltage can prevent autotune from running.

I am going through the process rignt now of identifying the source of the vibrations and taking steps to minimse them. The propellors had been carefully statically balanced and the motors were (supposedly) dynamically balanced during manufacture, but even so I will check thoroughly their balance myself using the tools suggested above. From the research that I have done (via YouTube), the culpril may be the connical nuts that are used to fasten the propellors to the motor shaft - they are not necessarily perfectly balanced!
image
This can be fixed by replacing them with regular aluminium flanged M5 nylock nuts.

@Johansen
I believe in your case it fails to twitch. I also don’t see how high vibrations will prevent twitch but will allow to twitch when you move a stick.

You have summed it up perfectly - I would love to know, from someone who knows how the Autotune code works, as to what is preventing the Autotune “twitching” to commence that is overcome by slightly moving any stick on the Tx?

I can’t see that the vibrations could be the cause, as the vibrations don’t suddenly drop when a stick is moved?

Even more puzzling is that I have a similar sized hexacopter that has always performed the Autotune to completion and it has similar vibration levels as in my first configuration (12" props, anti-vibration frame) above.

Oh, and I should say that I am using brand new fully charged batteries, so I dont think that low battery voltage is an issue in my case.

These can be very frustrating times. Certainly been there.
When I check the motor balance I start without the securing nut/spinner. Do the motor balance using MP motor test and then fit the the nut/spinner and check. Fortunately I have not have any out of balance spinners yet.
I know through checking that the FC is calculating vibes and clipping in real time. You can check the code. I have not located the autotune code. But it is possible that this may be looking at vibes and/or clipping. Hence its reluctance with progressing autotuning. Possible?
Something you may like to check is whether your hex is clipping as well and to the same extent. I know what has been written about clipping in the wiki but not entirely sure about that definition.
In addition they say high vibes etc can lead to problems in gps modes. This is where I mostly fly so hence my pains at getting vibes low.

I assume you correctly set all battery related parameters and PID scaling voltages