Autotune does not function unless input is given

Today is day for tuning finally, Got it outside up in the air. Switched into Alt hold and flipped the autotune switch. It twitched once then no more until I gave somekind of input. As soon as I gave the input and the stick got back to center it twitched again. I even let it drift and walked with it for 3 minutes and it refuses to continue with the process unless I give it some kind of input. I did not touch throttle at all during this process. Holds altitude well as well.

What is going on here? Am I doing something wrong?

1 Like

Check your Rc trims that all are in 0

I’ve checked trims on my taranis those are disabled. In the pixhawk though RC1-RC4_TRIM are at 1494. which is midstick for me and deadzone is 30

1 Like

If you share a Log perhaps devs or advance users can give you an idea what is happening.

Hello again Jonathan!

You may find some useful information from a similar post here: AutoTune doesn't restart after centering vehicle

I’m afraid I’ll be travelling shortly and won’t have time to go in depth, but I wish you luck in getting the AutoTune completed! Just remember that it may not resume unless the throttle is exactly where it was when you initiated the AutoTune, or at exact mid-throttle. It can be finicky!


Yes i read all through that post. The couple of times I have tried autotune once I set on Alt hold I take my hand away from the throttle. The only stick that gets touched is the roll/pitch. The log I included with this post is from the first attempt. something like 19minutes. I am not sure how to read alot of these things I understand some but am still learning. That being said during the autotune I noticed that If I would give input right when a twitch was finished I could get another twitch almost immediately after stick returned to center. So you may see a period of that. Also there were a couple times I did adjust the yaw during this due to drift but then hand went back in my pocket literally. Anyway thanks for any help.

Here is the log link it is to big to upload here

Oh I should mention as well that I have a sprung throttle. So my throttle stick returns to center when I let go it. I am a helicopter pilot and have it set up this way for that. I have learned to fly with it with multirotors and planks as well. So when my thumb is not on the stick it is at 50%

I always forget to mention that. I forget that most people do not fly this way.

So just a quick update here. Tonight with my flood lights on I went outside after removing the anti-vibration mount. I used some anti-vibration mounting foam to fix the pixhawk to the frame of the quad. The thing auto-tuned perfect this time around. Although afterword checking my vibe logs and the vibes are higher than when I had it mounted to the mount. The mount is the one with the 4 little rubber things in the cornes at 45° angles. So I am not sure why it performed better without the mounting when the vibes were worse. Log is included incase anyone wants to see.

1 Like

Hello Jonathan,

I too am having the same issue with auto tune. Funny thing is I gave up using auto tune a while ago and decided to just tune manually, up until this last firmware update I where it seems PID’s have changed and I can’t get my new copter tuned the way my old copters are. So I decided to try and use auto tune. I’m using the PX4v2 which shouldn’t make a difference, though I haven’t updated my Pixhawk 1 to the latest as its flying perfect the way it is. I recall from previous auto tuning adventures, that mission planner would call out “Autotune start” or “Autotune stop”. Am I dreaming this? Do you get that announcement? Because I don’t when using Ch7 and Alt hold for auto-tune…

To be honest I have not had my quad connected to mission planner while flying yet. So I couldnt tell ya. I will say that since it has a buzzer I do get an audible alert from the pixhawk itself when autotune starts and finishes.
Just to reiterate the issue why my autotune was not working was because of my anti vibration mount. After removing it and just using foam alot of my issues are not longer issues anymore.


That is very interesting - I burnt through three batteries last weekend trying to complete autotune (3.3.3) and all three times the battery was used up after 13-16 minutes without Autotune finishing even a single axis.

I saw a lot of “timeouts” too, i.e. the copter stopped the twitching, sometime I could nudge it into restarting with a small gentle twitch on the Rc only.

I have the same config as you (3d printed dampening mount with soft rubber dampers at 45° angle at the corners).

I will follow your example and remove that mount next weekend and see if it improves things - will reply back so others can also see if there is a pattern…


Yip that was the exact thing mine was doing. IT would also take a whole battery and one axis would not be done about 25 minutes. It is a night and day difference now that I have removed that mount. I want to put it back on and see how it performs now that it is tuned. that being said my vibes are within range without it. So I may I may not. Anxious to see if it works for you!

I have the same vibe plate, I will try what you did and see how it works.

Are you tuning a large copter?
Have you tried to reduce ATC_RAT_AXISNAME(RLL,YAW,ETC)_FILT to 10?
The standard value is 20, but it is not right for some large copters.

Yes I did do that in the very beginning, that worked wonders and allowed it to fly to where I could start the auto tune. But I had to remove the mount to get the autotune to work correctly.

You have to remove the mount?
What does this mean? Can you explain me better this point?

I had my pixhawk mounted on one of these. I describe it in the first post. Instead of mounting it to this I took this mount off my quad and mounting my pixhawk directly to the frame with thick foam pads. Make better sense to you know?

Understood (=
Thank you for explanation, and sorry for my bad english: I didn’t understand at the first sight :stuck_out_tongue:

I usually use this (very old pic, of 4 years ago):

In the pic you see an old APM, but I use this kind of mount also on Pixhawk: I have no problem with it also in autotune.
They are gimbal rubber. I use 8 of it for one Pixhawk (Sometimes I use 4 of it or 6 of it. It depend on the mounting and on the flight controller that I am using).

But I am gald that your problem now is solved! (=
So I think there is nothing more to say :stuck_out_tongue:

So I removed the vibe plate I used for my old PX4 v1 and then mounted the Pixhawk 2.1 with the tape provided in the box and it worked perfect. Autotune worked and it fly’s great without the vibe plate. Go figure.

1 Like

Someone (proficnc) has figured that having damping inside is more effective and reliable than damping outside, and it is one of the main advantages of the 2.1 PixHawk (amongst others)

1 Like