Servers by jDrones

Autotake off issue with Arduplane 3.8

takeoff
ap38

(rscarawa) #21

Another issue I am having is I see I am only getting 94% throttle (1898-1900 us) on take off. When I manually take off, I can see it registers 100% or 1947us. TKOFF_THR_MAX is set to 100. Any idea why I am not getting the rest of that 5-6% power?


(Hunt0r) #22

Take a look at the SERVO3_MAX parameter, see if adjusting that gets the extra power. (Assuming channel 3 is your throttle)


(rscarawa) #23

ch3 is my throttle. Here are my configs for that one.

RC3_DZ,30
RC3_MAX,1947
RC3_MIN,982
RC3_REVERSED,0
RC3_TRIM,982

SERVO3_FUNCTION,70
SERVO3_MAX,1947
SERVO3_MIN,982
SERVO3_REVERSED,0
SERVO3_TRIM,982

Thx for helping.


(rscarawa) #24

I do not have any setting for current limitation either.

BATT_AMP_OFFSET,0
BATT_AMP_PERVOLT,18.0018
BATT_CAPACITY,4000
BATT_CURR_PIN,3
BATT_LOW_TIMER,10
BATT_LOW_TYPE,0
BATT_MONITOR,4
BATT_SERIAL_NUM,-1
BATT_VOLT_MULT,10.3
BATT_VOLT_PIN,2
BATT_WATT_MAX,0


(Hunt0r) #25

I’m doing some digging… maybe some of these ideas will help?

  1. Do you get 100% throttle when flying in MANUAL and FBWA modes?

  2. Do you see THR_MIN and THR_MAX parameters? If yes, what are their values?

  3. Is it easy to try setting TKOFF_THR_MAX to 0? That should set TKOFF_THR_MAX = THR_MAX.

  4. Probably not relevant, but what is your TKOFF_THR_SLEW value? Again, if you set it to 0, it will use THR_SLEWRATE instead.

  5. What is your value for THROTTLE_NUDGE? If you have this set to 1, and your stick is held down during takeoff, that might limit your maximum… if this is the problem, if you push your stick up during takeoff, you should see max throttle achieved.

If none of these solve the issue, I think the relevant code is in Plane::set_servos_controlled() inside servos.cpp…


(rscarawa) #26

I get max throttle in manual mode. In FBW modes, I have it limited as below:

THR_MAX,75
THR_MIN,30

I did this to limit motor throttle to just what it needed for level flight in FBW and auto modes.

I can try setting tkoff_thr_max to 0 and ran THR_MAX to 100% to see what happens.

THR_SLEWRATE,100

THROTTLE_NUDGE,1

I can see if the nudge impacts throttle max too.

Thx for your time.


(rscarawa) #27

Strange. I setup a test where I was going to start the route with the stick idle, progress the stick to full throttle two seconds later and then go back to manual. All three showed 100% throttle. Not sure why it is working fine now.


(Hunt0r) #28

The “Throttle Nudge” idea is my favorite so far… and it wouldn’t be too hard to test. But if the problem is resolved, no need!


(rscarawa) #29

Hunt0r,
Thx for the help. I will do actual air testing on Monday if the weather holds. Looking at past test, they also throttled to 100% on auto modes. There is something odd that happens with my config on a random basis. For instance, I have had my voltage failsafe go off after 1-2 min of flight as the reading of the battery is off. I charge my batteries to 90-95% which puts them around 16.2-16.3 volts. most of the time, the voltage monitor on board measures it right. I have seen a 16v battery read 14.x volts. I unplug and plug back and it corrects it. Maybe there is residual voltage in the system that is throwing it off from the previous flight?