Servers by jDrones

Autotake off issue with Arduplane 3.8

takeoff
ap38

(rscarawa) #1

I am new to the auto takeoff and am having a hard time. I have a fixed wing tail dragger configured but when I add a takeoff to a route, the route never executes. Instead the ground station says ‘Timeout auto’. What is that? All other flightmodes, such as a regular route without take off, FBWA seem to work fine. When I start the process, I get the following messages:

armed auto -, xaccel=-0.1 m/s/s
Waiting 0.2 sec
Timeout Auto.

Is the FC sensing non-existent movement and refusing to start the auto takeoff? What parms should I look at tuning for this?

My bin file can be found on my drive share.

https://drive.google.com/open?id=0B_rKS7jwgyK3VFJ6S29ZbEpZMDA


(tridge) #2

The problem is the TKOFF_THR_MINSPD parameter, which is set to 13. That means “don’t start the throttle until you have reached 13m/s”. That parameter is meant for bungee or catapult launches.
You should also remove the TKOFF_THR_DELAY parameter, which is just delaying your takeoff for no reason.
There is more information here:
http://ardupilot.org/plane/docs/automatic-takeoff.html


(rscarawa) #3

I will give that a shot. I was reading that page but must have gotten crossed up on the different takeoff types. I will let you know if it works.

Thank you

Scot


(rscarawa) #4

I just did a test with the props off and your suggestion worked. Odd thing is I did not configure those values. Are they defaults? If they needed to be zeroed out, the documentation should be updated for CTOL launch to validate these variables.

All good now but it will be a week before I can attempt a real launch.

Thank you

Scot


(tridge) #5

no, they default to zero. I don’t know how you ended up with those set.


(rscarawa) #6

I have a couple more questions on this. I did some testing of the auto takeoff and it seems that the rudder/yaw compensation is either not working or reversed. How can I test to make sure the rudder compensates in the proper direction? I cannot see any setting for yaw P and I tried turning yaw dampening on but I got no response on the ground. I need to make it attempt to respond even with 0 ground speed. My autotakeoffs seem to pull to the left hard unless I intervene. I did have a crash on one takeoff too. Does arduplane assume to hold the plane straight on a tail dragger using only the up elevator? If so, I need to find out how to get rudder to over ride that.

Thx

Scot


(Hunt0r) #7

Were you able to verify the rudder direction is correct via the rudder-mix in FBWA?


(tridge) #8

one thing to watch for is prop torque on takeoff, which tends to make planes roll left on takeoff (assuming a CW prop). Plane 3.8 defaults THR_MAX to 100, which can lead to too much throttle on takeoff and lots of prop torque. I had that on a plane I flew last weekend.
The fix is to set TKOFF_THR_MAX to less than 100 if you don’t actually need 100% throttle on takeoff. Try 75 and see if that reduces the left turn.


(rscarawa) #9

I need 100% throttle for takeoff. As my configuration sits now, the plane depends on the up elevator to keep the tail pinned to the ground to keep the heading maintained. This is not a good idea to use only up elevator for this purpose as any crosswind can overpower the tailwheel traction once you get so much speed. Also grass runways also minimize the ability of up elevator as the exclusive heading hold method for takeoff roll.

When I manually do my takeoff rolls, I am on the rudder all the time and my takeoffs look 100x better than what my auto configuration is doing now and that should not be the case. Arduplane should be able to do better, more consistent takeoffs than I can do manually. Either it is not capable or I do not have it properly configured yet.

I should be done with crash repairs today so I can start dry runs today and test again next week.

Thx


(rscarawa) #10

do I did some basic testing with the prop off, in autoakeoff mode. I ran around like a fool with the model and never saw the rudder move unless the model was rolled. I think that is part of the ail to rudder coordination. I cannot see any way that this model would perform yaw compensation. Atleast while it is under 6 feet. I need it to compensate always. Any idea which settings I should be looking at?

Scot


(rscarawa) #11

I have done more ground testing and found that when the plane is below the ground steering level of 2 meters, the elevator will compensate for yaw movement only in extreme situations. The plane has to rotate more than 90 degrees a second, rudder compensation kicks in. That is a long time to wait for rudder compensation. I am not sure what variables are driving this. I would like much more immediate yaw correction than that. Any idea how to get more response in the yaw? There is no yaw P to help me.

Thank you

Scot


(Hunt0r) #12

While I’ve never done this before myself, I’m looking at the source code. I suspect you want to tune your Ground Steering controller. Can you find some parameters prefixed by “STEER2SRV_”? I hope you can find things like:
STEER2SRV_P
STEER2SRV_I
STEER2SRV_D
STEER2SRV_TCONST
STEER2SRV_IMAX
STEER2SRV_DRTSPD
and some others.

Also, your 90[deg/s] observation was a good one! The default value for GROUND_STEER_DPS is 90, which seems to indicate that at over 90[deg/s] the rudder maximizes deflection to counteract. You’re right that you definitely want the rudder to steer the plane well below this “bad-case limit” type of behavior.


(rscarawa) #13

Thank you for the suggestions. I tried turning all of these dials and nothing seems to impact the response to yaw. Maybe this is because I am testing the plane in hand and it has no forward motion. I do need a way to test these settings on the bench though. I turned that GROUND_STEER_DPS down and up too. No change at all to the rudder response. Still seems to take atleast 90 degrees/sec for the rudder to chime in. Maybe this is a question for the Git Hub?

Scot


(Hunt0r) #14

It sounds like something is preventing the STEER2SRV section of code from being active, but I don’t know if that’s some parameter(s) or some conditions (altitude, speed, etc) not being met.

I think you’re asking at the right place, but unfortunately I don’t have any actual experience with this. Can someone else chime in?


(tridge) #15

if you post a DF log of an attempted auto-takeoff I can take a look
A key parameter is GROUND_STEER_ALT, the altitude below which ground steering is used.


(tridge) #16

also note that you can use ground steering in FBWA mode. I usually tune in FBWA mode, by doing test takeoffs, and throttling back before liftoff. You should be able to go the full runway length without any rudder correction.
Please also post a photo of the plane. If it is a taildragger, then a photo of the tailwheel may help. Some have a high castor (angle of the wheel strut) which causes a lot of issues with auto-steering.


(rscarawa) #17

I will post a photo of the plane and a video tomorrow as I will do more testing then.

Below is a link to my last test that resulted in a crash. You can see that plane yawed to the left hard. I help restraining myself from correcting it as I thought the controller would correct it but it did not happen. I attempted to avoid the crash with the windsock pole with up elevator. More files to come tomorrow. Thx

https://drive.google.com/open?id=0B_rKS7jwgyK3VkhmR1AzbGhUeVE


(rscarawa) #18

Here are a couple more logs with videos. I still have the yaw drift issue. Any recommendations would be helpful.

I think I will keep the tail pinned to the ground a little longer on the next attempt.

https://drive.google.com/open?id=0B_rKS7jwgyK3eHhxZTYtcWFadWs

Scot


(rscarawa) #19

On a side note, I see that the pressure in the fuselage is not well balanced. Upon throttle up, I get a 13 meter drop in baro altitude. Not sure how that impacts the controller but I will try to correct some of it. Too many breathing holes in the front of the fuse and not enough area in the back for the air to escape. I never thought to look into this before.


(rscarawa) #20

I made some progress on this issue. After putting a camera on the plane to look backward on the tail, I could see that the left turn the plane made when winding the motor up was actually commanded. About 2 seconds after throttle up, I could see momentary left rudder that pushed the plane atleast 10 degrees to the left. I looked over my configuration and noticed I had my magnetic declination setup wrong. I had it set to 7 degrees when it should have been -8. I did a retest and the takeoffs are better. Some are straight and some do drift to the left but not nearly as bad. I am not seeing the left being commanded in the video. I will have to see what the logs indicate next.