Autopilot failed with new motors and settings (video and logs posted)

So i am picking up where i left off with this post (potential thrust loss) New to Custom Drones - Potential Thrust Loss - help please :)

i ended up getting larger tmotor mn3510 and 15" props, hover throttle is now at about 17% vs 34% i followed all the numbers givin in previous post as a “starting point” and for some reason it seems to glide so far on its own when rolling left and right, like after i gave it stick input it would then do it again and continue for a bit, strange, so i went to autotune and before it couldnt finish its roll sequence it took a dive, winds were low 1-2mph,

550mm frame
T-Motor mn3510
15" t-motor folding props
2x 5000mah batteries in paradelle
Pixhawk orange cube
arducopter/pilot firmware
t-motor f35 esc using dshot (the 6s variants)
here3 gps

here are the logs

and here is the video

i also input all of these settings as a recommendation (i input my specs and then used the parameters it suggests)

any help would be appreciated, waiting on new props to come in

also it seemed rediculously difficult to get it to stay somewhat in place, like i stated above it would glide to whatever direction i flew it even if i corrected and had it still, like it got an input after i got it stable, u can see me struggling to keep it in an area in the video

The roll PID’s are way off. Set them back to default and make another non-autotune flight. Set INS_LOG_BAT_MASK to 1 so you can prepare to configure the Dynamic Notch filter which is something you should have done before running Auto Tune anyway.

To start with in that log you were only in Alt Hold before autotune, and it will definitely move around with the wind and momentum. Loiter is the mode you’ll want to use, but we can get a bit of tuning out of the way first.
Autotune also moves around like that and you need a lot of space and minimal wind for it to work properly - leave it until later.

Set all these:

And these should be fairly safe values:

Just hover for about a minute or two, if it’s OK just do some gentle movements - and let’s see that .bin log. If there’s oscillations, land and reduce these

thanks for the input both of you, i will do another flight when i get the props, ordered 2 sets just in case, yeah i am familiar with it moving, since i have done this once before but this time was super strange, like after i i would roll left, it would level then roll left again on its own (not just the autotune) and move way more than it would before, but i understand that the settings must be off so ill report back when i get a new log, thanks again :slight_smile:

gotcha, ill do that, ill look up what the dynamic notch filter is as well :slight_smile: i appreciate your time and input

got everything reverted to stock PID’s and then added your changes, was also looking at the dynamic notch filter part that @dkemxr mentioned and am now debating on setting up telemetry since its available- it looks like i take all telemetry cables and tie them into one, and connect them to the RX of a serial port, i was looking at Serial 3 (GPS) since i am using CANbus GPS (here3) , so is the process just that? and then some parameter changes? thanks again

It will be something like this for params
SERIAL3_OPTIONS,16 (experiment to find what works for your flight controller)

thanks @xfacta , ill be soldering all of that in a minute and ill giv it a test sometime tonight

what flight controller do you have? I didnt check in the log
EDIT - OK I see Orange Cube, should be easy enough to get the ESC telem working

sorry for the month late reply, got the covid v2 so was out for about 2 weeks, ill be posting the results later today

alright, im sure the PID’s are off, sticks are sensitive, and on slow decent got SUPER unstable and crash, let me know what you guys think, looks like from logs that the tuning just way overcompensated but im sure you guys will have much better input, using telem from ESCs now, flew stable until decent as you can see in this video - these are the stock pids - just wanted to get the logs

Log (crash log that goes along with the video):

And video

And thank yo uagain for your guys’ input, really been a huge help @dkemxr & @xfacta

ill be making these changes today to see how it does, things that should have already been done but when i reverted to stock PID’s it was from a file that i used with smaller props lol, we will se how it does with these before i start tuning the PIDs, ultimately would be nice if i could get an autotune to not crash.

ATC_ACCEL_R_Max `75000 (current 11000)
ATC_ACCEL_P_Max 75000 (current 11000)
ATC_ACCEL_Y_Max 22000 (current 27000)
acro_yaw_p = .5x 22000 / 4500 = 2.4 (current 4.5)
ins_gyro_filter = 21 (current 30)
atc_rat_pit_fltd: = ins_gryo_filter/2 = 21/2 = 10.5 (current 20)
atc_rat_pit_fltt = same as above (current 20)
atc_rat_rll_FLTD: same (current 20)
atc_rat_rll_FLTT : same (current 20)
atc_rat_yaw_FLTE: 2 (current is 2.5)
atc_rat_yaw_FLTT: 10.5 (current is 20)

land speed 30 (current 50)
land_speed_high - (current 0 - uses WPNAV_SPEED_DN)
pilot_accel_z - note sure yet (current 250cm/s)
pilot_speed_dn - 50
wpnave_speed_dn - 50 (current 150cm/s)

PSC_ACCZ_I to 2x MOT_THST_HOVER = .4 (current 1)
PSC_ACCZ_P to MOTH_THST_HOVER = .2 (current .5)

Use this spreadsheet, it’s also the basis for the Alt A MissionPlanner plugin

EDIT: OK sorry, you’ve already got the spreadsheet
If you get to a stage where tuning is relatively good and descent is still unstable then you can start testing MOT_THST_EXPO as follows

  • set too high you can see instability at low throttle
  • set too low you can see instability at high throttle

I suspect the prop guards you have might slightly contribute to instability

Set all these exactly:

You can copy/paste them into windows notepad, save as “adjustment.param”
then in MissionPlanner full parameter tree: Load from file

You are not getting any ESC telemetry. Did you get that wired up?
If not, set these:

Let’s see that flight, use Althold only, take off, hover for a while, try some gentle movements in pitch and roll (yaw is not so important yet) then land.

ill get those set, ins_hnthc_mode is 3 right now (says to set to 3 for esc telemetry on website) also ins_hntch_ref is set to 1 right now (site says to set to 1 for use with RPM/ESC telem), got about 4 hours of prints to repair the drone, and ill try again :smiley:

how can i tell if my drone is using the esc telemetry properly?

It didn’t have any ESC telem in the log, so set the ones I specified for now. If you get the ESC telem wired up correctly and working via Serial 3 then you can set these again:

If you have ESC telemetry working you will see it in the MissionPlanner status tab something like this without even flying (well probably you wont have current) but you should see the 4 ESCs

gotcha, got it working, i had serial3_options set to rx pull down (16) ended up working when i set it to half-duplex.