Auto mission multirotor heading not changing

I recently flew a auto mission for mapping where the quad I just rebuilt flew to each waypoint however the heading never changed (I.e. drone front never turned to face next waypoint)
Additionally I was unable to disarm the drone with sticks on landing and had to send disarm thru mavlink. Log is below

https://1drv.ms/u/s!AmW8JONezY1Ugf0qNtGPUYeY80RvxQ

I’m using taranis radio
All help is greatly appreciated

Thanks!

For a Cube Black definitely upgrade to 3.6.12 right away - if not jump right to latest stable, 4.0.3 at the moment. I know the original SB2 recommended 3.6.11 but I think further issues were fixed in .12
Ensure your Mission Planner is updated too.

You’ve already got
WP_YAW_BEHAVIOR,2
which is what I would have suggested - try setting it to 1 or 3 and see if there’s any difference.
https://ardupilot.org/copter/docs/parameters.html#wp-yaw-behavior-yaw-behaviour-during-missions

For the landing/disarming issue all I can see is vibes are bit too high which will be confusing the flight controller and it wont be able to tell you’ve landed. There’s some clipping too.
Try the usual: balance props, check for loose items, secure wiring and all, make sure the FC anti-vibration is not being impeded by wiring rubbing or pulled tight.

I noticed there’s a few other parameters you can fix up too, use this spreadsheet to compare against yours:


MOT_BAT_VOLT* and Battery failsafe jumps out at me.
MOT_SPIN_ARM and MOT_SPIN_MIN are practically the same, maybe increase the MIN value a bit to something like 0.12

Hi Shawn

I really appreciate the advice, I hope you won’t mind a couple more questions

  • could you explain further your concern on the battery failsafe?
  • on the heading issue I previously found on another site someone with a similar issue and attributed it to “a yaw control not quite centered relative to what the radio calibration on pixhawk had as center” … actually I’m not sure how to even check that

I will let you know how it goes, and looking forward to digging into your settings… but I work slow so may be a few days

Thanks mike

You battery failsafe voltages and actions are not complete.
I highly recommend you grab a copy of that spreadsheet, plug in your prop size and LiPo cells, then check all you parameters are OK.
At least set these:
BATT_ARM_VOLT,22.1
BATT_CRT_VOLT,21
BATT_LOW_VOLT,21.6
MOT_BAT_VOLT_MAX,25.2
MOT_BAT_VOLT_MIN,19.8
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2
There’s a few other parameters you’ll be able to adjust and then run an Autotune - let is know what prop size you’ve got.

During the mission you Yaw channel is at 1505 and 1506 PWM, yet you’ve got:
RC4_TRIM,1528
Probably some slight error during RC calibration. Try setting:
RC4_TRIM,1505
and see how that mission goes then.

Thank you very much. I’m using 12 1/2” props
I did run autotune back in January after rebuilding, but plan to switch to 13” duel props with higher pitch. I will check all settings as you suggest and Re-tune

Below is a pic of drone- I make the frames and have 2 quads and one x8- still learning settings and tuning and always need to lean on others with more expertise!
https://1drv.ms/u/s!AmW8JONezY1Ugf0pj5T4R9M0HyssSQ?e=1frtg6

Ps

If you could point me to any posts on holding height with better accuracy that would be great. I believe all 3 drones use barameter and as I mostly fly with the controller uncovered the drone height is not well maintained in altitude hold

Thanks