Arducopter 3.6.9 made sudden crash from 10 meters

I was testing 3.6.9 version for third time. After 2 minutes of flying I tried to took her back to rtl. Suddenly 17m height motors just stopped and she crashed down. Now there is lot or work to get it back to flight. Batteries, part of frames etc has to be fixed. It would be good to identify problem why emergency mode went on and what actually caused blackout for motors. It was third flight with AC 3.6.9.

98 14.6.2019 (925.7 KB)

I noticed two things: 1. RXRSSI value was gradually degrading during your flight. 2. All RCIN channels jumped at the moment of motor emergency stop.
Could it be a failsafe? If your rx is set to output preset values on F/S then it might not show on log as radio F/S.

ch8_opt set to emergency stop, and failsafe set on ch8 to high. Seems your radio failed and went to failsafe.
Disaster encoded…

Hi Tom

On channel 8 you programmed „motor emergency stop“. If you look on RCIN.C8 you can see that it was on high for several times switching of the motors
So I see the following rasons for your crash:

  1. you switched it on accidentially
  2. you had a failsafe on your receiver leading to switch CH8 to high
  3. problem with your receiver, because all the other channels also went crazy when your copter went down.


1 Like

thank you for all answering. It is obvious problem is located in tx or rx. I made yesterday long testing phase for both and there are short periods when all channels create agressive movements. It lasts 2-3 seconds. thank you for all answering and helping with this!
Same problem occured couple of months ago, but it disappeared.

Would be nice to get feedback of the root cause after you solved it

It would be great to solve this, but this gets more complicated features. I have Holybro Pixhawk 4 as fc and Skydroid M12L as tx. Rx from same company as well. I reinstalled Arducopter 3.6.9 chibios to Pixhawk with qgroundcontrol to try if same random problems occurs with that program. After 2 hours of testing no sign of errors. Same with missionplanner. I also reinstalled AC with missionlanner but no sign of erroneous commands. Only explanation is that original Arducopter installation in pixhawk had problems. This is really weird as similar errors occured last december in test bench, luckily not during flying. I have no idea how to track this problem more because all systems are stabile now.
So as brief, reinstallation of Arducopter cleared random errors. But why rcin had those weird crazy errors, should that be pure incoming data without touch of Fc?

Perhaps you have an issue with Skydroid M12L. It is quite new. Have you tried another RX/TX.

I have used older pixhawks and other F4 fcs with arducopter and betaflight but not sign of this kind of errors. Maby there could be some clue in logfile but it will take lot of time. I tried pixhawk4 also with frsky r9m / nv14, also no problems yet. pretty complicated case.

Looks similar to the weird patterns that caused other crashes due to an S-Bus bug of Pixhawk 4, see Cumulation of crashes due to seemingly weird input (Pixhawk 4)
It should have been solved since AC 3.6.7 but still seems to be unsolved.

I replied to that thread and added this story. Thank you