Appeal to solve issue! MAIN_OUT 3?

Appealing to anyone that knows anything or everything, all help massively appreciated!

I have gone through the setup process many times and the best I have is 2 servos working but not the motor.
MAIN OUT slot 1 and 2 work perfectly (with servos) and even when I have the ESC in either 1 or 2 I can control the motor with roll or pitch input…which makes sense.
However, when i put the ESC wire into MAIN OUT 3 (the throttle port) nothing ever happens even after holding arming button and arming with the RC sticks.
I have calibrated the ESC a few times outside of the Pixhawk but have not been able to calibrate it while all wired into the Pixhawk.
Hope the photos cover all the necessary items.

RC = Spektrum DX6e
RUDDER_ONLY = 0 (Disabled)

Thanks for all replies!

Exact Pixhawk >

I will assume you are using the Arduplane firmware.

There can be several reasons why it will not arm the motor.

What you need to give us is the log file from the Pixhawk.
When you try to arm the motor do you have the PH connected Mission Planner?
If not, then that is the starting point.
In your flight data window select the messages tab.
When you try to arm what message do you get?
You can set logging in parameters to log while not armed.
Can you do that a do a power up and try to arm and post the log.

You would also get more people to see your post if you used the correct forum, which in your case would be the Arduplane forum.

Thanks for the reply. I will reupload in the correct forum.
Yes I am connected to mission planner and using the latest Arduplane firmware

u-blox 1 HW: 00080000 SW: ROM CORE 3.01 (107888)
GPS 1: detected as u-blox at 115200 baud
PX4v3 0041003D 3436510C 32393637
PX4: f84ee497 NuttX: 2f230473
ArduPlane V3.8.4 (e62e40a5)

There are two log files in .bin format but the larger one wont upload. It is 2,000kb and the limit says 4,500kb so not sure why it cant upload
2 01-01-2000 00-03-02.bin (992 KB)

FYI I have moved this post to the Arduplane category for you.

Can you perform a test where you give it plenty of time settle, and then try to arm a few times with a decent gap between tries.

Only thing I spotted was the direction of the rudder.
Is it going int he right direction?
Have you tried the rudder in the other direction?
There were no error messages so it could be that simple.
Have you pressed the safety switch? (but that would generate an error message in MP)

Pitch and Yaw are connected for some reason. In the radio calibration window rudder input moves the YAW and PITCH likewise, PITCH input moves PITCH and YAW. Could this be a configuration issue on my transmitter or a setting somewhere within pixhawk/mission planner?? I get the feeling it is my servo setup within my transmitter.
From the Radio calibration window the rudder is moving in the correct direction.
**I just tried MAIN OUT 4 and the motor works with both pitch and yaw input so i suspect this is the issue…MAIN OUT 3 is being overridden by MAIN OUT 4 due to the above issue. Don’t know if that’s even possible but i suspect its something to that effect. Regardless, I need to somehow separate this yaw and pitch.

To arm i hold down the safety switch until its displays solid light, release it and put the sticks down and centre like a DJI Phantom motor start.
I re uploaded the topic just before i saw your reply so maybe i will delete this and move over there?

Here is a google drive link to all the files from the original test:

Google drive link from the longer test. I connected to mission planner, pressed the safety switch until solid and did multiple attempts to move the sticks down and to the centre, hopefully thats what you were looking for, not totally sure though. The safety switch remained solid throughout the test.

Got it armed with a little transmitter tinkering and going outside to get good a GPS fix. Still need to try it on the V-tail configuration i need but for now, Thank you !!

V-tail working nicely but now the wireless communication is killing me.
Not sure if you could shed any light on this? Thank you!