Anyone using notch filter? I'm having bad results

I enabled the notch filter today, and when I armed, the motors went to full output. I disarmed and looked at mission planner, and the hud was spinning. I disable the filter, it’s fine… Re-enable, the hud spins.

I’ve got a small copter w/ 9000kv motors and 3" props, so the vibrations are relatively high frequency… The peak was about 280hz. So I first tried the notch at 280. When that didn’t work, I tried the highest that’s recommended in MP, which is 200hz, just to see what results I’d have, and it did the same thing… HUD spinning.

I see the few posts people have made about it are all filtering out frequencies around 70 or 80hz.
So, is my issue that the notch is not meant to filter out such high frequencies? Or is the notch not fully working yet?

Here’s my FFT.

I don’t currently have a log of the issue while it’s enabled, but if any developers want more data, I’d be happy to log disarmed.
Thanks for any advice.

I guess only a small part of users have play around the notch filter yet, and I hope it will be discovered more and more. I believe its really usefull for small unit, in all my small 5" I cannot work with autotune, but ASAP I enable it with the proper settings the autotune works again because its no longer confused by the system noise.
What’s we are missing is a way to visualize the frequency vibration before and after the low pass filter in acc_filt and gyro_filt to be able to fine tuning it, instead I’m still making it only observing the flight characteristics, but its not so accurate or able to catch the small details!

Another observation I’ve made using the notch filter is that if you have increased the main loop, you could have notch filter not working as supposed, because if the CPU its already close to its edge the (notch filter) CPU cost could make the overall system even worse.

My suggestion in general for evalueting the notch filter is to make also a test bench, make a log with and without the notch filter, trying to match at best duration and thrust level.

My issue though is that as soon as I enable it, the HUD spins. the IMU is not happy.
It’s the same as what was happening to Paul, and you linked to his post in your thread last year:

So there is no testing of flight characteristics at all… It just doesn’t work.
My loop rate is at 400, and CPU load at about 23, so that’s not the issue.

I guess I should mention, this is on Master, not 3.6.