Servers by jDrones

An Open Source Frsky Telemetry Script for the Horus X10,X12 and Taranis X9D,X9E and QX7 radios

ardupilot
frsky
lua

(daramidon volf) #576

Good day. I tried different options to enable the script. 1. First deleted all sensors. Further included a script. Checked the appearance of sensors. They did not appear. 2. Removed all sensors. Included search for sensors. Install the script. Sensors appear, but only two of them are active RxBt and RSSI. 3. Removed sensors. Included the script. Started the search for sensors. Only two RxBt and RSSI and sometimes GPS appear. Which of the scripts I have described is correct?


(Luís Vale Gonçalves) #577

Moved to the appropriate thread

Following the steps described here https://github.com/yaapu/FrskyTelemetryScript/wiki has enabled lots of users to get this running.


(Alex Apostoli) #578

Hi, most likely your cable is not working.
Remove the script from radio and delete all sensors.
If the cable is working and you have setup the serial port with protocol 10 a sensor discovery now should get RxBt, RSSI and GPS. If you do not get GPS something is not working.


(daramidon volf) #579

I understood you correctly that if the cable is intact, then after turning on the remote control I turn on the flight controller, then I go to the telemetry tab in the control panel and turn on the search for sensors. After finding them, I should see RxBt, RSSI and GPS. In this case, the script should not be included.


(Alex Apostoli) #580

Yes, when the script is not runnig (to be sure undefine it and delete from radio) and everything else is working and wired (flight controller -> cable -> RX --> radio link -> TX) a sensor discovery should get you RxBt,RSSI and GPS

Edit: a sensor discovery should also show all standard “physical” frsky sensors you might have chained on the s.port bud like FLVSS for instance


(Anton Khrapov) #581

I’m not sure if it’s a bug or my tx, but when Disarmed message flickers with black frame, few pixels stay black just above the word. X9D+ with latest firmware.


(daramidon volf) #582

Good day Alex Apostoli. After numerous and unsuccessful attempts to obtain telemetry data on the screen of the remote control, Taranis Q X7 decided to experiment with the script files. At first I copied files onto SD fs as in the instructions, but an error occurred when starting the script and turning on the flight controller. Then I left only the .luac files on the SD, the script was installed, no telemetry data was received, and there was no voice message about the script launch. The next time I placed on the SD card only the .lua files and about a miracle, telemetry worked without problems. My configuration: Flight Controller Radiolink Minipix (Arduplane 3.9.6); MAX3232 with diode on the output side of the receiver (connection to the receiver via one wire to S.Port, the ground wire is not used); receiver Frsky R9slim+; Frsky Taranis Q X7 transmitter (OpenTX 2.2.1). Thank you all for your help and all the luck.


(Alex Apostoli) #583

Hi, are you referring to this?
image

if so that’s the home icon
image

But if it’s something else please take a picture :slight_smile:


(Alex Apostoli) #584

Hi, very good. You probably don’t have the “luac” option ticket in the settings tab of your opentx firmware, that’s the reason why lua works and luac does not!

cheers,
Alex


(Anton Khrapov) #585

It probably is that home button but looks weird:


(Alex Apostoli) #586

this?


(Alex Apostoli) #587

Hi all,
new version 1.8.0-beta3 for Taranis X9D, QX7 and X-Lite

Note 1: OpenTX 2.2.3 is recommended for it frees some extra memory for lua scripts

https://drive.google.com/open?id=1K8jlPNCOrta4-GSeUQIIQzWLoZr_UJmV

image

image

Layout changes

hud left now is speed, hud right is altitude, middle bottom is vspeed
total flown distance is shown below home distance
vario on the right

Extra screen reachable by pressing [PLUS] twice

image

image

Here up to 6 sensors can be defined by editing the per model lua configuration (example included in the /MODELS/yaapu folder)
This was designed with gas suite users in mind, it’s possible to define multipliers, labels, warning and critical levels in the conf file.
There’s also the option to define lookup tables, when a sensor value is found in the lookup table the script shows that value instead of the sensor one.
When the script is in “show min/max” mode by short pressing [MENU] the custom sensor panel will show min or max values depending on the “min or max tracking” option defined in the lua configuration file.

@ChrisOlson briefly explains this new feature in his video

Support for @Eric_Stockenstrom “Plus” firmware,

The plus version sends extra info for

  • waypoints
  • airspeed
  • throttle

the custom left panel can be enabled by selecting “m2f” in the script conf menu

image

image

…and

  • voice playback of selected mavlink messages
  • script reset is now possible without power cycling the radio by pressing long [ENT] + flight reset, motors should not be armed and the flight timer should not be 00:00
  • fix to skip flight mode vocal announcement for very quick flight mode changes, like flipping a switch from pos 1 to pos 3
  • messages can now be logged to a file on the SD card, this must be enabled from the conf menu
  • haptic feedback, has to be enabled from the menu
  • more options to silence the incoming message beep

as always feedback is very welcome,

cheers,

Alex


(Anton Khrapov) #588

Yes. Sorry, I know It’s small and nothing really, just annoying for some weird reason.
Edit:
It might be a part of artificial horizont…


(Luigi Ceo) #589

Thanks Yaapu / Alex, I’m using your last review successfully following the instructions of this chat. I use a Taranis X9D plus radio remote control, updated to the latest LBT / EU firmware, with Pixhawk 2.1 flightcontrol on 960 hexacopter. Great job, my compliments. Greetings from Sardinia


(Alex Apostoli) #590

Hi Luigi,
thanks for the kind words!

Alex


(Alex Apostoli) #591

Hi Dave,
would you check if rover modes are handled all right?

thanks


(Henry Wurzburg aka ATX_HELI) #592

Alex, using the latest script in Taranis 9D…it works for a little while, then gives this error:

Script syntax error
not enough memory

any ideas?


(Alex Apostoli) #593

did you enable any particular feature, like msg logging or custom sensors?
OpenTX version?


(Alex Apostoli) #594

Could you try this version in the very same conditions, 1.8.0-beta4

https://drive.google.com/open?id=1nmHWDbF56V23WPV01b3zlJOdwpWrJGHO

@dkemxr This fixes rover mode sounds

EDIT: this version has the msg logging feature disabled


(Henry Wurzburg aka ATX_HELI) #595

Actually, it might not be the latest…its 1.7.2 under Opentx 2.2.1…its been running fine for some time, but just hooked up a new DL RX streaming Mavlink to Taranis via a Teensy bd…it was working a month ago with a different DL RX…
should I try something different or what you pointed me to?

PS I have added a few models to the TX in that interval…