Servers by jDrones

AltHold Up/down oscilation

Hi. I need help. My dron with full batery oscilation up/down about 1-2Hz in AltHold mode.

If batery isn’t full then no oscilation.
I dont need perfect height, more important is stable, how i can slow down this oscilations?

For longer fly in AltHold oscilations are bigger.

Try Voltage Scaling.

Hi Łukasz- Post a link to the flight log of this flight. Looking at your other post with a log I noticed you have INS_ACELL_FILTER at 5Hz. I think this is too low even for a big quad. How did you arrive at that?

its hard to say without log file but i think its high Z vibration

Thank you for reply !

My parameters and log from this flytest
https://drive.google.com/file/d/1nuvcPtpBk2pkjqJmpWY0Ev1_3S_5xyfT/view?usp=sharing

What parametars are using in AltHold mode but not using in Stabilize ?
I try found list of parameters responsible for althold.
Stabilze mode working good without any oscilations. Alt hold or Loiter in XY axis are working no bad, only Z Axis oscilate as video shows (keeps horizontally in all mode and keep XY with Loiter but Sound of all 4 motors/proppellers is oscilation evenly Up/Down in Z axis ).

This is not a Vibe problem, it’s a tuning problem. 1st, set the INS_ACCEL_FILTER to 15 and make another flight to see if the vertical oscillation is gone. Also, these are very low
ATC_ANG_PIT_P,2
ATC_ANG_RLL_P,2

How did you arrive at these tuning parameters?

1 Like

Now some days will raining :frowning: Will test it. Thanks.

Iprojest was paused by year, i don’t remember …
what should be value for my case ?

OK with log file we can see that its a tune problem as @dkemxr said

you have noise on your RATE values

also you can see this noise on DesRoll,Roll and DesPitch,pitch

main soure is D term on both roll and pitch

i can see these PID values in your log that they are high for your config

first change ATC_ANG_PIT_P and ATC_ANG_RLL_P to 4.5 and backoff your PIDs in steps of 10% until oscillation disappear then run autotune

Good luck and let us know how you go.

1 Like

I would set the accel filter to 15Hz. Hosein’s suggestion of setting the ATC_ANG_PIT/RLL back to default (4.5) is good also. And before the next flight set INS_LOG_BAT_MASK to 1 so we can view the Vibe FFT data. It’s useful at this stage of tuning.

1 Like

Thank You Guys !
I will try it and back here with result :slight_smile:
now waiting for good weather , but in Poland now is bad time for it.

Thank You Guys !
I will try it and back here with result :slight_smile:
now waiting for good weather , but in Poland now is bad time for it.

it’s big drone 1.7m 12kg construction with 30inches proppelers ;), need lot of time for all of smal test.

Thank you for your help.

in docs of AltHold Test i read

  1. Take off in STABILIZE and increase altitude to 5m. Switch to AltHold and be ready to switch back to STABILIZE. If the aircraft is hovering at a very low hover throttle value you may hear a reasonably fast oscillation in the motors. Ensure the aircraft has spent at least 30 seconds in hover to let the hover throttle parameter converge to the correct value. Land and disarm the aircraft.

Maybe it’s my problem ? My drone have too big power for weight , so can take of with 20% of thrust. I changed Spin Max to 0.65 , then can control, else was wery agresive.

That procedure sets the MOT_THST_HOVER value so it Hovers at mid stick. It will not cause the vertical oscillation you are seeing.

if it was good my idea to lowering mot_spin_max parameter to 65%?
After that my drone no vertical moving in stabilize mode about mid stick of throttle and then can changing between AltHold and Stabilize mode without change throttle position.

i’m sorry for lot of question, i try to understanding how ArduPilot algoritms work but it’s very big documentation. I’m very begginer of drone topics.

I’m very greateful for all your help.
In Poland people isn’t helpnes like here.
My project isn’t typical and not easy.
Small model of it working perfectly :slight_smile:

I don’t think so. You will probably need dynamic thrust above mid-throttle for when it’s flying autonomously particularly right after you drop it. The MOT_THST_HOVER learn function should adjust so you can switch between AltHold and Stabilize w/o requiring a large throttle adjustment. But with the very high thrust/weight ration you have Stabilize mode will be a handful no doubt.

65% spin = >40kg thrust
my dron now is 12kg, with bigger batery will be about 17kg
100% = 62kg of thrust

More battery weight would be the best solution but I think you can get it flying OK without dropping the MOT_THST_MAX value. You will probbaly want that thrust to get the paraglider in the air!!

[quote=“dkemxr, post:18, topic:62795”]
You will probbaly want that thrust to get the paraglider in the air!!
[/quote]Then working other (my own) controller ;). i need full thrust range for paraglider towing to 300-400m AGL

Ah right, I forgot about that. Arducopter is only for after release, Throw Mode, and RTL right?

1 Like
Servers by jDrones