Servers by jDrones

AltHold Up/down oscilation

Yes.

Last question before next test. What logmask is good for me at this moment? Now log file is too big i think.

161790 is good. I noticed you didn’t have RCIN in the previous log, you want that. Also set INS_LOG_BAT_MASK to 1 so we can get a better look at Vibes. They are not high enough to be causing any clipping but I’m interested in the response with the overlapping props. This is not common.

1 Like

Also i found in other topic drone with the same proppeller/motor with good parameters of flying with any modes. I thinked if good idea is using this parameters/pids and filter for test on my drone.

But it’s other construction , my it’s extremaly not standard.

I don’t think it’s a good idea to use another crafts parameters

1 Like

Thank You VERY, VERY MUCH !!!

here is raining, raining, raining but i found some minuts without rain for test your sugestions.
Also i change PIDs down ( because i don’t trust my setpoints ) between my previous and from other like model.
Now all is stable, without oscilation up/down in AltHold but dron is like on a gum, need 1-2 seconds to stop swing after move. But all is no bad, i can fly stable in Stabilize, AltHold and Loiter.

i’m don’t understand all logs but see that fast noises/oscilation RATE is gone :).

if now i can start AutoTune mode ?
it’s my parameters and logs :

https://drive.google.com/file/d/1pOk1d4L93Ge1Y22uLjUgoCbQJG-vLZgW/view?usp=sharing

Nice work Łukasz! Before you run Auto Tune I think you can take advantage of the Dynamic Notch Filter. This can be of great help obtaining the best Tune. This log you shared has the data to determine the parameters to set this filter. I would suggest you make these changes:
INS_HNTCH_ENABLE 1 (then refresh parameters)
INS_HNTCH_ATT 40 (ignore out of range warning)
INS_HNTCH_BW 15
INS_HNTCH_FREQ 30
INS_HNTCH_HMNCS 3
INS_HNTCH_MODE 1
INS_HNTCH_OPTS 0
INS_HNTCH_REF .147

Then set INS_LOG_BAT_OPT 2

Make another flight and Hover for ~60sec in Alt Hold and then post that log.

For your reference this is the data I was looking at so determine these parameters:

FFT before filter

After you make the next flight we will see the improvement (hoepfully) ffrom the notch filter and then you can perform ab Auto Tune.

Note: If the craft seems to be very sluggish and non-responsive just land right away. There is a small chance this 30Hz filter center frequency is too low and we will have to take a different approach.

1 Like

It’s no my good job.
It’s your good job :slight_smile:

Ok. I will do all your sugestion and back.

If harmonics maskbits should be 3 or 7 ( i see 3 peeks on 30,60,90 Hz ) value 3 means 1+2 harmonics only but i dont sure how works this function.

Now all test are very hard. I havent time for it when not raining.

You have it correct and the 3rd harmonic may indeed be helpful. I would try 2 1st and see the result. The higher harmonic may not be significant and adding more takes more processing.

I’m thinking now that you want to use the Double Notch Option for such a large craft. So let’s set INS_HNTCH_OPTIONS to 1.

1 Like

i haven’t this parameter.
for moment i will try fly because is not raining but windly :frowning:
not posible for autotune for some days .

https://drive.google.com/file/d/18uLpzS895suu_C1-ELNy2Se57WH31dTq/view?usp=sharing

Where i can see FFT GYR diagram ?

i can’t found it.

Ah, probably because you are running the Pixhawk1-1M firmware which has a limited feature set. I don’t recall form previous dialog but you are sure you have an older Pixhawk with only 1mb flash?

To plot the FFT graph go to the Ctrl>F menu and select FFT. Then select New DF Log and pick the log you want.

Before Notch filter:
FFT before filter

After Notch Filter. Note the larhe drop in magnitude:
FFT after filter

How did it feel flying? You can do an Auto Tune now I think.

Wow , filter working perfectly, you are awesome ! Thanks.
I can fly without problem, but in Loiter mode with wind corect position isn’t well .

i hope that i can start autotune. Because i have too small batery at this moment i will start tuning one axis only, then rewrite PIDs to second axis and start autotune all.

what autotuning parameters for my big drone will be good at start?

but need to wait for not windy wheather.
Thanks again, will back and inform you.

[quote=“dkemxr, post:31, topic:62795”]
Ah, probably because you are running the Pixhawk1-1M firmware which has a limited feature set. I don’t recall form previous dialog but you are sure you have an older Pixhawk with only 1mb flash?
[/quote] I using Pixhawk1-1M firmware because was problem to upload default. I will check board version beacause i don’t know. Yes, its no new :wink:

I wouldn’t write the parameters from one axis to the next. I would do a pitch tune, charge the battery, then a Roll Tune, charge the battery and then a Yaw tune. I would start with the AUTOTUNE_AGGR at .7 and see how that goes. If it’s OK but a bit slow in response you could then do another with this at the default of .1

I know this is time consuming but worth the effort. Particularly so for what you plan on using this “Booster” for :grinning:

1 Like

Ok, thanks.
i will do it.

If i will change for bigger bateries , and drone will be +5kg ( now 12, after finished about 17kg) then autotune only should be Sufficient ?

I guess you meant 0.07 instead of 0.7 :slight_smile:

2 Likes

That would be correct. Thanks for the correction.

I think that problem of this topic ( oscilation in AltHold Mode) is resolved.

Thank you very much for help!

Yes, I think so. And note the aggression mistake I posted. .07 !!

Yes, its clear for me.
I think that problem up/down oscilation in AltHold mode is resolved.
This Topic is closed.

Thank You for help!

Servers by jDrones