Alt_ Hold Fly away with Kakute F7 AIO First Flight - need help!

Hi I need now the communities help.

I built a Peon 230 based copter with Kakute F7 AIO FC using Chibios and a NEO 6M GPS with integrated compass. My Radio is now the Taranis 9xD Plus with the X8R .

I went through the complete first installation process in setting and calibrating the copter completely and to my belief correctly.

The first problem, which led me to the second problem, I encountered was that the EKF remained red. Due to a poor satellite signal, so no arming. It did not mater which configuration I chose, I got max. 10 satellites the mean number was 7. Funny wise I got more satellites under my roof window inside than outside on the free field with blue sky. I read a post that with copter 3.6 there might be an issue in configuring the GPS. So I tried to step down to 3.5. I missed because I could only find the 3.6.2 version for the Kakute Board. This is currently my arducopter versionI have installed. Nevertheless it did not change anything! I now remained with the value 67 to get GPS+SBAS+GLONASS.
In order the to get a white EKF in the HUD I changed the EK2_GPS_Check from 31 to 3. So just NSats and HDop as preflight check.
The third Problem is that the compass deviates around +13° even after various calibrating sessions which I concluded always ok.

As I could not find a better situation I wanted nevertheless to check how it behaves when flying.

Big Mistake!!! I am currently printing all parts again, all!!! :frowning_face:

Before the flight I checked how the copter behaved without props.

Quite aggressive reaction of the throttle in stabilised mode in Alt Hold the motors ran to my felling very stable with mid revs.

So I decided to go with props Alt_Hold.

Before the start I checked the gps with 7 satellites (I know poor).

In the middle position of the throttle the copter took off with some toilette bowling, but not very heavy. I put a little bit more throttle and then it flew away in the sky and did not react on the throttle position anymore.

With the climbing speed the copter showed I was very stressed, so I decided to cut off the motors. It fell, I then switched on the motors again. It recovered but went up again with the same speed. I did this 2 times then I crashed.

Except of one antenna leg from the X8R and all the plastic nothing was damaged.

Could you please explain me what did I wrong? Is it a vibration, GPS or compass problem? The copter flew quite good with Betaflight.

I would be really grateful for your help. I put already so much time in this project I must get it going.

I will attach the log of the flight as well as the params file.

Thank you very much for your help in advance.

Kind regards,


2019-12-06 11-43-30.tlog (212.4 KB) 2019-12-05.log.param (15.4 KB)

The Tlog is of limited value. Post the .bin log from the flight controller.The 6M GPS module is very old tech and not capable of more than 1 sat system concurrently. Replace that. You have some way off base rate filter settings for a small quad.Did you start here?

Hi Dave,

thank you for your fast reply. I know that there is certainly something I did not take into account, certainly a typical newbie error. However it is quite a lot of information to be learned, which is good but sometimes too much info leads you into the wrong direction. This is where I need your help.

I applied the initial rate filter settings as per your link. I checked it again and I believe I took the right values for a 5 inch prop. One value I mismatched. I put 0.1 for [ATC_THR_MIX_MIN] and kept the [ATC_THR_MIX_MAN] at 0.5 instead.

I was to much focused on the telemetry logs. I now downloaded the flash logs. When checking I saw mainly problems with the GPS/Compass.

I had ordered already a Ublox M8Q Sam and to test as well a Beitan BN880.

Are there any other things I should look for. The fly away was quite scary as it was very fast.

Thanks in advance.


2019-12-06 11-44-26.bin (308 KB) 2019-12-06 11-44-26.log (616.9 KB)

Don’t think this has anything to do with GPS or compass. You flew in Althold,which doesn’t need GPS.

Do i see that correctly: RC8 is motor interlock and RC3 is throttle ?
Why is RC3 trim = 1100 ??? ( = RC3.min !!!)

Quite aggressive reaction of the throttle in stabilised mode

Oh yes … not a miracle :scream:

I would strongly recommend to check this, otherwise chances are high that you’ll see the next crash,no matter what gps you have mounted !

Hi FS,

thank you for your reply. Yes you are right channel 8 is the motor emergency cut of, which I used to get the copter down (cashed).

Throttle is on RC3 right. I did not change the trim values. On the Tanaris the trim is for all for axis on 0.

I made the rc control calibration but I did not change manually the RC_trim value.
I presume it should be at 1500?

Do I have to check and set the trim of the other channels to 1500 too?

Does it influence the alt_hold mode as well? So that it may come to this attitude to fly up in the sky like crazy? When I pushed the throttle to zero there was no reaction. In did not stop climbing .As far as I remember. At that post I switched the channel 8 on.

Kind regards,


You should be able to stop the climb in althold by switching to stabilize. That gives you manual control of throttle. Before trying althold again, make sure stabilize mode is working well so you can use it to recover. The unlimited climb in althold is probably caused by excessive vibration. The fix for that is vibration isolation for the controller.

1 Like

You have the Rate filters (ATC_RAT_PIT/RLL_FILT) set at 2. They should be at INS_GYRO_FILTER/2. (half). The vibration levels are not terrible but how is the FC mounted? I wouldn’t rely on the soft mounted IMU alone on this FC as it’s minimal.

RC Trim for throttle doesn’t matter. At 1100 it just means you left the throttle low when completing the calibration. Don’t manually enter these values, just use the radio calibration function.

Really ???

If RC trim is set to 1100, the flightcontroller will assume this position as “stick is in the midle” and any value above 1100 as “climb” in AltHold. And that’s exactly what we find here:
The log shows that RC3 is above 1100 or 1100 all the time,so we shouldn’t wonder, that this copter climbed as a rocket.

Vibrations are within the limits, so no issue.
ATC_RAT_PIT is for pitch, nothing to do with climbing.

Andreas, i recommend following the docu exactly. First launch should be in Stabilize and before see this !

Really. Most of the time when I do a radio calibration I leave the throttle low at completion and that is the result. Here is my everyday flyer I just happened to have powered on the bench:


And here is the parameter that sets hover throttle:


Hmmm, MOT_THST_HOVER is below anything i have seen so far. That powerful motors ?

Yes, high thrust to weight. It’s a 210 size 5" on 4S

I would still recommend Andreas to set RC3.trim to 1500, mount a prop, hold the copter by hand, arm in Stabilize and see what happens. If RC3 stick is low, prop should spin slow and raising the stick should increase rpm’s.

As long as that doesn’t work -> don’t fly

Maybe ESC calibration is off ?

Is the barometer covered with foam? It’s required on these boards. Any boards really but the F4/F7’’s w/o housings its important. You need to fix the PID parameters. No quad will fly with rate filters at 2hz and certainly not a mini quad with Arducopter.

If you want to repeat the radio calibration and finish with the throttle centered go ahead but it won’t make any difference. On ESC’s where neutral is at 1500us, like a rover, it will but not here.

Holding the craft stationary in Stabilize mode doesn’t tell you much. With no sensor feedback the motors can spin up with little to no increase in throttle attempting to reach the commanded input. Typical loop behavior with no feedback.

If you want direct control of the motors Mission Planners motor test function will do that.

Dear Helpers,

thank you very much for all this input.

Let me resume:

  1. I should get an up to date GPS (Neo M8Q / Beitan 880 are ordered)
  2. The GPS isn’t responsible for the high climb rate when in stabilised or Alt_Hold mode.
  3. Vibration issue is excluded however I will put some rubber stands under the FC.
  4. I need to cover the barometer with a piece of foam. (Why in fact?)
  5. I changed the RC3 (throttle) trim set to 1500.
  6. I changed the ATC_RAT_PIT/RLL_FILT from 2 Hz to 40 Hz = INS_GYRO_FILTER/2 (80 Hz)
  7. I left the ATC_RAT_YAW at 2 Hz (possible value 1 - 10Hz) ?
  8. I will start in stabilised mode. (Transmitter is set now to 1. Stabilised 2. Alt_Hold 3. Land, 4. Loiter, 5. Auto, 6. Guided. Channel 7 is RTL and Channel 8 is motor emergency cut off. Failsafe is activated on the Frysky.

Anything I forgot?

All parts are printed now again and the copter is reassembled. I will wait for better weather condition to try it again.

Big thanks to Dave and FS!

Two reasons:

  1. The barometers are very sensitive to propwash, foam mitigates against this
  2. The barometers are very sensitive to light, the foam prevents this

Be cautious about soft mounts and the AIO. You are more than likely going to have power cables attached to it. In particular if you have the battery cabling soldered and then to a battery connector just be aware of any forces on this mass during flight. The tail wagging the dog during a fast turn. Same with the dc cables to each esc.
I believe the AIO was a natural fit with betaflight which had smart filtering. Ardupilot now has smart filtering as well. Andy above is a key figure with this.
I used Matek rubber mounts that seem to work well. The incoming dc supply I tied down to the quad base and then ran up to the fc. With a little slack. The F7 imu isolation/damper is basic as pointed out above by Dave. So if you are going to use gps modes then more care with vibration unless smart filtering. Out of my depth there.

I think this climb away is caused by a very large oscillation in the roll and pitch. This is rare and we have protections against it happening but in any case, there are situations where we raise the average throttle to give the roll and pitch controllers more range. On a very powerful copter, with gains that are set far too high this can lead to the average throttle being high enough that the vehicle keeps climbing. In other words the prioritisation of throttle vs attitude control is tricked by the high oscillation.

My guess is that the fix involves reducing the Roll and Pitch rate gains:

  • reduce ATC_RAT_PIT_P from 0.135 to 0.09
  • reduce ATC_RAT_PIT_R from 0.135 to 0.09

It might be good to manually reduce the hover throttle to improve safety

  • reduce MOT_THST_HOVER from 0.53 to 0.20

Below is a graph of the throttle input (in red) and the motor outputs.

Here’s a graph of the Roll axis’s desired rate (in red) vs the actual (in green). We can see that the response is far far too high.

EDIT: I also noticed that this vehicle is running Copter-3.6.2, normally it’s a good idea to use the latest version which is 3.6.11 although I don’t think it matters in this case.

1 Like

Randy is correct.

This is caused by oscillation in the roll and pitch controllers caused by very large PID terms for this aircraft.

You set the roll and pitch filter values way too small. They should have been set to 40.

This is from the wiki page:

  1. All flights after a significant tuning change should be done in Stabilize. Stabilize provides the pilot with significantly more control over the aircraft in the event that the attitude controllers are unstable.
  2. The pilot should not take off in AltHold until the altitude controller has been tested in flight. This should be done by taking off in Stabilize and switching to Alt Hold. While Alt Hold is rarely a problem unless the aircraft has a very low hover throttle.
  3. For the initial flights the pilot should ensure that these parameters are set:

This pretty much sums up what you did wrong. This is from the wiki page.

You should definatly be using 4.0 when it is released and after you get it flying setting up the harmonic notch.