Servers by jDrones

AC3.6.9 unable to calibrate ESC

(Niharika Patel) #1

@rmackay9,
We have an Iris+ with a pixhawk which had the AC3.2.1 firmware that we updated to AC3.6.9. On updating we found that we were unable to calibrate the ESC. We tried two methods, 1) Calibrating ESC from Mission Planner 2)All at one Calibration. When the throttle was up, and battery connected, it would go into the ESC calibration mode(red,blue,green LEDs ina cyclical pattern) and then we disconnected , reconnected and pressed the safety switch on. It would still be in the calibration mode but none of the calibration beeps would be heard. On pulling the throttle down nothing would happen either. The motors would not start either.

We went back to AC3.2.1 and were able to calibrate the ESC. Do we need to calibrate the ESC every time there is a firmware upgrade or only the Accel and Compass need to be Calibrated ?

P.S we updated to AC3.6.9(v3) in order to get the GRIP_ENABLE parameter ref this. However we were not able to calibrate the ESC in AC3.6.9(v2) or AC3.6.9(v3)

Right now we are calibrating the ESC on 3.2.1 and then updating to 3.6.9 to enable the rest of the features. Is this an expected outcome and do you recommend a better way to tackle this? Since we are not sure if the ECS would need re calibration when the firmware updates

Thanks,
Niharika

(rmackay9) #2

@NiharikaPatel,

Great that you’re upgrading from AC3.2.1.

In general AP handles the upgrade without requiring any re-calibration. If any calibration is required there will normally be a pre-arm failure message displayed so be sure to keep ARMING_CHECK = 1. Because you’re moving from such an old version I suspect that you’ll be forced to recalibrate almost everything but probably not ESCs.

ESC calibration should work with Copter-3.6.9. I have a few IRIS+ frames and have successfully calibrated them so not sure what the issue is I’m afraid.

(Loic Chappaz) #3

@rmackay9 thanks for getting back to us so quickly!
The upgrade itself was smooth and the recalibration (accelerometer and compass) too but yes, none of the ESC calibration methods – besides manual, didn’t try that one – didn’t seem to work.
What’s more curious even, is that we actually have two Iris+ and neither seems encline to the ESC calibration in 3.6.9…

(rmackay9) #4

@loicspace, if you have a log file or a parameter list I could have a look.

you might want to try using MP’s motor test screen to check that the motors spin up properly.

(Loic Chappaz) #5

@rmackay9 Aye, we can send that in the morning!
And will check out the motor test screen then as well.

(Niharika Patel) #6

@rmackay9 thanks for your reply. We just tried to do the MP motor test from AC3.6.9(v3) and it keep saying “Command denied by the autopilot” .

Please find our parameter file attached
AC3.6.9 iris11.param (14.2 KB) also, how do we get to the log file generated while we attempt to calibrate ?

Thank you

(rmackay9) #7

@NiharikaPatel, ok txs. When the ESC calibration fails, it will normally display a failure message on the Flight Data screen’s HUD and also in to the “Messages” tab on the bottom left.

If LOG_DISARMED = 1 then the log will be started once the vehicle is powered on and will keep recording during calibrations,etc.

(Niharika Patel) #8

Thanks for the info.
I have attached the log file of when I tried to calibrate the ESC. It does not say failure but it does not mention anything about the ESC.
2019-07-19 12-04-03.bin (952 KB)
70 7-19-2019 11-34-56 AM.bin.log (326.5 KB)
69 7-19-2019 11-34-36 AM.bin.log (109.4 KB)

(Niharika Patel) #9

@rmackay9 , we have 2 iris+ set up in a similar manner. When we calibrate the ESC using AC3.2.1,
I noticed that 1 of them (iris+ 11) lights up in red,blue,yellow in the calibration mode and the other (iris+ 12) lights up in red,blue,green in the calibration mode. Both calibrated on AC3.2.1.

FYI, The log files above are from attempting to calibrate iris+11 on AC3.6.9 (red,blue,yellow).

Is the color difference something to be concerned about?

Thanks

(rmackay9) #10

@NiharikaPatel,

I don’t think the colour difference is something to worry about.

You’re pushing the safety button of course? if there’s no safety button then maybe try setting BRD_SAFETYENABLE = 0.

(Niharika Patel) #11

@rmackay9 We have been pushing the safety button every time we try to calibrate. It does seem to go in the calibration mode. The calibration mode lights come up but it just doesn’t complete the calibration with AC3.6.9 the way it does with AC3.2.1.

(rmackay9) #12

@NiharikaPatel,

An of course, the procedure is:

  • hold transmitter throttle high, plug in the vehicle’s battery
  • wait for the vehicle to power on and note that multi-coloured flashing LEDs
  • unplug the vehicle’s battery and plug back in again
  • the multi-coloured flashing LEDs should come on again and push the safety button
  • ESCs should beep, then lower the transmitter throttle and they should beep again and the ESC calibration should be complete
(Niharika Patel) #13

@rmackay9 I followed the same procedure while calibrating with AC3.2.1 and AC3.6.9. All steps you mentioned above happens for AC3.2.1 but for AC3.6.9 it seems to get stuck at step 4 . The last step ,“ESCs should beep, then lower the transmitter throttle and they should beep again and the ESC calibration should be complete” does’nt happen (ESCs dont beep) just the multicolored LEDs keep flashing.

(Sergio Szabo) #14

I had issues to calibrate ESC as well and Chris Olson saved me highlighting to check
SERVO8_MAX, SERVO8_MIN, SERVO8_TRIM

Try setting to the min to 1000, max to 2000, trim to 1000
Hope it helps you as well.

1 Like
(Niharika Patel) #15

@Cirus Thank you so much ! that seemed to solve it for us. We are now able to calibrate the ESC on AC3.6.9. @rmackay9 I wonder if these were the settings for the older versions and were changed for some reason. By default SERVO8_MAX = 1504, SERVO8_MIN = 1503, SERVO8_TRIM = 1504 on AC3.6.9.

1 Like
(Sergio Szabo) #16

I’m so happy to hear it.

Thanks again to @chrisolson who helped both of us.

1 Like
(rmackay9) #17

Thanks very much @Cirus!

I’ll see if I can reproduce this and if “yes” then perhaps we can improve the reporting of the issue or at least add a note to the wiki.

(Loic Chappaz) #18

@rmackay9 @Cirus That actually solved it on both Iris we have.
We jumped from stock firmware (3.2.1 as far as we can tell) to 3.6.9 – maybe that was a bit too big of a jump.
I looked at the Iris parameter file that you refer to in some other threads and it didn’t have values for these specific parameters and we didn’t save a copy of the parameters in 3.2.1 so it might be tricky to reproduce depending on the source of the issue.