Servers by jDrones

4.1 Vehicle speed

I did a few tests on firmware 4.1 and found that in auto mode, the vehicle speed does not follow the DO_CHANGE_SPEED command.
What do you think could be the reason?

Log file:

Of the speed Is a round Number try with a decimali. If for example your speed Is 6 try 6.1
For me 4.0.7 Is the Only way to have It working.

I tested but it still has a problem, the speed remains around 4.3m/s.
Another issue I encountered was the decrease in altitude while flying in auto, for which I do not know the reason.

Hi @hassani,

Sorry, it’s taken me a while to get to this report. Could you re-post the log file?

I’ve just tested MP’s “change speed” button and it seems to work.

Hi @ rmackay9,
I use DO_CHANGE_SPEED command to set the speed to 5 (even 6 or 7) m/s , but in flight my speed remains constant at 4.3 m/s.
Log file:

1 Like

Some kind of problem in changing speed has been there since 4.x.x.
We have to use fractional numbers to have the copter change speed with a mavlink command.


Thanks for the log and sorry for the slow feedback. The issue is a known limitation with SCurves. The vehicle will not travel faster than a speed that allows it to stop in time for the next waypoint… whether or not the vehicle will actually stop at that waypoint or not.

If you remove the intermediate waypoints you’ll find that it reaches a higher speed. To prove this I ran the mission from the log file in SITL both with and without the intermediate points and used MP’s “change speed” button to increase the target to 15m/s.

FYI @Leonardthall

1 Like


While testing @hassani’s report I also tried using the do-change-speed command using both integer and non-integer values and it seemed to work fine. Can you describe how to reproduce the issue you’re seeing? If you have an onboard log that’d be great too but not required. txs for the report.

Randy try setting it to 6 or 8 without the .0


I did try integer (e.g. “setspeed 7”) and floats (e.g. “setspeed 5.5”) and both worked. Actually if you look closely at the screen shot above you can see exactly what I typed in.

Reproducing is pretty easy. If i set 6 m/s as speed in set speed command it doesn’t take it and goes at 2 m/s. I reported this since last year i think and here and there people show up with same problem.

Same problem for years, maybe it is worth taking a look and don’t let it drop as usual.


@Corrado_Steri, @ardisd

I just can’t reproduce this set-speed problem… I have tried with Copter-4.0 and 4.1.0-beta3 and it always works just as expected.

Sorry to keep asking questions, but can I get some more details on how to reproduce this including what GCS is being used?

I’ve tried this:

  • Start MP’s simulator including clicking the “Wipe” checkbox
  • Use the Plan screen to create a mission with a takeoff, then a long straight waypoint segment, then RTL
  • Arm in Guided
  • Right-mouse-button-click and Takeoff, enter 10
  • Use the MP’s Action tab to change the speed to 5, 7, etc

Sorry if I dropped the ball on the previous report.

On simulator always works, in real life doesn’t.



I hate to ask you more questions because you’ve obviously been trying pretty hard to get this issue addressed but are you sure the problem persists in 4.1? We’ve totally changed navigation including the bit of code that handled speed changes.

I can (and will) try it on a real vehicle of course… very happy to… but I suspect we’ve inadvertently fixed this issue in 4.1. @hassani’s problem is a known issue with SCurves and I’ve already shown the work around.

Can’t use 4.1 yet, problem is showing on a 25kg working machine. Once 4.1 will go stable for some months i’ll switch. Sorry about it.


1 Like

Thank you dear @rmackay9, I did not know about SCurves. Great!

1 Like

Re the issues of do-change-speed not working and/or requiring the speed to be a fraction (e.g. 5.1 instead of 5.0) I tested today on a real vehicle and could not reproduce the problem. I tried many different combinations and everything worked as expected.

As mentioned higher in the thread we changed how do-change-speed is handled as part of SCurves so I think we resolve this problem unknowingly.

Thanks again for the reports and testing.

Thank youfor your time testing it. We will try 4.1 as soon as it bocomes stable and let you know.

thank you!!


1 Like

Useful discussion, thanks, I appreciate that! :+1:

What would be the copter max speed can set?
It can go upto 30m/s?

Servers by jDrones