Servers by jDrones

4.0.6.rc1 Quad shoots into air when switched to AltHold

The quadrotor shoots into the air with full throttle when switched from Stabilize to AltHold or Loiter. Using TFMini lidar indoor without GPS on a Holybro Kakute F7.

Logs
https://drive.google.com/file/d/1YiMtv_jK7PZo-0LnQXtjZay-OFNNc5YN/view?usp=sharing

It seems like the altitude value is shooting to -150.

Hi, do you have the bin file? And before you takeoff did you get correct reading from lidar?

I took off manually and automatically with correct values (both same behavior).

Here’s the bin file: https://drive.google.com/file/d/1YiMtv_jK7PZo-0LnQXtjZay-OFNNc5YN/view?usp=sharing

I did a quick check on your log and it’s pretty odd when you switched to alt hold and the desired altitude went all the way to - 150. Can I have the param file? Also did you try alt hold without lidar?
And is your lidar somehow blocked by your landing gear? Even a little bit

Yup, I did (just with the baro, same result). Here’s the param file: https://drive.google.com/file/d/1xdl7CwgyhFyHZdc7XAqOqjqwLj7bbSdT/view?usp=sharing

The Lidar isn’t blocked by the landing gear.

i noticed you set arming check as 0. and thats the problem. you are ignoring all arming check and then there is definitely an error. please put back all arming check and see whats the error before arming.
also what type of esc are you using’? I noticed you set your pwm type as dshot 500

It’s a holybro tekko 32 4 in 1 esc. I’ll add the arming check back.

Hi Nitin,

It looks like your IMU is dead. The barometer and rangefinder altitude measurements consistent with each other. While hovering in STABILIZE mode, IMU Z-axis accelerometer measurements are kinematically inconsistent with respect to the throttle output and barometer-rangefinder height measurement.

Desired altitude supposed to be the vehicle’s current altitude the moment you switch to ALTHOLD. So, It is expected for the desired altitude to jump to the -29 meter for this case. EKF clear out wrong altitude estimation while hovering, but it didn’t really help.

Raw IMU measurement logging is enabled. This shows that there is too much noise in Accelorementer.


I suggest you to not perform any flight that requires altitude estimation. Perform further flight in STABILIZE mode and check the log for altitude estimation innovation. If you had an accident with this frame, I first suggest you change the motors to see if the vibration is reduced. If this does not help you might have to replace the flight controller.

I also suggest you take look at the following forum post with a similar problem.


Thanks a ton everyone! We solved the issue by soft mounting the flight controller (which I thought wasn’t needed since Kakute F7 IMU is already soft mounted). It was definitely an issue with the vibrations!

Glad it is solved. Which soft mounting did you decide to use? Can you also share the flight logs using soft mounting with RAW IMU logging enabled?

These ones: https://www.amazon.com/uxcell-Vibration-Rubber-Fright-Controller/dp/B082ZNZK3Z
I’ll post the logs in sometime :slight_smile:

TL;DR version:
Vibration mounts (https://www.amazon.com/uxcell-Vibration-Rubber-Fright-Controller/dp/B082ZNZK3Z) make the Loiter stable for T-Motor F20 II motors but not the EMAX RS1106 II motors.

Here’s a detailed analysis of the situation.
I tested with 2 different quadrotors (same firmware and config expect gains and ESC).
First quad has T-Motor F20 II 2800KV motors mated to 3x3x4 props and a Lumenier 4in1 35A ESC. Photos are shown below:


Second quad has EMAX RS1106 II 6000KV motors mated to 2540x3 props and an HGLRC 4in1 35A ESC. Photos are shown below:

Both quads were tested on firmware from 4.0.3 to 4.0.6rc1 and give the same results.
Both use TFMini lidar and FPV Optical flow sensor (CX-OF) for indoor (in a netted area) Loiter.

Here are the vibration results (logs).

  1. T-Motor F20 II quad with no soft mount: https://drive.google.com/file/d/1dPMwFO7artCSUmRer804Wh3l4AHhSYqz/view?usp=sharing
  2. T-Motor F20 II quad with soft mount: https://drive.google.com/file/d/13o4UVYEKz-D36xtbLOw4MlShbYY_L_2A/view?usp=sharing
  3. EMAX RS1106 II quad with no soft mount: https://drive.google.com/file/d/1QRTMJWyGGTmpmMTOyffyJStyCYgRTjbQ/view?usp=sharing
  4. EMAX RS1106 II quad with soft mount: https://drive.google.com/file/d/1s_L8WFErJylnQEee43poVEQMzrJ3-PHe/view?usp=sharing

Hope this helps someone with the same issue.

Thanks for the log file Nitin,

It seems the file name for T-Motor F20 logs is mixed. Good to see this much of vibration difference with the soft mounting.

1 Like

Some more tests:
I also tested out a few more vibration isolation methods.

  1. Kyosho Foam which can be purchased from Amazon.com: Kyosho Z8006 Zeal Vibration Absorption Sheet: Toys & Games. I used 2 layers for vibration isolation. It does not work on the F20II setup. Photo is shown below:

    Logs are here: https://drive.google.com/file/d/1XB0xoKYEdOuyDKl38JCb9vza7zpuRBbE/view?usp=sharing
  2. mRo vibration isolation foam which can be purchased from mRo Damping Foams (mrobotics.io). It does not work on the F20II setup. Logs are here: https://drive.google.com/file/d/1wY0pHPPjTZIfhmvC8nr6eR7cGAyL2ZyD/view?usp=sharing
  3. Flight soft mounting screws which can be purchased from Amazon.com: iFlight 12PCS M3X7+4.5 Anti-Vibration Fixed Screws Mounting Hardware Spacer Standoff RC Screws kit with 12PCS M3 Nylon Hex Nut for Naze32 CC3D F3 F4 Flight Controller FPV Racer: Industrial & Scientific and this works like a charm and I get perfect loiter. A photo of this is shown below: .
    Logs can be found here https://drive.google.com/file/d/1e-7ymGb5xL42VdXJBiSkeqldLuMidkFv/view?usp=sharing

Looks OK. Now configure the Dynamic Notch filter.

I have found the soft rubber grommets supplied with some small form factor boards (Kakute F7 Mini) work very well.

1 Like

If I am not mistaken, the dynamic notch filter only works for Gyro right and not the accelerometer values?

yes you are correct.

1 Like

So then it shouldn’t do much to the acc vibration right? Even though they might be coupled from EKF state.

That’s right, nothing. The value is filtering the Gyro raw output before it reaches the control loop. I had a 3" quad that was tuned beautifully after enabling the Dynamic Notch. Disable it after this tune and it was unflyable. There are numerous examples of that posted here.

2 Likes
Servers by jDrones