30KM 1080p 60fps 150ms - SIYI HM30 Full HD Digital Video Link Telemetry Radio System

As you see there is no open discussion here for A2 mini and we do not plan to start one for this model. Please send an email to support@siyi.biz to discuss.

Even me is not 24/7 for any kinds of issues.

I can tell you I’m using full UDP with the daily version of QGroundControl with no issues. Both Video and Telemetry are coming over my LAN connection. Can you help with how you have it setup? What is your Static IP set to? Do you have a router between? I used it daily for a solid 2 months with no issues after working out the intial setup problems.

2 Likes

I have been able to get UDP to work on Qgroundcontrol. What sort of issues are you seeing?

1 Like

Hi Jeff,

I was simply unable to get mission planner or q ground control to connect via udp. Video was fine.

Connecting direct into laptop without router or switch.

The documentation is a little ambiguous. Are you able to share what fixed ip you have given your LAN interface? Also what ip and port number you are connecting to with UDP. I will try again tomorow.

The PC that is connected to the “LAN” port on the Ground Unit HAS to have an static IP of 192.168.144.20 and the gateway HAS to be set to 192.168.144.12. The Air Unit ONLY sends UDP traffic to 192.168.144.20. If you don’t have that IP set you will not receive the mavlink UDP traffic. The video working has nothing to do with this but does at least show that traffic is passing over your radio link. (Because the video is RTSP, the ground station is actually requesting the video vs the Mavlink UDP which is being sent from the Air Unit all the time regardless of the ground unit state)

You have to kind of think of this network like 2 seperate networks with a gateway between them.

If you need the mavlink telemetry to go to multiple locations- you will have to setup a Mavlink forwarder from inside Qgroundcontrol. Otherwise you would have to use a Mavlink Router.

Edit: The only thing I can think of that might be different- if this doesn’t work for you- is that I have a router between my Ground Unit and my PC so that I can use my own WIFI and not be tethered to the ground unit. That might be why mine is working if you have tried the above.

4 Likes

Video OK Jeff, no telemetry at all. Settings as in manual.
I see the data coming in with Wireshark.

1 Like

Hi Jeff,

Thank you for confirming those settings. I am using exactly the same settings.

I get an initial connection with mission planner/QGC but it gets stuck downloading parameters as before. We see this with other telem systems where there is a high packet loss or slow data-rate.

Interesting that you are getting this to work with a router in the loop -

Have you done any port forwarding or specific config in your router? I just tried it with a router and get the same issue.

Hi to all!
I did manage to install the SIYI app and seem to have managed to connect my Android phone to the receiver / transmitter.
Yet I have a stupid issue which blocks me :


Hase anyone seen this before ?

I’ll try QGC in the meantime.
Best to all

Hi again
I managed to install QGC and find the HM30 via bluetooth but then no connections sets up.
I feel a liitle bit dumb :slightly_smiling_face:
Thanks for your help

Go to Android settings then apps then siyi FPV app then set the permissions

1 Like

Thanks a lot ! I managed to stop this pop up thanks to your support!

Now I am connected, and managed to enter the proper camera adress… but it says it is disconnected… and I have no image…

Behind “26” it should be “:” instead of “.”

1 Like

THANK YOU !

Now connecting the Taranis to the HM30 via SBUS.
I keep you guys posted
Thanks again for the support !
Stephan

I just randomly came across this thread and thought as an amateur radio guy I can shed some light on this.

When placing antennas of the same frequency and especially transmitter you want them to be at minimum 1/4 wavelength apart, the more separation the better. 1 wavelength is preferable especially at higher frequencies. The more omnidirectional the antenna, the more separation you want. This is because at 1/4 wavelength and less they will essentially work together/couple (and if not used with a matching network, will reduce the efficacy). So with antennas at 1/4 wavelength and parallel, like | |, they will become directional and radiate more like this: <-| |-> (more like one infinity symbol instead of two circles).

A lot of people like to have these omnidirectional vertical/dipole antennas at those 90 degree rotations because if they are close and parallel they may create that slight infinity symbol or oval pattern which makes them slightly directional. The rotation on a horizontal plane makes them work better when using a different polarization antenna to receive, i.e. using dipole antennas on VTX and RHCP on VRX. Realistically though if using a patch antenna or helical antenna it won’t matter much, so better to focus on proper placement to reduce obstruction by the body of the aircraft and have best separation.

Best would be wingtips for each antenna or nose and tail for each antenna, but then depending on distance from VTX you are introducing losses with all the extra cable. Realistically if you can get 6+cm separation, preferably 10-12cm, and best reduce obstruction from body of the craft while in the air, you will be good.

3 Likes

hi, tell me what the problem may be, the airspeed freezes on the application screen, for example, it may hang on the number 20 or 40, it may even show 0, I thought the airspeed sensor was not working, but I looked at the MP on the computer, it shows correctly there.


I would look at your fc setup and telemetry wiring. I had the same issue with downloading and it’s because one of my cables wasn’t properly attached. It was able to receive data…but not send data. Sounds like the same problem. QGC needs to be able to send some data to request parameters…sounds like that isn’t working. If you are receiving wireshark data…this is the next thing I would look at. (That and your gateway address)

1 Like

Here is how I have my HM30 setup for my Robotics Drone I’m working on: openSAR.net indoor sUAS 0.1 - YouTube

1 Like

Hello! How about UDP connection to MP?
I see a lot of time has passed and you still haven’t solved the problem. Maybe it was possible to make a custom MP? I bought this for LAN connection and I’m not comfortable with QGC. How can I connect telemetry if GU is 30 meters away from me? No way? I can’t use BT or Wi/Fi in this case. Why specify the ability to connect UDP if it does not work. More precisely, it works in one direction (with MP), it receives data from the AU but does not send them in any way. When will this issue be resolved?

1 Like

Hi all!
I would like to clarify whether the HM30 supports encryption?
if yes, what type?(AES etc)
Thank you

I am having the same issue.

@Jeff-openSAR.net says he has got telemetry to work via UDP but I can not replicate his success.

We know the HM30 is getting telemetry - I can send/recieve via USB connection to HM30.
I know the LAN connction is working because I can get video from HM30.
I can connect to the telemetry via LAN but it is only a one way connection as you describe.

We conclude that this is an issue within the HM30 firmware and await a fix.

Maybe I am missing something. Can anyone else confirm that they can get full bidirectional telemetry over UDP?