Servers by jDrones

3.6.4 Flowhold -> No such mode - Cheerson CX-OF


(Dre Selen) #1

After enabling Flowhold, switching to flowhold in flight, message “No such mode”
Probably because of unhealty flow sensor (Cheerson CX-OF )?

How to debug?

Logfile here


(rmackay9) #2

I think what’s happened is the flight controller being used suffers from the 1MB limit so Mission Planner is loading the fmuv2 firmware instead of fmuv3. If you manually download the fmuv3 firmware and then use the “Upload Custom Firmware” to load it to the flight controller it will probably work.

I’ll have a chat with the other devs on the weekly dev call about this.


(Dre Selen) #3

TY, worked. Unable to test in flight though because of weather and busy calendar.

Topic can be closed.


(Hari .P) #4

Me too was facing the fmuv2 problem. Now solved.
Got the cheerson CX-OF yesterday, all settings done as per Wiki. But it wobbles a lot in roll & pitch axis. If I move the quad in flight [roll or pitch] the wobbling reduces. When it holds the position, it starts to wobble again.
what settings should I look into to get it stable.


(Dre Selen) #6

I had the same issue. Created a new topic, to keep the board more tydi.
View it here;


(Hari .P) #7

Another thing I observed is, when Flow enabled, in Althold, Loiter, Poshold , there is a large dip in altitude when stopping. Only baro (no rangefinder).
If optical flow is disabled, it flies ok. (change in altitude is 1 or 2 feet)
Is a lidar necessary ?.


(rmackay9) #8

@ambattuhari, there shouldn’t be a need for a lidar to use FlowHold. It is required to use optical flow in place of GPS for other modes (Loiter, PosHold, Guided, RTL, Auto, etc)